Package Details: gnome-browser-connector 42.1-3

Git Clone URL: https://aur.archlinux.org/gnome-browser-connector.git (read-only, click to copy)
Package Base: gnome-browser-connector
Description: Native browser connector for integration with extensions.gnome.org
Upstream URL: https://wiki.gnome.org/Projects/GnomeShellIntegration
Licenses: GPL3
Conflicts: chrome-gnome-shell, gs-chrome-connector
Provides: chrome-gnome-shell
Replaces: chrome-gnome-shell, gs-chrome-connector
Submitter: rafaelff
Maintainer: rafaelff
Last Packager: rafaelff
Votes: 95
Popularity: 5.51
First Submitted: 2022-07-13 15:17 (UTC)
Last Updated: 2022-09-19 03:40 (UTC)

Pinned Comments

rafaelff commented on 2022-08-09 13:00 (UTC)

This package provides only the native host messaging connector that integrates with GNOME Shell and the corresponding extensions repository https://extensions.gnome.org

You also need to install the extension for your web browser. Find below URL for the extension/add-on for the supported browsers:

Opera is not supported. See Installation for this and more info.

Latest Comments

1 2 3 4 5 Next › Last »

rafaelff commented on 2022-09-22 16:07 (UTC)

@florianstascheck: Clean your local clone/checkout. See my comment from day 2022-09-16 below.

florianstascheck commented on 2022-09-22 15:23 (UTC)

I can't install 42.1-3, trying to install it with yay fails with this error message:

==> Making package: gnome-browser-connector 42.1-3 (fim 22.sep 2022, 15:20:10)
==> Retrieving sources...
==> ERROR: /home/.../.cache/yay/gnome-browser-connector/gnome-browser-connector is not a clone of https://gitlab.gnome.org/GNOME/gnome-browser-connector.git
    Aborting...

Eisenvaddi commented on 2022-09-21 21:00 (UTC)

I don't know what's going on but since today I can't install any extension. All buttons are gray.

rafaelff commented on 2022-09-19 02:19 (UTC)

@KCGD Understood. Then you confirmed my assumption that your personal Python 3 installation has preference in PATH environment variable, instead of Arch's python package which lands binaries in /usr/bin/.

Please let me know if the fix I applied in this last package release solves or not the issue you were having.

KCGD commented on 2022-09-19 02:14 (UTC)

@rafaelff It returned /home/b/anaconda3/bin/python3 for me (specifically 3.9.12). I made sure to install the aforementioned packages in my base environment

rafaelff commented on 2022-09-19 01:57 (UTC)

As of 42.1-2, build should explicitly look for /usr/bin/python3, instead of any other python3 binary in your PATH environment variable. Let me know if any other problem is presented.

rafaelff commented on 2022-09-18 23:04 (UTC)

@8xen8: Need more information.

8xen8 commented on 2022-09-18 22:47 (UTC)

error: packages failed to build: gnome-browser-connector-42.1-1

rafaelff commented on 2022-09-17 01:02 (UTC)

@KCGD: searching for python3 binary in your system, gives what path? For instance:

$ which python3
/usr/bin/python3

KCGD commented on 2022-09-17 00:37 (UTC)

The most recent release of this package (42.1-1) fails to build locally.

gnome-browser-connector/meson.build:16:0: ERROR: python3 is missing modules: gi

This can be fixed by installing pygobject through pip or conda