Package Details: gnome-builder-git 42.alpha1+10+gc550764ec-1

Git Clone URL: https://aur.archlinux.org/gnome-builder-git.git (read-only, click to copy)
Package Base: gnome-builder-git
Description: An IDE for writing GNOME-based software
Upstream URL: https://wiki.gnome.org/Apps/Builder
Licenses: GPL3
Conflicts: gnome-builder
Provides: gnome-builder
Submitter: blackout24
Maintainer: swiftscythe
Last Packager: swiftscythe
Votes: 10
Popularity: 0.000000
First Submitted: 2014-07-31 15:10 (UTC)
Last Updated: 2022-01-09 20:02 (UTC)

Latest Comments

1 2 3 4 Next › Last »

tasali commented on 2022-01-18 13:21 (UTC) (edited on 2022-01-18 13:25 (UTC) by tasali)

The project now depends on these packages (with its existing configuration)

Runtime deps: jsonrpc-glib -> jsonrpc-glib-git for 3.41.0 (probably temporary), libportal-gtk3 (new) and libhandy-git (1.5.0)

Build time deps: gi-docgen (new), python-sphinx_rtd_theme (as it was removed from sphinx 6.0 and builds fail without it)

tasali commented on 2021-10-12 15:22 (UTC)

For now libdazzle-git can be switched back to libdazzle. Also, cmark should be added as a new dependency.

fisch02 commented on 2020-03-04 17:37 (UTC) (edited on 2020-03-09 16:49 (UTC) by fisch02)

Package should now depend on sysprof-git instead of sysprof2-git. Why is there a sysprof dependency besides sysprof-git?

fisch02 commented on 2020-02-08 14:11 (UTC)

Add libportal dependency

trougnouf commented on 2019-03-26 13:06 (UTC) (edited on 2019-03-26 13:10 (UTC) by trougnouf)

meson.build:1:0: ERROR: Meson version is 0.49.2 but project requires >= 0.50.0. Works with meson-git

imyxh commented on 2018-06-25 22:01 (UTC)

It appears that there are at least two new dependencies: gtksourceview4 and sysprof2-git.

vanyasem commented on 2018-06-06 19:09 (UTC) (edited on 2018-06-07 13:47 (UTC) by vanyasem)

Thank you. Will fix it asap. Update: fixed

imyxh commented on 2018-06-06 02:06 (UTC) (edited on 2018-06-06 02:08 (UTC) by imyxh)

I get this error while building:

==> Starting prepare()...
patching file plugins/spellcheck/meson.build  
Reversed (or previously applied) patch detected!  Skipping patch.  
1 out of 1 hunk ignored -- saving rejects to file plugins/spellcheck  
/meson.build.rej  
==> ERROR: A failure occurred in prepare().  
Aborting...

Modifying the PKGBUILD to forget the patch worked for me.

Salamandar commented on 2017-07-26 09:27 (UTC)

Please set either gtk3 or gtk4-git as a dependency !

lubosz commented on 2015-07-13 15:53 (UTC)

requires libpeas-git