Package Details: gnome-calendar-linuxmint 41.2-1

Git Clone URL: https://aur.archlinux.org/gnome-calendar-linuxmint.git (read-only, click to copy)
Package Base: gnome-calendar-linuxmint
Description: Simple and beautiful calendar application designed to perfectly fit the GNOME desktop. (Package from Linux Mint repos)
Upstream URL: http://packages.linuxmint.com/pool/upstream/g/gnome-calendar
Keywords: calendar cinnamon cinnamon-calendar gnome-calendar-linuxmint linuxmint
Licenses: GPL
Conflicts: gnome-calendar
Provides: gnome-calendar
Submitter: Sam-Burgos
Maintainer: Sam-Burgos
Last Packager: Sam-Burgos
Votes: 2
Popularity: 0.000000
First Submitted: 2018-05-15 18:39 (UTC)
Last Updated: 2022-06-28 17:49 (UTC)

Pinned Comments

Sam-Burgos commented on 2018-05-15 18:59 (UTC) (edited on 2022-06-28 17:25 (UTC) by Sam-Burgos)

A couple of things related to this package:

  • This app is the same gnome-calendar, but with some patches applied from Linux Mint in order to make it compatible with Cinnamon (since now it supports the Gnome Online Accounts module), also this is a release taken directly from the Linux Mint repos instead of upstream, so before giving any comments or out-of-date notice, please check the new upstream repository since this is intended mainly for Cinnamon

  • Because of previous point, this patched version of gnome-calendar may be supported only on Cinnamon because of the nature of the patches applied (and thus the older dependencies compared to upstream GNOME), if you wish to use it on other GTK desktop environments you need to remove the Cinnamon/GNOME dependencies mainly; although you need to check if there won't be additional issues of pulling additional non-wanted packages for your particular DE due to the GNOME components (like gnome-control-center, evolution-data-server and the other libraries with it that GNOME already has; and cinnamon-settings combined with gnome-online-acounts in the case of Cinnamon). If you are unable to remove non-required GTK dependencies, then you can use any other program that you consider that may suite your needs.

  • This package is intended to be used only on Cinnamon due to being the last release that doesn't require the new libadwaita library and this particular version no longer works on GNOME properly because of the Linux Mint patches (it may work with the current releases of GNOME but due to GNOME programs requiring other/additional libraries, like libadwaita and GTK4, I cannot guarantee if something works or not on GNOME after installing due to this), in case it doesn't work and you wish to use the calendar on GNOME please use the package provided upstream.

  • Before giving an out-of-date notice, please check the package on Linux Mint repositories, since this particular version of gnome-calendar will depend on what Linux Mint provides on their repositories, also since this version will no longer be the same as upstream gnome-calendar, the comparison between upstream and this version no longer applies and please do not give out-of-date based on that.

  • Any problems or bugs related to this particular version, you can report it to Linux Mint developers on their respective communication channels, otherwise if the issue is with packaging you can report it here. Other issues you may need to check with upstream GNOME if these may be solved on newer versions

Latest Comments

sToRmInG commented on 2022-02-04 06:30 (UTC)

@florax This is fixed but not yet released: https://gitlab.gnome.org/GNOME/gnome-calendar/-/commit/e35dbc1acd03dd1751b755b6c8e1932a692ad4e1

florax commented on 2022-01-18 17:59 (UTC)

Won't build, tail of meson-log.txt:

Library m found: YES
Configuring org.gnome.Calendar.appdata.xml.in using configuration

gnome-calendar/data/appdata/meson.build:3:0: ERROR: Function does not take positional arguments.

zc0rp10 commented on 2020-10-19 21:23 (UTC)

Required libhandy0 specifically to build.

Sam-Burgos commented on 2018-09-22 04:42 (UTC)

@yochananmarqos: check if the upgrade to 3.30.0 from the gnome-calendar should help you, some of the options changed (probably related to its dependencies) and maybe that was the reason you weren't able to build it

yochananmarqos commented on 2018-09-19 16:36 (UTC)

I'm not able to build it:

Log of Meson test suite run on 2018-09-19T10:30:04.422699

Inherited environment: LC_MEASUREMENT='en_US.UTF-8' LC_PAPER='en_US.UTF-8' LC_MONETARY='en_US.UTF-8' LANG='en_US.UTF-8' DISPLAY=':0' OLDPWD='/tmp/makepkg/gnome-calendar-linuxmint/src' COMMAND_MODE='legacy' EDITOR='/usr/bin/nano' GTK_OVERLAY_SCROLLING='1' MOZ_PLUGIN_PATH='/usr/lib/mozilla/plugins' CFLAGS='-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt' XDG_VTNR='7' SSH_AUTH_SOCK='/run/user/1000/keyring/ssh' LC_NAME='en_US.UTF-8' XDG_SESSION_ID='2' XDG_GREETER_DATA_DIR='/var/lib/lightdm-data/yochanan' USER='yochanan' CXXFLAGS='-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt' DESKTOP_SESSION='cinnamon' TEXTDOMAINDIR='/usr/share/locale' GTK2_RC_FILES='/home/yochanan/.gtkrc-2.0' QT_QPA_PLATFORMTHEME='qt5ct' PWD='/tmp/makepkg/gnome-calendar-linuxmint/src/build' HOME='/home/yochanan' TEXTDOMAIN='pacman-scripts' XDG_SESSION_TYPE='x11' XDG_SESSION_DESKTOP='cinnamon' LC_ADDRESS='en_US.UTF-8' LC_NUMERIC='en_US.UTF-8' GTK_MODULES='canberra-gtk-module' MAIL='/var/spool/mail/yochanan' CHOST='x86_64-pc-linux-gnu' SHELL='/bin/bash' XDG_SEAT_PATH='/org/freedesktop/DisplayManager/Seat0' XDG_CURRENT_DESKTOP='X-Cinnamon' XDG_SEAT='seat0' SHLVL='2' CPPFLAGS='-D_FORTIFY_SOURCE=2' SOURCE_DATE_EPOCH='1537374545' LC_TELEPHONE='en_US.UTF-8' GDK_BACKEND='x11' GDMSESSION='cinnamon' GNOME_DESKTOP_SESSION_ID='this-is-deprecated' LOGNAME='yochanan' DBUS_SESSION_BUS_ADDRESS='unix:path=/run/user/1000/bus' XDG_RUNTIME_DIR='/run/user/1000' XAUTHORITY='/home/yochanan/.Xauthority' LDFLAGS='-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now' XDG_SESSION_PATH='/org/freedesktop/DisplayManager/Session0' PATH='/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl' LC_IDENTIFICATION='en_US.UTF-8' MAKEFLAGS='-j4' SESSION_MANAGER='local/pavilion:@/tmp/.ICE-unix/1349,unix/pavilion:/tmp/.ICE-unix/1349' LC_TIME='en_US.UTF-8' _='/usr/bin/meson' 

1/2 test-event                              FAIL     0.01 s (exit status 1)

--- command ---
G_TEST_SRCDIR='/tmp/makepkg/gnome-calendar-linuxmint/src/gnome-calendar/tests' G_TEST_BUILDDIR='/tmp/makepkg/gnome-calendar-linuxmint/src/build/tests' MALLOC_CHECK_='2' GSETTINGS_SCHEMA_DIR='/tmp/makepkg/gnome-calendar-linuxmint/src/build/data' GSETTINGS_BACKEND='memory' /tmp/makepkg/gnome-calendar-linuxmint/src/build/tests/test-event
--- stderr ---
Tests were compiled with G_DISABLE_ASSERT and are likely no-ops. Aborting.
-------

2/2 test-manager                            FAIL     0.01 s (exit status 1)

--- command ---
G_TEST_SRCDIR='/tmp/makepkg/gnome-calendar-linuxmint/src/gnome-calendar/tests' G_TEST_BUILDDIR='/tmp/makepkg/gnome-calendar-linuxmint/src/build/tests' MALLOC_CHECK_='2' GSETTINGS_SCHEMA_DIR='/tmp/makepkg/gnome-calendar-linuxmint/src/build/data' GSETTINGS_BACKEND='memory' /tmp/makepkg/gnome-calendar-linuxmint/src/build/tests/test-manager
--- stderr ---
Tests were compiled with G_DISABLE_ASSERT and are likely no-ops. Aborting.
-------


OK:         0
FAIL:       2
SKIP:       0
TIMEOUT:    0

Sam-Burgos commented on 2018-05-15 18:59 (UTC) (edited on 2022-06-28 17:25 (UTC) by Sam-Burgos)

A couple of things related to this package:

  • This app is the same gnome-calendar, but with some patches applied from Linux Mint in order to make it compatible with Cinnamon (since now it supports the Gnome Online Accounts module), also this is a release taken directly from the Linux Mint repos instead of upstream, so before giving any comments or out-of-date notice, please check the new upstream repository since this is intended mainly for Cinnamon

  • Because of previous point, this patched version of gnome-calendar may be supported only on Cinnamon because of the nature of the patches applied (and thus the older dependencies compared to upstream GNOME), if you wish to use it on other GTK desktop environments you need to remove the Cinnamon/GNOME dependencies mainly; although you need to check if there won't be additional issues of pulling additional non-wanted packages for your particular DE due to the GNOME components (like gnome-control-center, evolution-data-server and the other libraries with it that GNOME already has; and cinnamon-settings combined with gnome-online-acounts in the case of Cinnamon). If you are unable to remove non-required GTK dependencies, then you can use any other program that you consider that may suite your needs.

  • This package is intended to be used only on Cinnamon due to being the last release that doesn't require the new libadwaita library and this particular version no longer works on GNOME properly because of the Linux Mint patches (it may work with the current releases of GNOME but due to GNOME programs requiring other/additional libraries, like libadwaita and GTK4, I cannot guarantee if something works or not on GNOME after installing due to this), in case it doesn't work and you wish to use the calendar on GNOME please use the package provided upstream.

  • Before giving an out-of-date notice, please check the package on Linux Mint repositories, since this particular version of gnome-calendar will depend on what Linux Mint provides on their repositories, also since this version will no longer be the same as upstream gnome-calendar, the comparison between upstream and this version no longer applies and please do not give out-of-date based on that.

  • Any problems or bugs related to this particular version, you can report it to Linux Mint developers on their respective communication channels, otherwise if the issue is with packaging you can report it here. Other issues you may need to check with upstream GNOME if these may be solved on newer versions