Package Details: gnome-calls 46.0-3

Git Clone URL: https://aur.archlinux.org/gnome-calls.git (read-only, click to copy)
Package Base: gnome-calls
Description: Phone dialer and call handler
Upstream URL: https://gitlab.gnome.org/GNOME/calls
Licenses: GPL-3.0-or-later
Conflicts: calls
Replaces: calls
Submitter: carsme
Maintainer: carsme
Last Packager: carsme
Votes: 8
Popularity: 0.38
First Submitted: 2024-04-03 15:16 (UTC)
Last Updated: 2024-04-03 16:12 (UTC)

Latest Comments

1 2 Next › Last »

fabiscafe commented on 2024-04-08 12:51 (UTC)

@aurroot debugedit is part of base-devel. You're expected to have it installed to build things on Arch. That's why there is no explicit need to depend on it..

aurroot commented on 2024-04-08 08:00 (UTC)

Hi! Thank you for providing this package! There is a missing dependency for debugedit. It does not build without debugedit.

fabiscafe commented on 2024-04-03 15:57 (UTC) (edited on 2024-04-04 12:14 (UTC) by fabiscafe)

😅 I'm actually fine with whatever it is called (especially with the binary "gnome-calls")

For the merge, it is probably a good thing to do prior my potential adoption. I wont do that before the python 3.12 rebuild anyways. :)

And for the git history: Thanks!

Edit: I asked upstream for the name and gnome-calls it is. https://gitlab.gnome.org/GNOME/calls/-/issues/631

carsme commented on 2024-04-03 15:44 (UTC)

@fabiscafe Import as much as you like, of course! :)

Regarding the name, I was just about to submit a request to merge it into gnome-calls lol.. It seems like a less generic/ambiguous name while being consistent with other packages in [extra]:

$ pacman -Ss gnome | grep 'extra/gnome'
...
extra/gnome-calculator 46.0-1 (gnome)
extra/gnome-calendar 46.0-2 (gnome)
extra/gnome-characters 46.0-1 (gnome)
extra/gnome-chess 46.0-1 (gnome-extra)
extra/gnome-clocks 46.0-1 (gnome)
extra/gnome-color-manager 3.36.0+r51+gcf7ee2b5-1 (gnome)

fabiscafe commented on 2024-04-03 15:36 (UTC)

@dreieck Usually the package name is set to reflect the name of the source. be it a tarball[0] or a git repo[1].


@carsme In case you read this. I'd like to import calls in Arch directly (not 100% certain yet). If that's going to happen, would you be OK if I import your AUR git, including the whole history or would you like me to start fresh?

dreieck commented on 2024-01-12 12:27 (UTC)

Actually, this is "gnome-calls". Can you rename this package to gnome-calls please (and for backwards compatibility add calls=${pkgver} to the provides array and calls<=45.0 to the replaces and conflicts arrays, please)?

If it really should be named calls, can you add gnome-calls=${pkgver} to the provides array and gnome-calls to the conflicts array, please?

Regards!

Kunda commented on 2023-10-18 15:58 (UTC)

Please bump to 45.0 (https://gitlab.gnome.org/GNOME/calls/-/tags/v45.0)

Sematre commented on 2022-12-15 09:50 (UTC)

This package requires openssl-1.1

robertomorrison commented on 2022-11-25 15:35 (UTC)

python-docutils needed to be added as make dependency for it to build on my machine

flipflop97 commented on 2021-01-25 18:41 (UTC)

callaudiod has been updated and calls hasn't incorporated these changes yet. You can use an older version of callaudiod in the meantime (clone, checkout to previous commit, install).

https://source.puri.sm/Librem5/calls/-/merge_requests/230