Package Details: gnome-defaults-list 3.18.1.2-1

Git Clone URL: https://aur.archlinux.org/gnome-defaults-list.git (read-only)
Package Base: gnome-defaults-list
Description: default file associations for GNOME environment
Upstream URL: http://packages.ubuntu.com/source/gnome-session
Licenses: GPL, LGPL
Submitter: rtimush
Maintainer: ItachiSan
Last Packager: ItachiSan
Votes: 102
Popularity: 1.874586
First Submitted: 2009-01-15 07:56
Last Updated: 2016-05-18 17:11

Latest Comments

ItachiSan commented on 2015-03-22 17:29

To update:
-> ubuntuver: 2ubuntu4
-> md5sum: c4f3267e501465c7352f47a1d8c65727
-> archive extension: tar.xz -> tar.gz

max.bra commented on 2015-02-05 18:00

2ubuntu3
9e13e13b8fbef7e65bc5a56e9c4972ee

andrewchen commented on 2014-09-20 01:04

Please update:
_ubuntuver to 0ubuntu14
md5sum to 47b72ef999e911cfab70435ec1087341

madscience commented on 2014-03-15 07:25

Sorry, corrected pkgrel, should be:

# Maintainer: Daniel Apolinario <dapolinario@gmail.com>
# Contributor: Roman Timushev <romikt@gmail.com>
pkgname=gnome-defaults-list
pkgver=3.9.90
pkgrel=12
pkgdesc="default file associations for GNOME environment"
_ubuntuver=0ubuntu12
arch=('any')
url="http://packages.ubuntu.com/source/trusty/gnome-session"
license=('GPL' 'LGPL')
source=(http://archive.ubuntu.com/ubuntu/pool/main/g/gnome-session/gnome-session_$pkgver-$_ubuntuver.debian.tar.gz)
md5sums=('f69824c58fba41710fd9e42e2735ae2e')

package() {
install -d "$pkgdir/etc/gnome"
install -d "$pkgdir/usr/share/applications"
cp $srcdir/debian/defaults.list $pkgdir/etc/gnome/defaults.list
sed -i "s/openoffice\.org\-//g" $pkgdir/etc/gnome/defaults.list
ln -s "/etc/gnome/defaults.list" "$pkgdir/usr/share/applications/"
}

# vim:set ts=2 sw=2 et:

madscience commented on 2014-03-15 05:41

and now it's:

#Maintainer: Daniel Apolinario <dapolinario@gmail.com>
# Contributor: Roman Timushev <romikt@gmail.com>
pkgname=gnome-defaults-list
pkgver=3.9.90
pkgrel=8
pkgdesc="default file associations for GNOME environment"
_ubuntuver=0ubuntu12
arch=('any')
url="http://packages.ubuntu.com/source/trusty/gnome-session"
license=('GPL' 'LGPL')
source=(http://archive.ubuntu.com/ubuntu/pool/main/g/gnome-session/gnome-session_$pkgver-$_ubuntuver.debian.tar.gz)
md5sums=('f69824c58fba41710fd9e42e2735ae2e')

package() {
install -d "$pkgdir/etc/gnome"
install -d "$pkgdir/usr/share/applications"
cp $srcdir/debian/defaults.list $pkgdir/etc/gnome/defaults.list
sed -i "s/openoffice\.org\-//g" $pkgdir/etc/gnome/defaults.list
ln -s "/etc/gnome/defaults.list" "$pkgdir/usr/share/applications/"
}

# vim:set ts=2 sw=2 et:

morealaz commented on 2014-03-04 07:26

please update!!
change _ubuntuver to 0ubuntu11 and md5sums to 1f31125b1b224538124a68256b900c0f

tuxsavvy commented on 2014-02-24 03:18

ubuntu 7 does not exist anymore on that site however, ubuntu 8 is available. Here is a fixed PKGBUILD:
Maintainer: Daniel Apolinario <dapolinario@gmail.com>
# Contributor: Roman Timushev <romikt@gmail.com>
pkgname=gnome-defaults-list
pkgver=3.9.90
pkgrel=8
pkgdesc="default file associations for GNOME environment"
_ubuntuver=0ubuntu8
arch=('any')
url="http://packages.ubuntu.com/source/trusty/gnome-session"
license=('GPL' 'LGPL')
source=(http://archive.ubuntu.com/ubuntu/pool/main/g/gnome-session/gnome-session_$pkgver-$_ubuntuver.debian.tar.gz)
md5sums=('b41ca6b81ebefed457281dac4d913ae6')

package() {
install -d "$pkgdir/etc/gnome"
install -d "$pkgdir/usr/share/applications"
cp $srcdir/debian/defaults.list $pkgdir/etc/gnome/defaults.list
sed -i "s/openoffice\.org\-//g" $pkgdir/etc/gnome/defaults.list
ln -s "/etc/gnome/defaults.list" "$pkgdir/usr/share/applications/"
}

# vim:set ts=2 sw=2 et:

morealaz commented on 2014-02-09 09:11

source should be
http://archive.ubuntu.com/ubuntu/pool/main/g/gnome-session/gnome-session_3.9.90-0ubuntu6.debian.tar.gz

Jristz commented on 2013-10-15 09:53

'Buntu update it to -ubuntu3 so now this have error

stecco commented on 2013-09-05 14:44

please update:
_ubuntuver=0ubuntu2

md5sums=('18da695fe35aadf6470838e40956f997')

MonkeyWrench32 commented on 2013-03-18 17:09

Source should now be http://archive.ubuntu.com/ubuntu/pool/main/g/gnome-session/gnome-session_3.6.2-0ubuntu4.debian.tar.gz

Jristz commented on 2013-01-03 04:35

ubuntu update to 0ubuntu3
and remove the older, please update

dapolinario commented on 2012-08-11 13:44

We just need a file within the compressed file, so I opted for the smaller version.

Jristz commented on 2012-08-11 11:29

http://archive.ubuntu.com/ubuntu/pool/main/g/gnome-session/gnome-session_3.5.5-0ubuntu1.debian.tar.gz

You never considering using the ,orig in place of the ubuntu patcheted version?

Jristz commented on 2012-07-22 00:18

curl: (22) The requested URL returned error: 404

not work,a and in fact the source not exist

and update to the -0ubuntu3 http://archive.ubuntu.com/ubuntu/pool/main/g/gnome-session/gnome-session_3.5.2-0ubuntu3.debian.tar.gz

Jristz commented on 2012-07-22 00:14

curl: (22) The requested URL returned error: 404

not work,a and in fact the source not exist

Anonymous comment on 2012-07-19 16:58

Please update again.

pkgrel=2
md5sums=('ff0f3f267d01bd20f16a9b30a92cc3b1')

francoism commented on 2012-06-16 20:18

Update:
md5: 326666cd4428355dd26223c49100b1dc
gnome-session_3.5.2-0ubuntu1.debian.tar.gz

Anonymous comment on 2012-04-23 13:15

Updated again...

_ubuntuver=0ubuntu8
md5sums=('9b2bed5a6f95039c253a0d3506720f12')

Anonymous comment on 2012-04-16 01:02

Please update... its giving 404 error.

You can install with this:
_ubuntuver=0ubuntu7
md5sums=('c4ec75424a3d3678c89e2c797374c78c')

TamCore commented on 2011-12-08 21:23

_ubuntuver=0ubuntu4
md5sums=('2475efc6aa30593522fb14c6c0a508e1')

Anonymous comment on 2011-09-26 03:08

@dapolinario
Thanks, that fixed the issue!

dapolinario commented on 2011-09-26 02:53

@kennym:
What is not working? Already updated the package and tested.
The version used has more lines than the version you provided.

dapolinario commented on 2011-09-26 02:52

What is not working? Already updated the package and tested.
The version used has more lines than the version you provided.

Anonymous comment on 2011-09-25 00:42

This is the new PKGBUILD, which works:

# Maintainer: Daniel Apolinario <dapolinario@gmail.con>
# Contributor: Kenny Meyer <knny.myer@gmail.com>
pkgname=gnome-defaults-list
pkgver=0.18
pkgrel=1
pkgdesc="default file associations for GNOME environment"
_ubuntuver=0ubuntu4
arch=('i686' 'x86_64')
url="http://packages.ubuntu.com/source/natty/desktop-file-utils"
license=('GPL' 'LGPL')
source=(http://archive.ubuntu.com/ubuntu/pool/main/d/desktop-file-utils/desktop-file-utils_$pkgver-$_ubuntuver.debian.tar.gz)
md5sums=('2802d8d16887546a49c408a93f92457f')

build() {
install -d "$pkgdir/etc/gnome"
install -d "$pkgdir/usr/share/applications"
cp $srcdir/debian/defaults.list $pkgdir/etc/gnome/defaults.list
ln -s "/etc/gnome/defaults.list" "$pkgdir/usr/share/applications/"
}

Anonymous comment on 2011-09-25 00:26

Seems like the source URL isn't correct anymore:


==> Continue building gnome-defaults-list ? [Y/n]
==> ---------------------------------------------
==>
==> Building and installing package
==> Making package: gnome-defaults-list 3.1.91-2 (Sat Sep 24 20:23:15 PYT 2011)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving Sources...
-> Downloading gnome-session_3.1.91-0ubuntu2.debian.tar.gz...
--2011-09-24 20:23:15-- http://archive.ubuntu.com/ubuntu/pool/main/g/gnome-session/gnome-session_3.1.91-0ubuntu2.debian.tar.gz
Resolving archive.ubuntu.com... 91.189.92.171, 91.189.88.30, 91.189.88.31, ...
Connecting to archive.ubuntu.com|91.189.92.171|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2011-09-24 20:23:21 ERROR 404: Not Found.

==> ERROR: Failure while downloading gnome-session_3.1.91-0ubuntu2.debian.tar.gz
Aborting...
==> ERROR: Makepkg was unable to build gnome-defaults-list.
==> Restart building gnome-defaults-list ? [y/N]
==> --------------------------------------------

dapolinario commented on 2010-11-11 03:01

An alternative version using the file http://packages.ubuntu.com/source/natty/desktop-file-utils.

It is simpler and less MIME Type's.

http://aur.pastebin.com/MjiG4vFx

Wish to choose which version: 2.32.0 (current) 0.17 (update the old version)?

dapolinario commented on 2010-11-11 02:18

I will adopt the package, but do not have much experience in this area. Anything can criticize.

rtimush commented on 2010-11-08 22:04

Disowning the package as I don't use Gnome and cannot test the suggested change (though it seems correct). Please adopt.