Package Details: gnome-firmware-git 3.36.0.r40.g96cc9e4-1

Git Clone URL: https://aur.archlinux.org/gnome-firmware-git.git (read-only, click to copy)
Package Base: gnome-firmware-git
Description: GNOME application to update, reinstall and downgrade firmware on devices supported by fwupd
Upstream URL: https://gitlab.gnome.org/hughsie/gnome-firmware-updater
Keywords: firmware fwupd gnome lvfs
Licenses: GPL2
Conflicts: gnome-firmware, gnome-firmware-updater
Provides: gnome-firmware, gnome-firmware-updater
Replaces: gnome-firmware-updater-git
Submitter: Depau
Maintainer: Depau
Last Packager: Depau
Votes: 8
Popularity: 0.000411
First Submitted: 2019-09-13 18:28 (UTC)
Last Updated: 2021-12-21 17:54 (UTC)

Latest Comments

galvez_65 commented on 2022-04-22 21:36 (UTC)

I had to edit the dependencies adding libadwaita and changing gtk3 to gtk4 for it to compile. I don't know if the other dependencies such as libhandy are still required

yochananmarqos commented on 2021-12-20 23:17 (UTC)

The dependencies have changed:

depends=(fwupd gcab glib2 gtk3 libhandy libjcat libsoup libxmlb systemd)
makedepends=(help2man meson)

Depau commented on 2021-02-20 15:05 (UTC)

Addressed, sorry for the delay.

yochananmarqos commented on 2021-02-11 15:52 (UTC)

appstream isn't required, but may be in the future if tests are added.

systemd is a missing dependency.

Depau commented on 2019-09-13 18:29 (UTC) (edited on 2021-12-21 17:55 (UTC) by Depau)

Added help2man.

Pushed to new package: https://aur.archlinux.org/packages/gnome-firmware-git/

~~Will ask Trusted Users to remove this one. Thank you.~~ (this package's page was merged from another package with another name that I also previously owned)

glitsj16 commented on 2019-09-13 18:07 (UTC)

Upstream changed the name to gnome-firmware: https://blogs.gnome.org/hughsie/2019/09/13/gnome-firmware-3-34-0-release/.

@A.J. That's expected when protocols don't support verification. Instead of greyed-out buttons upstream plans to not showing any buttons in that case (see link above for discussion).

MessedUpHare commented on 2019-09-13 09:56 (UTC)

additional build requirement: help2man

A.J commented on 2019-08-29 12:14 (UTC)

everything is grayed out ?!

FabioLolix commented on 2019-08-28 20:19 (UTC)

Hello, this is missing appstream as makedepends