Package Details: gnome-screenruler 0.9.6-3

Git Clone URL: https://aur.archlinux.org/gnome-screenruler.git (read-only)
Package Base: gnome-screenruler
Description: ScreenRuler lets you measure objects on your screen using six different metrics.
Upstream URL: https://launchpad.net/screenruler
Licenses: GPL
Conflicts: gruler
Submitter: gborzi
Maintainer: lilydjwg
Last Packager: lilydjwg
Votes: 29
Popularity: 2.454670
First Submitted: 2010-02-19 23:50
Last Updated: 2015-07-25 05:00

Dependencies (5)

Required by (0)

Sources (3)

Latest Comments

lilydjwg commented on 2016-01-10 02:05

tomaszgasior: ruby has been updated. ls /usr/lib/ruby/gems/2.2.0/gems and reinstall all ones shown.

tomaszgasior commented on 2016-01-09 13:58

When I try to run gnome-screenruler I encounter error:

/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- gettext (LoadError)
from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/bin/screenruler:25:in `<main>'

Application worked properly before last updates. Where is the problem?

lilydjwg commented on 2015-04-09 05:43

VVS: you need ruby-gettext 3.1.6. I've adopted and updated that.

VVS commented on 2015-04-08 19:04

how to fix this:

$ screenruler
/usr/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require': cannot load such file -- locale/util/memoizable (LoadError)
from /usr/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require'
from /usr/lib/ruby/gems/2.2.0/gems/gettext-2.3.7/lib/gettext/runtime/class_info.rb:3:in `<top (required)>'
from /usr/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require'
from /usr/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require'
from /usr/lib/ruby/gems/2.2.0/gems/gettext-2.3.7/lib/gettext/runtime/textdomain_manager.rb:13:in `<top (required)>'
from /usr/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require'
from /usr/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require'
from /usr/lib/ruby/gems/2.2.0/gems/gettext-2.3.7/lib/gettext.rb:31:in `<top (required)>'
from /usr/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:128:in `require'
from /usr/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:128:in `rescue in require'
from /usr/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:39:in `require'
from /usr/bin/screenruler:25:in `<main>'

lilydjwg commented on 2013-05-22 07:35

I've updated this package :-)

gborzi commented on 2013-04-21 12:49

I've disowned the package.

gborzi commented on 2012-01-08 09:39

I reported the bug upstream and got this answer:

You may have more luck with Ruby 1.8.7.
No effort has gone into porting it to 1.9 yet.

So, I'll stick with 0.89.1.

gborzi commented on 2012-01-07 22:26

I've tried to make a working package for the new version (0.9.6), but I'm still stuck with an error

/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': iconv will be deprecated in the future, use String#encode instead.
/usr/lib/ruby/gems/1.9.1/gems/gettext-2.1.0/lib/gettext/runtime/locale_path.rb:20: Use RbConfig instead of obsolete and deprecated Config.
Loading libraries...
/usr/lib/ruby/gems/1.9.1/gems/gettext-2.1.0/lib/gettext/runtime/class_info.rb:33:in `related_classes_internal': undefined method `split' for nil:NilClass (NoMethodError)
...

When (and if) I'll be able to solve it I'll upload a new PKGBUILD.

Anonymous comment on 2010-10-13 21:17

Thanks a lot, this fixed it.

gborzi commented on 2010-10-07 18:49

You can't find them in AUR because these packages are in community. Use abs to recompile them http://wiki.archlinux.org/index.php/ABS.

All comments