Package Details: gnome-shell-40alfa 1:40.alpha.1.1+228+g829a096ba-1

Git Clone URL: https://aur.archlinux.org/gnome-shell-40alfa.git (read-only, click to copy)
Package Base: gnome-shell-40alfa
Description: Next generation desktop shell
Upstream URL: https://gitlab.gnome.org/GNOME/gnome-shell
Licenses: GPL2
Groups: gnome
Conflicts: gnome-shell
Provides: gnome-shell
Submitter: marcio
Maintainer: marcio
Last Packager: marcio
Votes: 6
Popularity: 3.81
First Submitted: 2021-01-23 02:22
Last Updated: 2021-02-13 02:52

Dependencies (37)

Required by (317)

Sources (1)

Latest Comments

wooque commented on 2021-02-23 23:11

Gnome shell reached beta, so maybe rename package to gnome-shell-40beta, same for mutter

marcio commented on 2021-02-11 14:56

@maniacata I can't compile new glib2-git here at least for two weeks. Gnome shell neither. The version I kept is not updated with the latest development branches, but I can't compile the new ones. Mutter compiles ok, but the new one has runtime bugs, so I have to downgrade :/.

Is glib2-git compiling ok on your systems?

maniacata commented on 2021-02-11 14:46

@wooque @ewout use the latest glib2-git from AUR. e.g.

yay -S aur/glib2-git aur/glib2-docs-git

ewout commented on 2021-02-05 08:39

New glib2-git dependency conflicted with glib2. Force removal of glib2 using # pacman -Rdd glib2 resolved it.

wooque commented on 2021-02-04 23:32

Getting this error mutter/meson.build:101:0: ERROR: Invalid version of dependency, need 'glib-2.0' ['>= 2.67.3'] found '2.66.4'.

ewout commented on 2021-01-31 10:32

@marcio Alternatively only forcing the uninstallation of mutter did the trick here. Shaves a few minutes of having to reinstall gnome-shell.

# pacman -Rdd mutter

Thanks for creating this package, allowing easy testing without VM hassle! :) The UX of the shell is much much more responsive, may Daniel van Vugt and Georges Basile Stavracas Neto be forever blessed for their contributions.

marcio commented on 2021-01-30 16:02

@bluebyt I had this problem here too. I was thinking that as long as I was installing both gnome-shell and mutter, aur helpers will resolve this. But anyway, I worked around this by removing gnome-shell before starting the processes:

# pacman -Rdd gnome-shell
# "aur-helper" -S gnome-shell-40alfa

I will be glad if you have a more clean solution.

bluebyt commented on 2021-01-30 15:38

I get this error: :: mutter-40alfa and mutter are in conflict. Remove mutter? [y/N] error: failed to prepare transaction (could not satisfy dependencies) :: removing mutter breaks dependency 'libmutter-7.so=0-64' required by gnome-shell