Package Details: gnome-shell-extension-activities-config 66-1

Git Clone URL: https://aur.archlinux.org/gnome-shell-extension-activities-config.git (read-only, click to copy)
Package Base: gnome-shell-extension-activities-config
Description: Configure the Activities Button via the Gnome Shell Extension Preferences Tool.
Upstream URL: https://extensions.gnome.org/extension/358/activities-configurator/
Licenses: GPLv2
Submitter: XZS
Maintainer: XZS
Last Packager: XZS
Votes: 21
Popularity: 0.000000
First Submitted: 2014-01-30 15:46 (UTC)
Last Updated: 2018-09-17 15:16 (UTC)

Latest Comments

getzze commented on 2019-03-22 11:17 (UTC) (edited on 2019-04-01 15:36 (UTC) by getzze)

https://gist.github.com/getzze/8c75486b3f44ea22a3fe61a65b1d8ef8

I put a revised version of the PKGBUILD with:

  • .install file removed

  • no gnome-shell version check

  • download again source page to get the version (so the pkgver gets updated correctly)

  • [EDIT] use convenience.js provided by upstream

zfkerr commented on 2019-03-15 14:55 (UTC) (edited on 2019-03-15 14:56 (UTC) by zfkerr)

@XZS hi! Same issue as usually happens when trying to build with the latest GNOME. Maybe you will remove the dependence on a specific gnome-shell release number so that there will never be such issues in the future?

resolving dependencies...
warning: cannot resolve "gnome-shell<3.31", a dependency of "gnome-shell-extension-activities-config"

zfkerr commented on 2018-09-21 00:13 (UTC)

@XZS thank you!

XZS commented on 2018-09-17 15:20 (UTC)

The package should now report to be compatible up to gnome-shell version 3.30 when built anew.

zfkerr commented on 2018-09-12 14:55 (UTC)

This package can not be installed because it requires gnome-shell 3.28 in the PKGBUILD dependencies . The developer of this extension has already officially supported gnome-shell 3.30. Fix it please. Thank you.

zfkerr commented on 2018-04-23 12:25 (UTC)

Can not be installed because it requires gnome-shell 3.27. The developer of this extension has already officially supported gnome-shell 3.28. Fix it please.

lightern commented on 2017-12-26 18:08 (UTC)

I agree, not working anymore (not visible in settings if installed). Using 3.26.2

Taijian commented on 2017-11-04 14:56 (UTC)

OK, for me even manual update does not work (via makepkg -si OR makepkg -s && pacman -U), giving this error message complaining about a gnome shell version mismatch: Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen) :: gnome-shell-extension-activities-config: benötigt gnome-shell<3.25

getzze commented on 2017-10-19 18:50 (UTC)

The .install file is not needed, pacman hooks recompile the schemas automatically

davidgxxl commented on 2017-10-02 15:05 (UTC) (edited on 2017-10-02 22:02 (UTC) by davidgxxl)

Hi! XZS I get this when trying update to this last version. gnome-shell-extension-activities-config package(s) failed to install. ensure package version does not mismatch between .SRCINFO and PKGBUILD ensure package name has a VCS suffix if this is a devel package COMMENT UPDATE: trying manual installation works well. I'm using pacaur helper. I think there is some bug in pacaur when try update this package. Thanks Dominik Fischer for your help!

XZS commented on 2016-11-03 12:20 (UTC)

As previously mentioned, this package updates automatically. So when pacaur shows this message, it means that a new version of activities configurator was released and I did not yet propagate the change to the package. As I use yaourt, I do not know whether pacaur has an option to silence this warning, but if it has, feel free to do so. For now, I updated the package and it should install without any hiccups.

ptkato commented on 2016-07-28 17:00 (UTC)

@XZS, got the same error again when updating.

XZS commented on 2016-07-20 14:12 (UTC)

The PKGBUILD automatically installs the newest available version, even when the package is out of date here in the AUR. This is what most likely happened in your case, @ptkato. Thank you for the notice, I updated to the newest version just now.

ptkato commented on 2016-07-16 02:13 (UTC)

I'm having troubles trying to install with pacaur: :: Installing gnome-shell-extension-activities-config package(s)... :: gnome-shell-extension-activities-config package(s) failed to install. Check .SRCINFO for mismatching data with PKGBUILD. It seems that pkgver from .SRCINFO differs from PKGBUILD, the former is 44 and the latter 46.

orschiro commented on 2015-01-31 10:52 (UTC)

@XZS Thanks for the fix.

XZS commented on 2015-01-29 13:03 (UTC)

The package should work just fine with these differing permissions. They are also fixed for now.

orschiro commented on 2015-01-21 07:29 (UTC)

I get the follow warning on installation: (1/1) installing gnome-shell-extension-activit... [######################] 100% warning: directory permissions differ on /usr/share/glib-2.0/schemas/ filesystem: 755 package: 775 Can this safely be ignored?

XZS commented on 2014-11-04 01:13 (UTC)

Thanks for the note. For future version checksum updates should not be necessary. It now automatically determines and downloads the newest version from extensions.gnome.org.

vinadoros commented on 2014-11-03 14:13 (UTC)

Checksum has changed again (new checksum: 7965fe5d7e43742030406e472ed0b8c5).

XZS commented on 2014-10-07 00:56 (UTC)

The newest version now also supports gnome 3.14.

vinadoros commented on 2014-10-03 20:19 (UTC)

Checksum has changed on the shell extension (the extension has been updated recently). Can we get an update to the md5sum? I think the new one is: d1605ed2ab840312a153dd9eb66b0c74. Thanks.