Package Details: gnome-shell-extension-arch-update 60-1

Git Clone URL: https://aur.archlinux.org/gnome-shell-extension-arch-update.git (read-only, click to copy)
Package Base: gnome-shell-extension-arch-update
Description: Convenient indicator for Arch Linux updates in GNOME Shell.
Upstream URL: https://github.com/RaphaelRochet/arch-update
Keywords: extension gnome-shell notification pacman update
Licenses: GPL3
Conflicts: gnome-shell-extensions-git
Submitter: michiwend
Maintainer: WoefulDerelict
Last Packager: WoefulDerelict
Votes: 75
Popularity: 0.000164
First Submitted: 2016-01-31 14:38 (UTC)
Last Updated: 2024-03-26 22:32 (UTC)

Latest Comments

1 2 3 Next › Last »

system7 commented on 2024-03-24 09:22 (UTC)

If anybody needs the GNOME 46 compatible version, it is exists on Github.

alexheretic commented on 2023-10-10 16:47 (UTC)

@WoefulDerelict v57 is working fine in with current gnome-shell 45. I can help maintain this pkgbuild if that's helpful?

WoefulDerelict commented on 2022-12-29 19:41 (UTC) (edited on 2022-12-29 21:22 (UTC) by WoefulDerelict)

esben: While I agree that it would be convenient if the update feature just worked as part of the default installation there are users who prefer to use other terminals and would find it rather annoying to have this including one they deliberately chose not to install as an unnecessary dependency. Given the only feature affected is the update command and the extension functions properly otherwise, allowing end users to configure the update command to suit their deployment is a far more flexible and accomodating option.

Defaulting to the old GNOME Terminal is an upstream behaviour. If you would like the extension updated so that it defaults to using the new GNOME Console I would suggest raising that issue there; however, as this issue is already documented there along with a work around it appears to be a low priority.

esben commented on 2022-12-29 17:28 (UTC)

Updating fails if gnome-terminal is not installed:

gnome-shell[1467]: error: Execution of “gnome-terminal -- /bin/sh -c "sudo pacman -Syu ; echo Done - Press enter to exit; read _" ” failed:: Command not found

So maybe add gnome-terminal as a dependency.

Note, that default gnome terminal is now gnome-console, and not gnome-terminal, so new installations will easily see this problem.

Of-course, it can be fixed manually using gsettings, but it would be nice if a default installation would not require this.

malacology commented on 2021-11-10 00:18 (UTC)

PKGBUILD v45

# Maintainer: Llewelyn Trahaearn <WoefulDerelict at GMail dot com>
# Contributor: Michael Wendland <dev at michiwend dot com>

pkgname=gnome-shell-extension-arch-update
pkgver=45
pkgrel=1
pkgdesc="Convenient indicator for Arch Linux updates in GNOME Shell."
arch=('any')
url="https://github.com/RaphaelRochet/arch-update"
license=('GPL3')
depends=('fakeroot' 'gnome-shell>=3.18' 'pacman-contrib')
conflicts=('gnome-shell-extensions-git')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
sha512sums=('e10c5462685d7ca79306531c5493faa855f77359901d60bbf4e214e1798d0c680b3fa4b767152f0d77db6bd349d97ee16b665bcc75f0e55fe5186f4a9870e9c7')


package() {
  # Locate the extension.
  cd "$(dirname $(find -name 'metadata.json' -print -quit))"
  _extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
  _destdir="${pkgdir}/usr/share/gnome-shell/extensions/${_extname}"
  # Copy extension files into place.
  find -maxdepth 1 \( -iname '*.js*' -or -iname '*.css' -or -iname '*.ui' \) -exec install -Dm644 -t "${_destdir}" '{}' +
  find -maxdepth 2 \( -iname '*.svg*' \) -exec install -Dm644 -t "${_destdir}/icons" '{}' +
  install -Dm644 prefs.xml "${_destdir}"
  find -name '*.gschema.xml' -exec install -Dm644 -t "${pkgdir}/usr/share/glib-2.0/schemas/" '{}' +
  cd locale
  for locale in */
    do
      install -Dm644 -t "${_destdir}/locale/${locale}/LC_MESSAGES" "${locale}/LC_MESSAGES"/*.mo
    done
}

malacology commented on 2021-11-10 00:01 (UTC)

Gnome 41 is coming, if you don't want to update it, you can disown this package

malacology commented on 2021-06-28 11:37 (UTC)

If you don't have enough time to maintain it, you can add other people as co-maintainers.

Taijian commented on 2021-03-27 12:57 (UTC)

Um, the new update (v40) is only compatible with gnome-shell version 40. Could you please adjust the depends array accordingly, so that people do not accidentially install this update prematurely?

Thank you!

Strykar commented on 2021-02-22 06:50 (UTC)

WoefulDerelict, would you mind hosting a -git version too?

zed123 commented on 2020-10-16 19:21 (UTC)

Can you change conflicts=('gnome-shell-extensions-git') with gnome-shell-extension-arch-update-git?