Package Details: gnome-shell-extension-gamemode-git 5.r19.gf4b5a35-1

Git Clone URL: https://aur.archlinux.org/gnome-shell-extension-gamemode-git.git (read-only, click to copy)
Package Base: gnome-shell-extension-gamemode-git
Description: GNOME Shell extension for Feral Interactive's GameMode
Upstream URL: https://github.com/gicmo/gamemode-extension
Licenses: GPL-2.0-or-later
Conflicts: gnome-shell-extension-gamemode
Provides: gnome-shell-extension-gamemode
Submitter: encounter
Maintainer: yochananmarqos
Last Packager: yochananmarqos
Votes: 7
Popularity: 0.71
First Submitted: 2019-09-26 20:21 (UTC)
Last Updated: 2024-01-20 22:29 (UTC)

Latest Comments

makidoll commented on 2024-02-15 23:16 (UTC)

From fbd6c8fdd4804bbee07d0d360acfa7ffcf0a732b Mon Sep 17 00:00:00 2001
From: Maki <maki@hotmilk.space>
Date: Thu, 15 Feb 2024 18:15:44 -0500
Subject: [PATCH] Use gnome_shell_45 branch

---
 .SRCINFO | 4 ++--
 PKGBUILD | 4 ++--
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/.SRCINFO b/.SRCINFO
index de26757..ea84cb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
 pkgbase = gnome-shell-extension-gamemode-git
    pkgdesc = GNOME Shell extension for Feral Interactive's GameMode
-   pkgver = 5.r19.gf4b5a35
+   pkgver = 5.r27.g8912a17
    pkgrel = 1
    url = https://github.com/gicmo/gamemode-extension
    arch = any
@@ -11,7 +11,7 @@ pkgbase = gnome-shell-extension-gamemode-git
    depends = gnome-shell
    provides = gnome-shell-extension-gamemode
    conflicts = gnome-shell-extension-gamemode
-   source = git+https://github.com/fjsevilla-dev/gamemode-extension.git
+   source = git+https://github.com/fjsevilla-dev/gamemode-extension.git#branch=gnome_shell_45
    sha256sums = SKIP

 pkgname = gnome-shell-extension-gamemode-git
diff --git a/PKGBUILD b/PKGBUILD
index d7c02c9..b8b5e0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Mark Wagie <mark dot wagie at proton dot me>
 # Contributor: Luke Street <luke.street@encounterpc.com>
 pkgname=gnome-shell-extension-gamemode-git
-pkgver=5.r19.gf4b5a35
+pkgver=5.r27.g8912a17
 pkgrel=1
 pkgdesc="GNOME Shell extension for Feral Interactive's GameMode"
 arch=('any')
@@ -12,7 +12,7 @@ makedepends=('meson' 'git')
 provides=("${pkgname%-git}")
 conflicts=("${pkgname%-git}")
 #source=('git+https://github.com/gicmo/gamemode-extension.git')
-source=('git+https://github.com/fjsevilla-dev/gamemode-extension.git')
+source=('git+https://github.com/fjsevilla-dev/gamemode-extension.git#branch=gnome_shell_45')
 sha256sums=('SKIP')

 pkgver() {
-- 
2.43.2

Genstar commented on 2023-10-16 00:54 (UTC)

Since you are using the fjsevilla-dev repo, don't forget to add #branch=gnome_shell_45 to the source.

yochananmarqos commented on 2021-06-10 15:07 (UTC)

@llamajacker: Done.

llamajacker commented on 2021-06-10 13:52 (UTC)

Patch 38 is no longer required (and is breaking the install), as it's been merged.

encounter commented on 2020-03-14 17:19 (UTC)

The PKGBUILD uses the version info specified in https://github.com/gicmo/gamemode-extension/blob/master/metadata.json.in

You can track upstream support for 3.36 here: https://github.com/gicmo/gamemode-extension/issues/20

librewish commented on 2020-03-14 13:56 (UTC)

warning: cannot resolve "gnome-shell<3.35", a dependency of "gnome-shell-extension-gamemode-git" :: The following package cannot be upgraded due to unresolvable dependencies: gnome-shell-extension-gamemode-git

as i am using gnome-shell-performance which is 1:3.36

so please remove that

encounter commented on 2019-12-16 19:23 (UTC)

Thanks, just pushed a fix.

librewish commented on 2019-12-16 17:04 (UTC)

==> Starting pkgver()... ==> ERROR: A failure occurred in pkgver(). Aborting...