Package Details: gnome-shell-extension-system76-power-git 1.2.0.r6.g5253c21-1

Git Clone URL: https://aur.archlinux.org/gnome-shell-extension-system76-power-git.git (read-only, click to copy)
Package Base: gnome-shell-extension-system76-power-git
Description: Gnome shell extension for System76 power management
Upstream URL: https://github.com/pop-os/gnome-shell-extension-system76-power
Licenses: MIT
Submitter: m3thodic
Maintainer: m3thodic
Last Packager: m3thodic
Votes: 4
Popularity: 0.76
First Submitted: 2018-10-04 16:34
Last Updated: 2020-02-22 01:40

Latest Comments

jimbojim commented on 2020-05-22 13:33

It appears as though there is a missing dependency. The build process requires typescript. Please update the dependencies for this package.

jimbojim commented on 2020-05-21 21:53

This package is failing to build for me.

==> Starting pkgver()... ==> Updated version: gnome-shell-extension-system76-power-git 1.2.0.r15.g48f10b3-1 ==> Entering fakeroot environment... ==> Starting package()... UUID is "system76-power@system76.com" rm -rf /home/joliver/Arch/gnome-shell-extension-system76-power-git/pkg/gnome-shell-extension-system76-power-git/usr/share/gnome-shell/extensions/system76-power@system76.com mkdir -p /home/joliver/Arch/gnome-shell-extension-system76-power-git/pkg/gnome-shell-extension-system76-power-git/usr/share/gnome-shell/extensions/system76-power@system76.com cp -r _build/* /home/joliver/Arch/gnome-shell-extension-system76-power-git/pkg/gnome-shell-extension-system76-power-git/usr/share/gnome-shell/extensions/system76-power@system76.com/ cp: cannot stat '_build/*': No such file or directory make: *** [Makefile:60: install] Error 1 ==> ERROR: A failure occurred in package(). Aborting...

jcsanyi commented on 2019-11-06 18:04

For this to work, your user must be a member of the "adm" or "sudo" groups.

See this policy file that's installed as part of system76-power for details: https://github.com/pop-os/system76-power/blob/master/data/system76-power.conf (installed to /usr/share/dbus-1/system.d/system76-power.conf )

m3thodic commented on 2018-12-14 19:44

@shalzz updated, thanks!

shalzz commented on 2018-12-11 07:10

Hi, can you update the depends to depends=('gnome-shell' 'system76-power'). This allows using both system76-power and system76-power-git