Package Details: gnome-shell-extension-window-buttons-git 2.9-1

Git Clone URL: https://aur.archlinux.org/gnome-shell-extension-window-buttons-git.git (read-only)
Package Base: gnome-shell-extension-window-buttons-git
Description: Extension which puts minimize, maximize and close buttons in the top panel.
Upstream URL: https://github.com/danielkza/Gnome-Shell-Window-Buttons-Extension
Licenses: GPL3
Conflicts: gnome-shell-extension-window-buttons
Provides: gnome-shell-extension-window-buttons=2.9
Submitter: pi3r1k
Maintainer: XZS
Last Packager: XZS
Votes: 21
Popularity: 0.000000
First Submitted: 2011-12-07 20:14
Last Updated: 2016-11-03 13:52

Latest Comments

artodeto commented on 2019-02-16 19:23

Can be build.

Dependency not met 'gnome-shell<3.21'

Following the full german console output.

Lade Pakete... Löse Abhängigkeiten auf... Warnung: Kann "gnome-shell<3.21" nicht auflösen (eine Abhängigkeit von "gnome-shell-extension-window-buttons-git") :: Das folgende Paket kann aufgrund nicht auflösbarer Abhängigkeiten nicht aktualisiert werden: gnome-shell-extension-window-buttons-git

:: Möchten Sie das obengenannte Paket bei dieser Aktualisierung überspringen? [j/N] Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen) :: Unerfüllbare Abhängigkeit 'gnome-shell<3.21', benötigt von gnome-shell-extension-window-buttons-git

XZS commented on 2016-06-13 15:25

It should now work with gnome-shell 3.20, though a manual rebuild may be required.

sergey.orloff commented on 2016-04-18 18:13

anaveragehuman commented on 2016-04-15 01:44 (edited on 2016-04-15 01:58 by anaveragehuman)

@XZS and anyone else looking to make it compatible with GNOME 3.20:

I added the following lines to package_02_install():

sed -i.bak "s/3.18/3.18\",\n \"3.20/g" "$pkgdir/usr/share/gnome-shell/extensions/$extname/metadata.json"
sed -i.bak "s/3.18/3.18\",\n \"3.20/g" $(find -path ./pkg -type d -prune -o -name metadata.json)

XZS commented on 2015-11-25 22:14

Indeed you are right. I added the dependency. Thanks for the notice.

gva commented on 2015-11-25 15:39

Looks like this needs gconf to work. Could it be set as a dependence?