Package Details: gnome-terminal-git 3.41.90+29+g9100fd9a-1

Git Clone URL: https://aur.archlinux.org/gnome-terminal-git.git (read-only, click to copy)
Package Base: gnome-terminal-git
Description: The GNOME Terminal Emulator
Upstream URL: https://wiki.gnome.org/Apps/Terminal
Licenses: GPL
Submitter: lubosz
Maintainer: None
Last Packager: fisch02
Votes: 3
Popularity: 0.000000
First Submitted: 2013-02-10 19:18 (UTC)
Last Updated: 2021-09-21 22:43 (UTC)

Latest Comments

lubosz commented on 2021-07-01 19:11 (UTC)

Update:

From eef047f2cb3204c52bf027e0cfdf0d55d3c656a1 Mon Sep 17 00:00:00 2001
From: Lubosz Sarnecki <lubosz@gmail.com>
Date: Thu, 1 Jul 2021 21:10:13 +0200
Subject: [PATCH] Update to 3.39.90.

* Use meson.
* Use updated depenendcies from non-git package.
---
 .SRCINFO | 13 ++++++-------
 PKGBUILD | 28 ++++++++--------------------
 2 files changed, 14 insertions(+), 27 deletions(-)

diff --git a/.SRCINFO b/.SRCINFO
index f21951c..e119f80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,24 @@
 pkgbase = gnome-terminal-git
    pkgdesc = The GNOME Terminal Emulator. Git Version
-   pkgver = 3.37.0.6396.5e7209c4
+   pkgver = 3.39.90+51+g2f391408
    pkgrel = 1
    url = https://www.gnome.org
    arch = i686
    arch = x86_64
    groups = gnome
    license = GPL
-   makedepends = gnome-doc-utils
-   makedepends = intltool
-   makedepends = itstool
    makedepends = docbook-xsl
-   makedepends = appdata-tools
+   makedepends = libnautilus-extension
+   makedepends = gnome-shell
    makedepends = yelp-tools
+   makedepends = git
+   makedepends = meson
    depends = vte3-git
    depends = gsettings-desktop-schemas
-   provides = gnome-terminal=3.37.0.6396.5e7209c4
+   provides = gnome-terminal=3.39.90+51+g2f391408
    conflicts = gnome-terminal
    options = !emptydirs
    source = git+https://gitlab.gnome.org/GNOME/gnome-terminal.git
    md5sums = SKIP

 pkgname = gnome-terminal-git
-
diff --git a/PKGBUILD b/PKGBUILD
index e877105..cb2e9f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@
 _realname=gnome-terminal
 pkgname=$_realname-git

-pkgver=3.37.0.6396.5e7209c4
+pkgver=3.39.90+51+g2f391408
 _realver=3.7.3
 pkgrel=1
 pkgdesc="The GNOME Terminal Emulator. Git Version"
 arch=('i686' 'x86_64')
 license=('GPL')
-depends=('vte3-git' 'gsettings-desktop-schemas')
-makedepends=('gnome-doc-utils' 'intltool' 'itstool' 'docbook-xsl' 'appdata-tools' 'yelp-tools')
+depends=('vte3-git' gsettings-desktop-schemas)
+makedepends=(docbook-xsl libnautilus-extension gnome-shell yelp-tools git meson)
 options=('!emptydirs')
 url="https://www.gnome.org"
 groups=('gnome')
@@ -23,29 +23,17 @@ conflicts=($_realname)
 source=("git+https://gitlab.gnome.org/GNOME/${_realname}.git")
 md5sums=("SKIP")

-subver() {
-  PREFIX="m4_define(\[terminal_version_$1\],\["
-  echo $(grep $PREFIX configure.ac | eval sed "'s/$PREFIX//'" | sed 's/\])//')
-}
-
 pkgver() {
   cd $_realname
-  major=$(subver major)
-  minor=$(subver minor)
-  micro=$(subver micro)
-  hash=$(git log --pretty=format:'%h' -n 1)
-  revision=$(git rev-list --count HEAD)
-  echo $major.$minor.$micro.$revision.$hash
+  git describe --tags | sed 's/-/+/g'
 }

 build() {
-  cd $_realname
-  ./autogen.sh --prefix=/usr --sysconfdir=/etc \
-      --localstatedir=/var --disable-scrollkeeper
-  make
+  rm -rf build
+  arch-meson $_realname build
+  ninja -C build
 }

 package() {
-  cd $_realname
-  make DESTDIR="$pkgdir" install
+  meson install -C build --destdir "$pkgdir"
 }
-- 
2.32.0

TwainDee commented on 2019-12-21 14:17 (UTC) (edited on 2019-12-21 14:18 (UTC) by TwainDee)

Why does this package depend on gconf instead of dconf?

Also given that in the official repositories gnome-terminal depends only on vte3 gsettings-desktop-schemas but this package depends on gconf vte3-git gsettings-desktop-schemas libsm I don't see why gconf would be necessary.

jyantis commented on 2015-04-05 01:41 (UTC)

Requires these as make depends: gnome-shell libnautilus-extension Also, if you get this error "Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." This helpful thread: https://bbs.archlinux.org/viewtopic.php?id=176663 tells you this fix: export NO_AT_BRIDGE=1

wtry commented on 2015-03-18 16:48 (UTC)

requires 'yelp-tools' as makedepends

rafaelff commented on 2014-09-02 07:13 (UTC)

requires 'appdata-tools' as makedepends due to 'appdata-validate'

dsreyes1014 commented on 2014-08-11 13:29 (UTC)

This doesn't build. It requires "vte-2.91". There is no package with that version for vte.