Package Details: gnome-twitch 0.4.2-1

Git Clone URL: https://aur.archlinux.org/gnome-twitch.git (read-only)
Package Base: gnome-twitch
Description: Enjoy Twitch on your GNU/Linux desktop
Upstream URL: https://github.com/vinszent/gnome-twitch
Keywords: livestream player twitch
Licenses: GPL3
Conflicts: gnome-twitch-git
Submitter: vinszent
Maintainer: vinszent
Last Packager: vinszent
Votes: 56
Popularity: 3.216062
First Submitted: 2015-10-18 20:45
Last Updated: 2018-05-20 11:54

Pinned Comments

vinszent commented on 2017-04-01 19:00

I've just bumped the version to v0.4.0 which no longer includes the GStreamer player backends by default. However you can easily install any of the player backend packages (called gnome-twitch-player-backend-*) straight from the AUR. This removes the unecessary GStreamer dependencies for those who use the MPV backend ;).

If you need help deciding I've created a short wiki page here https://github.com/vinszent/gnome-twitch/wiki/How-to-install-player-backends which describes the differences between the different player backends.

Latest Comments

Freso commented on 2018-05-20 16:43

You should rename the $source to something like ("$pkgname-$pkgver.tar.gz::<https://github.com/vinszent/gnome-twitch/archive/v>${pkgver}.tar.gz") (without the <> that the AUR comment system apparently feels like adding…) to make the filename unique; see https://wiki.archlinux.org/index.php/PKGBUILD#source for more details. I just got a checksum failure because I already have a "v0.4.2.tar.gz" from some other package.

vinszent commented on 2018-05-20 11:56

@t0phr @Moo-Crumpus Sorry for the delay, I've updated the version to v0.4.2 now which has the SSL fix.

Moo-Crumpus commented on 2018-05-19 10:46

[10:44:50] Warning - GNOME-Twitch : {GtTwitch:336} Received unsuccessful response from url 'http://api.twitch.tv/api/channels/debitorlp/access_token' with code '400' and body '{"error":"Bad Request","status":400,"message":"Requests must be made over SSL"}' [10:44:50] Warning - GNOME-Twitch : {GtTwitch:594} Error getting stream access token for channel 'debitorlp' because: Received unsuccessful response from url 'http://api.twitch.tv/api/channels/debitorlp/access_token' with code '400' and body '{"error":"Bad Request","status":400,"message":"Requests must be made over SSL"}'

t0phr commented on 2018-05-11 07:32

Playback crashes as twitch api now requires ssl. Fixed in git, see https://github.com/vinszent/gnome-twitch/issues/356

vinszent commented on 2017-10-14 11:12

Thanks for notifying me, this has been fixed upstream now. I will add a patch for this package.

EDIT: Should be fixed now.

digitalone commented on 2017-10-14 08:50

Resolved. The source package is bugged. You have to modify the source package v0.4.1.tar.gz, open meson_option.txt and replace "descritpion" with "description".
Then replace md5 in in PKGBUILD with:
15a89fecd66041e0f9499128d33fe6c3

digitalone commented on 2017-10-14 08:39

Same error here, cannot install the package.

fentom commented on 2017-10-12 16:34

I have a problem when i install it:

The Meson build system
Version: 0.43.0
Source dir: /tmp/yaourt-tmp-fentom/aur-gnome-twitch/src/gnome-twitch-0.4.1
Build dir: /tmp/yaourt-tmp-fentom/aur-gnome-twitch/src/gnome-twitch-0.4.1/build
Build type: native build

Meson encountered an error in file meson_options.txt, line 3, column 0:
Invalid kwargs for option "use-deprecated-webkit": "descritpion"

A full log can be found at /tmp/yaourt-tmp-fentom/aur-gnome-twitch/src/gnome-twitch-0.4.1/build/meson-logs/meson-log.txt

stefnix commented on 2017-04-06 18:57

@vinszent
You were right, I forgot to comment my anaconda installation of python from my $PATH

vinszent commented on 2017-04-04 21:28

@stfenix
Something is most likely wrong with either your Python or Meson installation I think. Make sure you have Python 3.6 installed and that Meson is available in your site-packages (usually in /usr/lib/python3.6/site-packages/mesonbuild/ on Arch).

All comments