Package Details: gnome-vfs-perl 1.082-7

Git Clone URL: https://aur.archlinux.org/gnome-vfs-perl.git (read-only)
Package Base: gnome-vfs-perl
Description: Gnome2-VFS perl bindings for gnome-vfs
Upstream URL: http://gtk2-perl.sourceforge.net/
Licenses: LGPL
Submitter: PhotonX
Maintainer: PhotonX
Last Packager: PhotonX
Votes: 30
Popularity: 0.295948
First Submitted: 2017-01-25 19:16
Last Updated: 2018-03-03 22:09

Latest Comments

1 2 3 Next › Last »

Ralf_Mardorf commented on 2019-03-25 06:11

Getting rid of libselinux and libsepol is a never-ending task. It isn't worth the hassle.

[snip]
==> Making package: gnome-perl 1.045-8.1 (Mon 25 Mar 2019 06:50:52 AM CET)
[snip]
rm -f blib/arch/auto/Gnome2/Gnome2.so
[ LD blib/arch/auto/Gnome2/Gnome2.so ]
chmod 755 blib/arch/auto/Gnome2/Gnome2.so
"/usr/bin/perl" "-Iblib/arch" "-Iblib/lib" -MGnome2 podifyenums.pl Gnome2 maps > blib/lib/Gnome2/enums.pod
Generating POD...
Can't load 'blib/arch/auto/Gnome2/Gnome2.so' for module Gnome2: libselinux.so.1: cannot open shared object file: No such file or directory at /usr/lib/perl5/5.28/core_perl/DynaLoader.pm line 193.
 at podifyenums.pl line 0.
Compilation failed in require.
BEGIN failed--compilation aborted.
make: *** [Makefile:1671: blib/lib/Gnome2/enums.pod] Error 2
make: *** Waiting for unfinished jobs....
Can't load 'blib/arch/auto/Gnome2/Gnome2.so' for module Gnome2: libselinux.so.1: cannot open shared object file: No such file or directory at /usr/lib/perl5/5.28/core_perl/DynaLoader.pm line 193.
 at -e line 0.
Compilation failed in require.
BEGIN failed--compilation aborted.
make: *** [Makefile:1657: build/podindex] Error 2
==> ERROR: A failure occurred in build().
    Aborting...
==> ERROR: Makepkg was unable to build gnome-perl.
[snip]

PhotonX commented on 2019-03-24 21:04

Ralf, sounds like you need a rebuild of gnome-perl without libselinux as well:

Can't load '/usr/lib/perl5/5.28/vendor_perl/auto/Gnome2/Gnome2.so' for module Gnome2: libselinux.so.1: cannot open shared object file[...]

Ralf_Mardorf commented on 2019-03-20 09:21

No, it doesn't. Shutter and its dependencies were build with libselinux installed, so probably something else was build against libselinux.so.1. I'm short in time, hence I can't build shutter and all of its dependencies one after the other, to find out which package actually is the culprit. At least for now I will keep libselinux and libsepol installed.

[rocketmouse@archlinux ~]$ yaourt -S gnome-vfs-nosmb 
[snip]
checking for is_selinux_enabled in -lselinux... no
[snip]
Gnome VFS configuration summary:

    IPv6 support:                yes
    SSL support:                 yes
        Avahi support:           yes
        Howl support:            no
    HAL  support:                no
    Enable gnome-vfs-daemon:     yes
    SELinux  support:            no
    File ACL backends:           posix
    Gtk Doc:                     no
    FS monitor backends:         inotify fam
    Samba method:            no
    CDDA method:             no
    Enable profiler:             no
[snip]
[rocketmouse@archlinux ~]$ pacman -Qi gnome-vfs-nosmb libselinux libsepol | grep -e Ver -e Des
error: package 'libselinux' was not found
error: package 'libsepol' was not found
Version         : 2.24.4-9.1
Description     : The GNOME Virtual File System build without libselinux
[rocketmouse@archlinux ~]$ shutter; echo $?
Can't load '/usr/lib/perl5/5.28/vendor_perl/auto/Gnome2/Gnome2.so' for module Gnome2: libselinux.so.1: cannot open shared object file: No such file or directory at /usr/lib/perl5/5.28/core_perl/DynaLoader.pm line 193.
 at /usr/bin/shutter line 37.
Compilation failed in require at /usr/bin/shutter line 37.
BEGIN failed--compilation aborted at /usr/bin/shutter line 37.
2
[rocketmouse@archlinux ~]$ sudo pacman -U /var/cache/aur/current/{libsepol,libselinux}-2.9-1-x86_64.pkg.tar.xz
[snip]
[rocketmouse@archlinux ~]$ pacman -Qi gnome-vfs-nosmb libselinux libsepol | grep -e Ver -e Des
Version         : 2.24.4-9.1
Description     : The GNOME Virtual File System build without libselinux
Version         : 2.9-1
Description     : SELinux library and simple utilities
Version         : 2.9-1
Description     : SELinux binary policy manipulation library
[rocketmouse@archlinux ~]$ shutter; echo $?
[snip]
0

PhotonX commented on 2019-03-20 07:38

Nice, looks like we figured it out! Ralf, can you confirm that rebuilding gnome-vfs-nosmb or gnome-vfs without libselinux solves the issue?

dark-saber commented on 2019-03-19 22:58

It turns out, I've had the same problem: gnome-vfs-nosmb was built with libselinux installed and then I've uninstalled selinux. Rebuilding gnome-vfs-nosmb without libselinux solves this indeed. Thanks, Ralf_Mardorf and PhotonX!

PhotonX commented on 2019-03-19 21:58

That might be the key observation! I will try to reproduce this and write back tomorrow.

Ralf_Mardorf commented on 2019-03-19 21:50

Installed is gnome-vfs-nosmb. I don't remember why gnome-vfs was replaced with gnome-vfs-nosmb.

[rocketmouse@archlinux ~]$ grep gnome-vfs /var/log/pacman.log | grep ALPM
[2015-04-12 23:55] [ALPM] installed gnome-vfsmm (2.26.0-3)
[2015-04-19 18:55] [ALPM] upgraded gnome-vfs (2.24.4-8 -> 2.24.4-9)
[2015-06-28 17:59] [ALPM] upgraded gnome-vfs-perl (1.082-2 -> 1.082-3)
[2015-12-11 13:24] [ALPM] upgraded gnome-vfsmm (2.26.0-3 -> 2.26.0-4)
[2016-06-06 07:47] [ALPM] upgraded gnome-vfs-perl (1.082-3 -> 1.082-4)
[2016-08-04 09:20] [ALPM] upgraded gnome-vfs (2.24.4-9 -> 2.24.4-10)
[2017-01-28 12:51] [ALPM] upgraded gnome-vfs-perl (1.082-4 -> 1.082-5)
[2017-02-04 12:13] [ALPM] removed gnome-vfs (2.24.4-10)
[2017-02-04 12:13] [ALPM] installed gnome-vfs-nosmb (2.24.4-9)
[2017-02-04 12:13] [ALPM] upgraded gnome-vfs-perl (1.082-5 -> 1.082-6)
[2017-06-07 03:24] [ALPM] upgraded gnome-vfs-perl (1.082-6 -> 1.082-7)
[2017-09-03 15:05] [ALPM] upgraded gnome-vfs-perl (1.082-7 -> 1.082-8)
[2018-09-18 21:28] [ALPM] upgraded gnome-vfs-perl (1.082-8 -> 1.082-9)
[2018-11-14 08:38] [ALPM] removed gnome-vfsmm (2.26.0-4)
[2018-11-14 08:39] [ALPM] installed gnome-vfsmm (2.26.0-4)
[2018-11-14 08:39] [ALPM] removed gnome-vfsmm (2.26.0-4)

However, the current installed version of gnome-vfs-nosmb was build with libselinux installed.

[rocketmouse@archlinux ~]$ grep selinux /var/log/pacman.log | grep ALPM
[2017-01-20 15:07] [ALPM] installed libselinux (2.6-2)
[2017-08-11 23:08] [ALPM] upgraded libselinux (2.6-2 -> 2.7-1)
[2018-05-27 10:32] [ALPM] upgraded libselinux (2.7-1 -> 2.8-1)
[2019-03-17 18:19] [ALPM] removed libselinux (2.8-1)
[2019-03-19 13:29] [ALPM] installed libselinux (2.9-1)

I don't have time to rebuild without libselinux.

PhotonX commented on 2019-03-19 21:30

Does the problem persist if you use gnome-vfs-nosmb instead of gnome-vfs? Also, do gnome-vfs and gnome-vfs-nosmb build fine without libselinux installed? I will try to reproduce the problem on another machine tomorrow!

Ralf_Mardorf commented on 2019-03-19 20:22

My apologies for not editing my previous comment. IMO it's better to write a new comment, so you receive a notification about something that might or might not be important.

I notice that I've got gnome-vfs-perl 1.082-9 installed, but AUR provides gnome-vfs-perl 1.082-7.

[rocketmouse@archlinux ~]$ pacman -Q gnome-vfs-perl
gnome-vfs-perl 1.082-9

Likely related to the need to rebuild some packages locally. IOW related to my pinned comment from 2017-09-03 13:25 at aur/shutter.

[rocketmouse@archlinux ~]$ grep gnome-vfs-perl /var/log/pacman.log | tail -7
[2017-06-07 03:24] [ALPM] upgraded gnome-vfs-perl (1.082-6 -> 1.082-7)
[2017-09-03 15:05] [PACMAN] Running 'pacman --color auto -U /tmp/yaourt-tmp-rocketmouse/PKGDEST.NRg/gnome-vfs-perl-1.082-8-x86_64.pkg.tar.xz'
[2017-09-03 15:05] [ALPM] upgraded gnome-vfs-perl (1.082-7 -> 1.082-8)
[2018-09-14 08:27] [PACMAN] Running 'pacman -Rss gnome-perl gnome-vfs-perl gnomecanvas-perl perl-gnome2-wnck perl-goo-canvas perl-gtk2-imageview'
[2018-09-18 20:50] [PACMAN] Running 'pacman -Rss gnome-perl gnome-vfs-perl gnomecanvas-perl perl-gnome2-wnck perl-goo-canvas perl-gtk2-imageview'
[2018-09-18 21:28] [PACMAN] Running 'pacman --color auto -U /tmp/yaourt-tmp-rocketmouse/PKGDEST.6WJ/gnome-vfs-perl-1.082-9-x86_64.pkg.tar.xz'
[2018-09-18 21:28] [ALPM] upgraded gnome-vfs-perl (1.082-8 -> 1.082-9)
[rocketmouse@archlinux ~]$ grep shutter /var/log/pacman.log | grep 0.94 | grep ALPM
[2017-08-17 06:57] [ALPM] upgraded shutter (0.93.1-11 -> 0.94-1)
[2017-08-17 19:06] [ALPM] upgraded shutter (0.94-1 -> 0.94-2)
[2018-09-18 20:31] [ALPM] upgraded shutter (0.94-2 -> 0.94.2-1)
[2018-09-18 21:53] [ALPM] reinstalled shutter (0.94.2-1)

FWIW regarding GNOME and the virtual file system I should mention, that I fulfil dependencies to gvfs by an empty dummy package.

[rocketmouse@archlinux ~]$ pactree -r gvfs
gvfs
├─caja
├─libgnome
│ └─libbonoboui
│   └─libgnomeui
│     ├─gnocl-builder
│     │ └─osc2midi-utils
│     ├─gnocl-gconf
│     │ └─osc2midi-utils
│     └─gnome-perl
│       └─shutter
├─nautilus
│ └─gnome-panel
└─nemo
  └─cinnamon

FWIW all hard dependencies of gvfs are installed.

$ pacman -Q avahi  dconf  fuse  libarchive  libcdio-paranoia  libsoup  udisks2  libsecret  libbluray  libgudev  gcr  psmisc
avahi 0.7+18+g1b5f401-1
dconf 0.32.0-1
fuse2 2.9.9-1
libarchive 3.3.3-1
libcdio-paranoia 10.2+2.0.0-1
libsoup 2.66.0-1
udisks2 2.8.2-1
libsecret 0.18.8-2
libbluray 1.1.0-1
libgudev 232-1
gcr 3.28.1-1
psmisc 23.2-1

Regards,

Ralf

Ralf_Mardorf commented on 2019-03-19 19:45

Hi,

as already pointed out by a comment from 2019-03-19 12:40 at aur/shutter, I only need libselinux to run shutter.

[rocketmouse@archlinux ~]$ pacman -Qs selinux
local/libselinux 2.9-1 (selinux)
    SELinux library and simple utilities
local/libsepol 2.9-1 (selinux)
    SELinux binary policy manipulation library
[rocketmouse@archlinux ~]$ pactree -r libselinux
libselinux
[rocketmouse@archlinux ~]$ pactree -r libsepol
libsepol
└─libselinux
[rocketmouse@archlinux ~]$ pactree -r gnome-vfs-perl
gnome-vfs-perl
└─gnome-perl
  └─shutter

Regards,

Ralf