Package Details: gns3-server 2.2.22-1

Git Clone URL: https://aur.archlinux.org/gns3-server.git (read-only, click to copy)
Package Base: gns3-server
Description: GNS3 network simulator, Server package
Upstream URL: https://github.com/GNS3/gns3-server
Licenses: GPL3
Groups: gns3
Submitter: korjjj
Maintainer: buzo
Last Packager: buzo
Votes: 67
Popularity: 1.78
First Submitted: 2014-05-13 17:40
Last Updated: 2021-06-16 12:03

Latest Comments

1 2 3 4 5 6 ... Next › Last »

buzo commented on 2021-06-16 12:03

SpacingBat3: Done, thanks for trying this out!

SpacingBat3 commented on 2021-06-15 21:13

Could you (the maintainer of this PKGBUILD) add aarch64 architecture to arch() array in PKGBUILD? I was able to compile it on my AArch64 device and actualy use it (with an exception it won't work with most QEMU presets, it runs fine and can be used with dynamips).

kazaii commented on 2021-05-20 00:02

Woops, sorry about that; Misunderstood your last reply to black_file. Thanks, Buzo

buzo commented on 2021-05-19 17:00

kazaii: I've already fixed this a few days ago.

kazaii commented on 2021-05-18 01:01

It should work with jinja 2.X, but it Seems that this one stopped working when Python jinja 3.0 dropped into Arch upstream

resolving dependencies...
looking for conflicting packages...

Packages (2) python-markupsafe-2.0.0-1  python-jinja-3.0.0-3

Total Download Size:   0.23 MiB
Total Installed Size:  1.35 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 python-jinja-3.0.0... 

Probably another tweak in the requirements section would get it going.

edit: Looks like this does the trick:

-e 's|^Jinja2==2.11.3$|Jinja2>=2.11.3|' \

added to requirements .txt

prepare() {
    cd "$pkgname-$pkgver"
    # Arch usually has the latest versions. Patch requirements to allow them.
    sed -i \
        -e 's|^aiohttp==3\.7\.4.*|aiohttp>=3.7.4|' \
        -e 's|^aiofiles==0\.6\.0$|aiofiles>=0.6.0|' \
        -e 's|^sentry-sdk==1\.0\.0$|sentry-sdk>=1.0.0|' \
        -e 's|^psutil==5\.8\.0$|psutil>=5.8.0|' \
        -e 's|^distro==1\.5\.0$|distro>=1.5.0|' \
        -e 's|^py-cpuinfo==7\.0\.0$|py-cpuinfo>=7.0.0|' \
        -e 's|^Jinja2==2\.11\.3$|Jinja2>=2.11.3|' \      ##<---------- Here
        requirements.txt
}

buzo commented on 2021-05-16 18:41

Black_file: Does it work with version 2.2.21-2?

Black_file commented on 2021-05-16 12:39

Hey, have a problem with this package because python-jinja2=2.13.1 is missing tried to downgrade but nothing solved can you help me pls ?

douglasimc commented on 2021-04-26 19:24

@buzo: I made a mistake in identifying the problematic dependency in the service logs. @usbping has already indicated the correction it would make. Now it's all right!

usbping commented on 2021-04-25 18:06

buzo: It`s works with that. Thank you for your help.

buzo commented on 2021-04-25 17:05

usbping: Thanks for calling attention! I have patched the requirements to allow py-cpuinfo>=7.0.0 – does it work with that?