Package Details: gns3-server 2.1.21-2

Git Clone URL: https://aur.archlinux.org/gns3-server.git (read-only)
Package Base: gns3-server
Description: GNS3 network simulator, Server package
Upstream URL: https://github.com/GNS3/gns3-server
Licenses: GPL3
Groups: gns3
Submitter: korjjj
Maintainer: buzo
Last Packager: buzo
Votes: 56
Popularity: 0.612277
First Submitted: 2014-05-13 17:40
Last Updated: 2019-06-16 19:19

Dependencies (18)

Required by (1)

Sources (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

enderst commented on 2017-01-12 05:53

Had to uninstall python-aiohttp and python-zipstream then use pip3 to install the versions required by gns3-server 1.5.2-1 so I could get the gns3 vm to work.

pip3 install aiohttp==0.21.5
pip3 install zipstream==1.1.3

johnthekipper commented on 2016-11-12 08:20

Please replace 'python-aiohttp' 'python-zipstream' at the depends
and change the version to 1.5.2

hcartiaux commented on 2016-10-02 14:02

Could you please update to 1.5.2 ?

hugleo commented on 2016-08-01 15:57

Local server is not working with 0.22 version.
Downgrade to 0.21.5 and worked.

bubbles commented on 2016-07-27 06:58

@veroke
I edited /usr/lib/python3.5/site-packages/gns3_server-1.5.1-py3.5.egg-info/requires.txt
change aiohttp==0.21.5 to aiohttp>=0.21.5
and pip install multidict
working fine.

noplay commented on 2016-07-22 11:14

The require.txt is fixed in the GNS3 git to use >=

veroke commented on 2016-07-22 10:34

I encountered some error running gns3-server

pkg_resources.ContextualVersionConflict: (aiohttp 0.22.1 (/usr/lib/python3.5/site-packages), Requirement.parse('aiohttp==0.21.5'), {'gns3-server'})

So, i edited vim /usr/lib/python3.5/site-packages/gns3_server-1.5.1-py3.5.egg-info/requires.txt

change aiohttp==0.21.5 to aiohttp==0.22.1

then i ran gns3 on terminal, another error showed up:
pkg_resources.DistributionNotFound: The 'multidict>=1.1.0' distribution was not found and is required by aiohttp

$ wget https://aur.archlinux.org/cgit/aur.git/snapshot/python-multidict.tar.gz
$ tar xvf python-multidict.tar.gz
Edit the PKGBUILD, change pkgver=1.1.0b4 to pkgver=1.1.0
$ updpkgsums
$ makepkg -rs

then, installed it.
gns3 runs okay now.

jmartins commented on 2016-07-13 17:30

Please update to latest version

tks
joao

buhaha commented on 2016-07-10 17:23

1.5.1
http://pastebin.com/cwLZSih1

noplay commented on 2016-07-05 15:22

You can drop this dependencies:
python-netifaces' 'gns3-netifaces' 'python-docker-py

We have replaced netifaces by a function available in psutils.