Package Details: gnumeric-pure 0.15-2

Git Clone URL: https://aur.archlinux.org/gnumeric-pure.git (read-only)
Package Base: gnumeric-pure
Description: A Gnumeric extension which lets you use Pure functions in Gnumeric, the Gnome spreadsheet.
Upstream URL: http://docs.pure-lang.googlecode.com/hg/pd-pure.html
Licenses: custom
Groups: pure-complete, pure-math
Submitter: g2oo7fy
Maintainer: pure-aur
Last Packager: pure-aur
Votes: 2
Popularity: 0.000000
First Submitted: 2012-11-20 19:45
Last Updated: 2015-12-19 00:22

Latest Comments

aggraef commented on 2013-09-08 12:22

Package gnumeric-pure-hg is out: https://aur.archlinux.org/packages/gnumeric-pure-hg/. This uses the latest gnumeric-pure from the Pure hg repository. Please use that package until gnumeric-pure 0.13 comes out.

aggraef commented on 2013-09-01 21:25

Just for the record: The latest version in Pure's hg repository works fine with Gnumeric 1.12 and GTK3 now. The OpenGL support requires GtkGLExt 3.0 which is available from https://github.com/tdz/gtkglext. The OpenGL support under GTK3 still has some issues, though, so it's not enabled by default.

aggraef commented on 2013-08-31 22:27

Well, apparently I was a bit too pessimistic. :) The Gnumeric ppl have apparently done an amazing job. With some minor source changes, I have the module working with Gnumeric 1.12.4 now, minus the OpenGL support, so it looks like the port won't be so difficult after all. I still have to review the source changes I did, though, and see whether I can get the OpenGL support working again.

aggraef commented on 2013-08-30 07:21

This package is currently broken (won't compile). At present, gnumeric-pure requires Gnumeric <= 1.10. I believe that the Gnumeric plugin interface has changed in 1.11, so this will probably take substantial effort to port to Gnumeric versions >= 1.11.