Package Details: gnuradio38 v3.8.4.0.r27.g1d110e076-2

Git Clone URL: https://aur.archlinux.org/gnuradio38.git (read-only, click to copy)
Package Base: gnuradio38
Description: General purpose DSP and SDR toolkit. 3.8 branch.
Upstream URL: https://gnuradio.org
Licenses: GPL
Provides: gnuradio, libgnuradio-analog.so, libgnuradio-audio.so, libgnuradio-blocks.so, libgnuradio-channels.so, libgnuradio-digital.so, libgnuradio-dtv.so, libgnuradio-fec.so, libgnuradio-fft.so, libgnuradio-filter.so, libgnuradio-pmt.so, libgnuradio-qtgui.so, libgnuradio-runtime.so, libgnuradio-trellis.so, libgnuradio-uhd.so, libgnuradio-vocoder.so, libgnuradio-wavelet.so, libgnuradio-zeromq.so
Submitter: greyltc
Maintainer: greyltc
Last Packager: greyltc
Votes: 0
Popularity: 0.000000
First Submitted: 2021-11-13 16:32 (UTC)
Last Updated: 2021-12-19 14:23 (UTC)

Required by (57)

Sources (3)

Latest Comments

micdnj commented on 2022-04-28 21:50 (UTC) (edited on 2022-04-28 21:50 (UTC) by micdnj)

During compilation process I got an error as below. Any ideas what to do?

gnuradio38/src/gnuradio/gr-vocoder/lib/freedv_rx_ss_impl.cc:69:15: error: ‘struct freedv_advanced’ has no member named ‘interleave_frames’
   69 |         d_adv.interleave_frames = interleave_frames;
      |               ^~~~~~~~~~~~~~~~~

dreieck commented on 2021-12-19 18:43 (UTC)

Can you strip the trailing v from the version?

And add =${pkgver} to the gnuradio related entries in the provides array? (There are packages that need a specific gnuradio version, e.g. gr-foo-git.)