Package Details: gnustep-gui-clang-svn 1:r38298-3

Git Clone URL: https://aur.archlinux.org/gnustep-gui-clang-svn.git (read-only)
Package Base: gnustep-gui-clang-svn
Description: The GNUstep GUI class library, using Clang
Upstream URL: http://www.gnustep.org/
Licenses: GPL3, LGPL2.1
Groups: gnustep-clang-svn
Conflicts: gnustep-gui, gnustep-gui-multilib-clang-svn, gnustep-gui-svn
Provides: gnustep-gui
Replaces: gnustep-gui-multilib-clang-svn
Submitter: Xorg
Maintainer: espectalll
Last Packager: Xorg
Votes: 8
Popularity: 0.000001
First Submitted: 2013-08-14 13:55
Last Updated: 2016-02-18 08:21

Required by (11)

Sources (1)

Latest Comments

Xorg commented on 2016-02-18 08:34

I disown this package. Reason: it was created for darling-git, but darling-git no longer depends on gnustep-gui-clang-svn.

Xorg commented on 2013-10-18 20:50

I don't understand why it's work for me without libao... But I've added it as dependency, thanks.

Chimyx commented on 2013-10-17 16:14

Compilation fails linking with libao.
Installing lib32-libao fixed it, it should be a dependency.

Xorg commented on 2013-09-13 23:03

Yes, the patch 'giflib-5.0.patch' is useless since revision 37078, because 'NSBitmapImageRep+GIF.m' is now compatbile with giflib 5.
Release 4 solve this. Thanks.

DeckardXCain commented on 2013-09-13 20:53

this happens when I run makepkg
==> Making package: gnustep-gui-clang-svn 37078-1 (Fri Sep 13 16:52:36 EDT 2013)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Updating gnustep-gui svn repo...
Updating '.':
At revision 37078.
-> Found giflib-5.0.patch
==> Validating source files with md5sums...
gnustep-gui ... Skipped
giflib-5.0.patch ... Passed
==> Extracting sources...
-> Creating working copy of svn repo...
==> Starting pkgver()...
==> Starting prepare()...
-> Patch 'NSBitmapImageRep+PNG.m' file...
+ sed -i 's|png_sizeof|sizeof|g' Source/NSBitmapImageRep+PNG.m
-> Patch for package 'giflib-5'...
Hmm... Looks like a unified diff to me...
The text leading up to this was:
--------------------------
|--- a/Source/NSBitmapImageRep+GIF.m 2013-08-14 14:47:10.278573901 +0200
|+++ b/Source/NSBitmapImageRep+GIF.m 2013-08-14 15:10:05.449777559 +0200
--------------------------
patching file Source/NSBitmapImageRep+GIF.m
Using Plan A...
Reversed (or previously applied) patch detected! Skipping patch.
Hunk #1 ignored at 39.
Hunk #2 ignored at 144.
patch unexpectedly ends in middle of line
Hunk #3 ignored at 220.
3 out of 3 hunks ignored -- saving rejects to file Source/NSBitmapImageRep+GIF.m.rej
done
==> ERROR: A failure occurred in prepare().
Aborting...

kopiersperre commented on 2013-08-19 16:24

@X0rg: Now it builds

Xorg commented on 2013-08-19 15:34

Release 3 : Remove traces of packages from gnustep-clang-git.

Xorg commented on 2013-08-19 10:14

@kopiersperre : /Headers/Additions/GNUstepGUI/GMAppKit.h has not been modified since 3 years.
With 'yaourt -S darling-git' in a VM, I have no problem. It's the revision 36990 at this time.
I don't know, you can try to update all packages in group Gnustep-clang-git. The best order is, according to LubosD : GNUstep Make -> GNUstep Libobjc2 -> GNUstep Base -> GNUstep GUI -> GNUstep CoreBase

kopiersperre commented on 2013-08-19 06:00

In file included from NSAlert.m:65:
In file included from ../Headers/Additions/GNUstepGUI/GMAppKit.h:54:
../Headers/AppKit/NSSavePanel.h:85:1: error: expected parameter declarator
DEFINE_BLOCK_TYPE(GSSavePanelCompletionHandler, void, NSInteger);
^
/usr/include/GNUstepBase/GSBlocks.h:78:40: note: expanded from macro 'DEFINE_BLOCK_TYPE'
retTy (*invoke)(void*, argTys, args);\
^
1 error generated.

Xorg commented on 2013-08-18 17:20

GNUstep-GUI-Clang-SVN Release 2 : build trouble with revision 36968 is fixed, now use the latest SVN revision.

All comments