Package Details: goffice0.8 0.8.17-4

Git Clone URL: https://aur.archlinux.org/goffice0.8.git (read-only)
Package Base: goffice0.8
Description: A library of document-centric objects and utilities built on top of GLib and Gtk+
Upstream URL: http://www.gnome.org
Licenses: GPL
Conflicts: goffice<0.10
Submitter: City-busz
Maintainer: kubrick
Last Packager: kubrick
Votes: 15
Popularity: 2.388309
First Submitted: 2017-06-30 07:40
Last Updated: 2017-07-02 17:01

Latest Comments

snuffop commented on 2017-09-28 22:40

that fixed it up. Thank you Kubrick
I had both
en_US.UTF-8 UTF-8
en_US ISO-8859-1

uncommented and I suspect I only needed the UTF-8

kubrick commented on 2017-09-28 10:24

@snuffop: this is most likely an issue with your locale & special character in a path or hostname, maybe try export LANG=en_US.UTF-8 ?

snuffop commented on 2017-09-28 02:24

I'm attempting to install gnucash and am getting this error on goffic0.8 which is a dependency..

-- Installing ./html/up.png
Traceback (most recent call last):
File "/usr/bin/gtkdoc-rebase", line 56, in <module>
sys.exit(rebase.run(options))
File "/usr/share/gtk-doc/python/gtkdoc/rebase.py", line 73, in run
ScanDirectory(dir, options)
File "/usr/share/gtk-doc/python/gtkdoc/rebase.py", line 131, in ScanDirectory
ScanDirectory(subdir, options)
File "/usr/share/gtk-doc/python/gtkdoc/rebase.py", line 104, in ScanDirectory
o = ReadDevhelp(scan_dir, entry)
File "/usr/share/gtk-doc/python/gtkdoc/rebase.py", line 137, in ReadDevhelp
for line in open(os.path.join(dir, file)):
File "/usr/lib/python3.6/encodings/ascii.py", line 26, in decode
return codecs.ascii_decode(input, self.errors)[0]
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 2123: ordinal not in range(128)
make[3]: *** [Makefile:713: install-data-local] Error 1
make[3]: Leaving directory '/tmp/yaourt-tmp-marty/aur-goffice0.8/src/goffice-0.8.17/docs/reference'
make[2]: *** [Makefile:491: install-am] Error 2
make[2]: Leaving directory '/tmp/yaourt-tmp-marty/aur-goffice0.8/src/goffice-0.8.17/docs/reference'
make[1]: *** [Makefile:425: install-recursive] Error 1
make[1]: Leaving directory '/tmp/yaourt-tmp-marty/aur-goffice0.8/src/goffice-0.8.17/docs'
make: *** [Makefile:535: install-recursive] Error 1

Seems like I'm missing sometihng obvious

kubrick commented on 2017-08-24 14:47

Well, there's something fishy going on here so stay away from this package for now.
I shall get in touch with gnome developers but the SHA256 sum in the PKGBUIL is definitely the good one and matches https://download.gnome.org/sources/goffice/0.8/goffice-0.8.17.sha256sum

psamim commented on 2017-08-24 09:10

==> Validating source files with sha256sums...
goffice-0.8.17.tar.xz ... FAILED

kubrick commented on 2017-07-02 17:02

@Hello71 pkg-config is part of base-devel and thus should be removed from the PKGCONFIG alltogether. Done.

Hello71 commented on 2017-07-02 13:39

please change to depend on "pkg-config", this is the only one that pkgconf provides.