Package Details: gog-the-witcher-2-assassins-of-kings 2.2.0.8-1

Git Clone URL: https://aur.archlinux.org/gog-the-witcher-2-assassins-of-kings.git (read-only)
Package Base: gog-the-witcher-2-assassins-of-kings
Description: Enjoy a captivating story, dynamic combat system and beautiful graphics in the second installment in the RPG saga about the Witcher, Geralt of Rivia.
Upstream URL: http://thewitcher.com/
Licenses: custom
Groups: games, gog
Submitter: fettouhi
Maintainer: krakn
Last Packager: krakn
Votes: 7
Popularity: 0.028887
First Submitted: 2014-09-05 06:26
Last Updated: 2017-05-19 18:24

Latest Comments

NityaSattva commented on 2016-02-28 01:54

Using file: gog_the_witcher_2_assassins_of_kings_enhanced_edition_2.2.0.8.sh

I had to make custom links for following file:
ln -s /usr/lib32/mesa/libEGL.so /usr/lib32/libEGL.so
ln -s /usr/lib32/mesa/libEGL.so.1 /usr/lib32/libEGL.so.1
ln -s /usr/lib32/mesa/libEGL.so.1.0.0 /usr/lib32/libEGL.so.1.0.0

After that the game started but without sound, install missing libs:
pacman -Syu lib32-alsa-plugins lib32-libpulse

And no more issues at all on my minimal x86_64 install, about 2 hours in to the game.

jdarch commented on 2015-08-30 18:36

I believe it makes sense to have PKGBUILDs for GOG games, that way dependencies and duplicate files can be managed by pacman.

Therefore I have just created a quick 'wapper PKGBUILD' for another GOG-game (https://aur.archlinux.org/packages/gog-mountandblade-warband/), the GOG installers are just executed inside the script, it requires user interaction unfortunately, as I have not been able to find a way to give the installer GOG uses the right parameters in a PKGBUILD after quickly looking at it.

fettouhi commented on 2015-08-18 06:34

Does it even make sense now to have PKGBUILDS for GOG games? Isn't the new installer distro-agnostic? I'm disowning this package now. I don't have time to update it.

Theredbaron1834 commented on 2015-08-17 17:21

GOG just updated the installers, now we have "gog_the_witcher_2_assassins_of_kings_enhanced_edition_2.2.0.8.sh" using the mojo installer. This pkgbuild no longer works. Plus it seems the game is all in all buggy now, crashes often on cutscenes, people using this version might be best off skiping the cutscenes.

fettouhi commented on 2015-05-22 17:33

Updated to @mirandir version of the PKGBUILD. Many thanks!!!

mirandir commented on 2015-05-22 15:09

Well, I had some free time so I have updated my PKGBUILD, you can take it if you want ;)
=> https://www.dropbox.com/s/hv0hgrhee93n9sa/gog-the-witcher-2-assassins-of-kings-1.2.0.7-1.src.tar.gz?dl=0

fettouhi commented on 2015-05-22 09:03

@mirandir I'll look into it this weekend. I didn't have much time to update this PKGBUILD yesterday.

mirandir commented on 2015-05-21 21:00

@fettouhi : you should really rebase your PKGBUILD from my last proposition (https://www.dropbox.com/s/e6kji39g02a7fgv/the_witcher_2_latest_beta.zip?dl=0). Many tricks in your PKGBUILD are not needed anymore, like the workaround, libcurl, ...

fettouhi commented on 2015-05-21 19:29

Updated to 1.2.0.7.

tea commented on 2015-05-21 15:42

Latest tarball from GOG is 1.2.0.7 with sha256: 9139bae265de692b5b3bbe9466ca7eff3b006f7a51e2df13cf2d86b2b247fadf

All comments