Package Details: gogland 171.4424.55-1

Git Clone URL: https://aur.archlinux.org/gogland.git (read-only)
Package Base: gogland
Description: Capable and Ergonomic Go IDE
Upstream URL: https://www.jetbrains.com/go/
Licenses: Commercial
Submitter: frederik
Maintainer: frederik
Last Packager: frederik
Votes: 9
Popularity: 2.940377
First Submitted: 2016-12-15 22:39
Last Updated: 2017-05-12 21:05

Dependencies (3)

Required by (0)

Sources (2)

Pinned Comments

frederik commented on 2016-12-25 00:45

This will follow the EAP branch until gogland hits stable. It will then switch to the stable releases immediately.

Latest Comments

mixedCase commented on 2017-03-22 19:19

Split packages cause issues with AUR helpers, which is why maintainers tend to avoid them for the AUR.

frederik commented on 2017-03-19 20:18

@ginabythebay: This is a so called "split package". What is the exact error you got?

ginabythebay commented on 2017-03-19 18:30

Like intagger, I am now also unable to update gogland because this aur entry now seems to contain two packages. I tried uninstalling gogland and reinstalling it and got the same failure.

frederik commented on 2017-02-20 05:16

I split the package due to a discussion on the aur mailing list. It's now easier to install gogland without the bundled jre.

intagger commented on 2017-02-19 21:02

Why you have added the gogland-jre in the PKGBUILD?
+pkgname=(gogland gogland-jre)
I was unable to update the gogland, because it wants to install two packages now: gogland and gogland-jre.

intagger commented on 2017-02-19 07:39

Y U do not update?

frederik commented on 2016-12-25 00:45

This will follow the EAP branch until gogland hits stable. It will then switch to the stable releases immediately.

farwayer commented on 2016-12-16 12:23

@justinus gogland is in closed beta still.

justinus commented on 2016-12-16 06:08

==> Retrieving sources...
==> ERROR: {pkgname}-2016.3.tar.gz was not found in the build directory and is not a URL.
==> ERROR: Makepkg was unable to build gogland.