Package Details: goobook-git 3.5.1-3

Git Clone URL: (read-only, click to copy)
Package Base: goobook-git
Description: Search your google contacts from the command-line or mutt.
Upstream URL:
Licenses: GPL
Conflicts: goobook
Provides: goobook
Submitter: firecat53
Maintainer: None
Last Packager: firecat53
Votes: 58
Popularity: 0.000000
First Submitted: 2010-03-29 18:20 (UTC)
Last Updated: 2022-09-25 17:45 (UTC)

Latest Comments

1 2 3 4 5 6 .. 9 Next › Last »

firecat53 commented on 2023-12-17 03:02 (UTC)

I no longer use this package. Feel free to adopt!

firecat53 commented on 2022-07-16 02:32 (UTC)

The protobuf error must be fixed now, as I haven't seen it.

Updated PKGBUILD for latest goobook packaging changes and switch to python-pyxdg.

merlock commented on 2022-06-14 14:30 (UTC)

Actually, the below error is from python-google-api-core and python-googleapis-common-protos.

Upstream is aware of both; api-core is fixed for upcoming 2.8.2 release, and common-protos is in work.

In the meantime, it can be manually fixed:

+++ /usr/lib/python3.10/site-packages/google_api_core-2.8.1-py3.10.egg-info/requires.txt    
@@ -1,5 +1,5 @@


+++ /usr/lib/python3.10/site-packages/googleapis_common_protos-1.56.2.dist-info/METADATA
 @@ -20,7 +20,7 @@
 Requires-Python: >=3.6
 Description-Content-Type: text/markdown
 License-File: LICENSE
-Requires-Dist: protobuf (<4.0.0dev,>=3.15.0)
+Requires-Dist: protobuf (<5.0.0dev,>=3.15.0)
 Provides-Extra: grpc
 Requires-Dist: grpcio (<2.0.0dev,>=1.0.0) ; extra == 'grpc'

I got the version number straight from the upstream fixes.

merlock commented on 2022-06-13 23:36 (UTC) (edited on 2022-06-13 23:59 (UTC) by merlock)

It seems that the new protobuf split package breaks goobook. Error after upgrade:

Traceback (most recent call last):
  File "/usr/lib/python3.10/site-packages/pkg_resources/", line 579, in _build_master
  File "/usr/lib/python3.10/site-packages/pkg_resources/", line 897, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.10/site-packages/pkg_resources/", line 788, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (protobuf 4.21.1 (/usr/lib/python3.10/site-packages), Requirement.parse('protobuf<4.0.0dev,>=3.15.0'), {'google-api-core'})

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/goobook", line 33, in <module>
    sys.exit(load_entry_point('goobook==3.5.1.dev0', 'console_scripts', 'goobook')())
  File "/usr/bin/goobook", line 25, in importlib_load_entry_point
    return next(matches).load()
  File "/usr/lib/python3.10/importlib/metadata/", line 171, in load
    module = import_module('module'))
  File "/usr/lib/python3.10/importlib/", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1050, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1027, in _find_and_load
  File "<frozen importlib._bootstrap>", line 1006, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 688, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 883, in exec_module
  File "<frozen importlib._bootstrap>", line 241, in _call_with_frames_removed
  File "/usr/lib/python3.10/site-packages/goobook/", line 18, in <module>
    import pkg_resources
  File "/usr/lib/python3.10/site-packages/pkg_resources/", line 3247, in <module>
    def _initialize_master_working_set():
  File "/usr/lib/python3.10/site-packages/pkg_resources/", line 3221, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.10/site-packages/pkg_resources/", line 3259, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.10/site-packages/pkg_resources/", line 581, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/usr/lib/python3.10/site-packages/pkg_resources/", line 594, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/usr/lib/python3.10/site-packages/pkg_resources/", line 783, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'protobuf<4.0.0dev,>=3.15.0' distribution was not found and is required by google-api-core

Downgrading both protobuf and python-protobuf restores functionality.

firecat53 commented on 2022-03-27 03:01 (UTC)

@simona - Yes, that's correct. Please read the post-install message for options.

simona commented on 2022-03-25 23:59 (UTC)

-> Installing python-xdg will remove: python-pyxdg, python-pyxdg (python-xdg)

AkechiShiro commented on 2021-08-27 20:13 (UTC)

@firecat53 Yes, I did afterwards, and I have no longer any issue.

Thanks for your answer, I should have done this before commenting.

firecat53 commented on 2021-08-27 20:11 (UTC)

@AkechiShiro, did you read and attempt to follow the post-install message?

AkechiShiro commented on 2021-08-27 02:22 (UTC)

Hi, I'm getting this error when trying to build this pkg:

aura >>= The package goobook-git depends on version >=4.0.1 of python-pyxdg, but the most recent version is 0.27.

firecat53 commented on 2021-07-18 23:49 (UTC)

From the post-install message:

  The Archlinux packages python-xdg and python-pyxdg conflict. If
  you need python-pyxdg, remove python-xdg from the PKGBUILD and
  `pip install --user xdg` or install goobook into a virtualenv.

I believe xdg is just used to open a browser for authentication.