Package Details: goobook-git 1.9-1

Git Clone URL: https://aur.archlinux.org/goobook-git.git (read-only)
Package Base: goobook-git
Description: Search your google contacts from the command-line or mutt.
Upstream URL: https://gitlab.com/goobook/goobook
Licenses: GPL
Conflicts: goobook
Provides: goobook
Submitter: firecat53
Maintainer: firecat53
Last Packager: firecat53
Votes: 46
Popularity: 0.423636
First Submitted: 2010-03-29 18:20
Last Updated: 2015-06-11 17:01

Latest Comments

firecat53 commented on 2015-07-13 17:44

pyasn1 dependency problem is solved with the python2-pyasn1-0.1.8-1 update today.

Scott

firecat53 commented on 2015-07-08 19:06

Comments from AUR (non-AUR4) that got lost in migration:

Comment by firecat53

2015-06-29 15:53

Yeah, I've had to pin the python2-pyasn1-modules package at 0.0.5 as well. The python2-pyasn1 package is flagged out of date and I'm hoping when that gets updated to 0.1.8 that the other packages dependent on it will also get updates that will fix this issue.

Comment by shioyama

2015-06-29 04:55

I just tried goobook today and got an error about a dependency on `pyasn1-modules==0.0.5`, so I downgraded [python-pyasn1-modules](https://www.archlinux.org/packages/extra/any/python-pyasn1-modules/) so I downgraded it from 0.0.6 to 0.0.5 and that seems to have fixed the issue.

firecat53 commented on 2015-06-03 15:03

Everything seems to be working now. PKGBUILD updated for new dependencies and the package was fixed to correct some build/run errors.

Scott

StreakyCobra commented on 2015-06-03 09:49

There seems to be missing dependencies: python2-httplib2 & python2-oauth2client

firecat53 commented on 2015-06-02 23:16

The new authentication system is live. There's a small bug in setup.py for which the fix hasn't been merged yet. I'll update this once that fix is in place.

Scott

steve1234 commented on 2015-05-28 15:05

The error as been reported:

https://gitlab.com/goobook/goobook/issues/52

steve1234 commented on 2015-05-28 14:15

I am seeing this error:
File "/usr/lib/python2.7/site-packages/gdata/service.py", line 1108, in Get
'reason': server_response.reason, 'body': result_body}
gdata.service.RequestError: {'status': 401, 'body': '<?xml version="1.0" encoding="UTF-8"?>\n<errors xmlns="http://schemas.google.com/g/2005">\n <error>\n <domain>GData</domain>\n <code>required</code>\n <location type="header">Authorization</location>\n <internalReason>Login Required</internalReason>\n </error>\n</errors>\n', 'reason': 'Unauthorized'}

Does goobook use OAuth2.0?

firecat53 commented on 2015-04-17 17:18

Thanks! Fixed.

TrialnError commented on 2015-04-17 15:24

The Upstream URL should be changed too. Nothing to see there except for the URL that links to the gitlab repo

firecat53 commented on 2015-03-17 06:27

Fixed, thanks. The author just renamed the repository yesterday.

Scott

loxley commented on 2015-03-17 06:15

To get this to build I had to change _gitname to 'goobook' and source to '.../goobook.git'.

firecat53 commented on 2015-03-12 17:40

Switched to https link on gitlab, as gitorious is going away soon.

Scott

nougad commented on 2015-03-07 20:02

What about switching sources to https:// protocol to avoid need of a ssh key for gitorious?

https://gitorious.org/goobook/mainline.git

firecat53 commented on 2013-08-26 01:18

Updated for python2-setuptools. Thanks!

Scott

the_isz commented on 2013-08-25 08:09

Until the change makes it upstream, I propose the following PKGBUILD which
contains the changes suggested by petelewis:

http://pastebin.com/N3Hzg5jZ

Kind regards

petelewis commented on 2013-08-20 08:09

Arch has just replaced python2-distribute with python2-setuptools.

To get this to build and work, I found that I had to:

1) Change the depepend and makedepend from python2-distribute to python2-setuptools.

2) Replace line 58 of setup.py:
'distribute',
with
'setuptools',

I guess this should/will probably make it upstream at some point, but then I have no knowledge of python packaging. HTH.

firecat53 commented on 2013-08-14 05:04

Thanks! Guess I should test in a clean environment....
Fixed.

Scott

loxley commented on 2013-08-13 06:16

Missing a dependency for python2-six also.

goobook
Traceback (most recent call last):
File "/usr/bin/goobook", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2850, in <module>
working_set.require(__requires__)
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 696, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 594, in resolve
raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: six

Installing it will fix it.

firecat53 commented on 2013-08-11 03:03

Updated goobook-git (1.5) and python2-hcs_utils (1.4rc5) to most recent releases. You shouldn't get any errors now. Thanks for the heads up.

Scott

geekinthesticks commented on 2013-08-07 16:43

Latest version seems to require hcs-utils>=1.3. However, when I update to hcs_utils 1.4rc5 I get the following error:

pkg_resources.DistributionNotFound: argparse>=1.1

I have updated my Arch, so all the python packages should be the latest version.

firecat53 commented on 2013-06-12 16:55

Fixed, thanks!

Scott

Stebalien commented on 2013-06-12 02:08

You should add the '--tags' flag to 'git describe'. As it is, it generates 'v1.2.85.gbf7eb0f' instead of '1.4.1.gbf7eb0f'.

firecat53 commented on 2013-05-23 02:41

Fixed, thanks!

Scott

bidossessi commented on 2013-05-23 01:16

Package fails to install with yaourt.
Starting pkgver()...
==> Updated version: goobook-git 1.4-1-gbf7eb0f.bf7eb0f-1
==> ERROR: pkgver is not allowed to contain colons, hyphens or whitespace.
My solution: append "| sed 's|-|.|g'" to last pkgver() line.

firecat53 commented on 2013-04-16 04:22

PKGBUILD updated for pacman 4.1 standards.

Scott

firecat53 commented on 2013-04-07 23:23

Thanks! I'll have a look at this and update as soon as I can. Appreciate the heads up!

Scott

poxar commented on 2013-04-07 09:27

Hey,

I've updated the PKGBUILD to use the new features of pacman 4.1

https://gist.github.com/anonymous/5329733

firecat53 commented on 2012-12-24 21:09

Fixed. Thanks :)

Scott

ISF commented on 2012-12-21 06:36

Hi,

Please change the reference to ${startdir}/pkg in line 39 to "${pkgdir}" (with quotes), otherwise packaging fails in yaourt when exporting packages to non-default locations.

firecat53 commented on 2012-11-12 19:59

Updated dependencies to python2-keyring and python2-hcs_utils. Note - AUR package python-hcs_utils renamed to python2-hcs_utils. I emailed a merge request to AUR-general.

Scott

ISF commented on 2012-11-12 12:40

Hi, please update the package to use python2-keyring instead of python-keyring (they will be merged soon).

Thanks

firecat53 commented on 2012-11-10 19:18

Fixed, thanks!

Scott

ervandew commented on 2012-11-10 02:11

Looks like python-simplejson is now python2-simplejson.

firecat53 commented on 2012-10-10 04:22

Fixed, thanks. If you've got python-gdata installed, make sure you uninstall it before installing goobook, which will install python2-gdata.

Scott

The-Compiler commented on 2012-10-09 20:04

python-gdata was renamed to python2-gdata it seems.

firecat53 commented on 2012-08-14 21:35

Well, I could probably figure it out, but as python-simplejson is available in community still, I'd rather not take the time right now to patch the original source...which still requires it. I'll keep an eye on it, though. It doesn't look like goobook has been updated in over a year now.

Scott

myle commented on 2012-08-14 11:02

Is python-simplejson required? I thought it was included in the main distribution of Python since Python 2.6.

firecat53 commented on 2011-10-10 17:51

Updated dependencies - python2-distribute instead of setuptools

firecat53 commented on 2010-11-03 09:22

python-hcs_utils is one of the dependencies in the PKGBUILD, but perhaps it needs reinstalling following the python2 change recently.

Scott

Anonymous comment on 2010-11-03 01:42

I also had the exact error message as ricklpt below, and I was able to correct it by installing

python-hcs_utils

firecat53 commented on 2010-11-01 17:14

Is python-keyring installed? If so, try reinstalling it.
Scott

Anonymous comment on 2010-11-01 09:49

When i install this package and run it i get the folloeing error message, i dont know if this is goobook-related but maybee its usefull to post here

.-(~)-------------------------------------------------------------------------------------
`--> goobook
Traceback (most recent call last):
File "/usr/bin/goobook", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2671, in <module>
working_set.require(__requires__)
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 654, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 552, in resolve
raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: keyring>=0.2

Rick

firecat53 commented on 2010-10-25 16:08

Ah, updated to remove python-argparse dependency.

Scott

cmb commented on 2010-10-25 07:49

Just remove python-argparse from depends=,
and all should be well. argparse is part of Python 2.7's standard
library.

firecat53 commented on 2010-10-19 17:58

Updated to reflect python2 dependency. Note -- until python-argparse is fixed, you have to change the depends line in that PKGBUILD to python2 (instead of python<2.7).

firecat53 commented on 2010-08-16 16:25

Added python-keyring dependency.

ejstacey commented on 2010-08-16 01:34

Just an FYI, this also requires python-keyring >= 0.2.

anpieber commented on 2010-04-23 06:02

seams to work fine. Thank you very much!

firecat53 commented on 2010-04-23 00:25

1. Added python-hcs_utils package to AUR (version 1.1.1)
2. Patched (temporarily, until python-argparse is updated) goobook source to only require argparse 1.0.1. I tested goobook and it seems to work with the lower version of argparse, but let me know if I'm wrong!

Scott

firecat53 commented on 2010-04-23 00:14

1. Added hcs_utils package to AUR (version 1.1.1)
2. Patched (temporarily, until python-argparse is updated) goobook source to only require argparse 1.0.1. I tested goobook and it seems to work with the lower version of argparse, but let me know if I'm wrong!

Scott

anpieber commented on 2010-04-22 07:44

ah ok found the required version: http://pypi.python.org/pypi/hcs_utils/1.0rc1

anpieber commented on 2010-04-22 07:31

ok, i know that always the latest version is used; but this case is different. Some additional references are required:

1) python-argparse (http://aur.archlinux.org/packages.php?ID=26000); but the package is in a lower version (1.0.1) than required by goobook (1.1). Nevertheless goobook also works with 1.0.1; I've flagged the python-argparse package out of date. We can wait for the python-argparse maintainer to upgrade his package or talk to the goobook maintainer to use the >1.0 version in the requirements

2) hcs_utils (git://gitorious.org/hcs_utils/mainline.git) Currently there is no aur package available for this reference. Besides two problems again: 1) version numbers do not match (1.0 in hcs_utils; 1.0rc1 required by goobook). 2) I'm no python expert and have no idea why this happen (I find nothing within the setup.py which can cause this behavior), but if i use sudo python setup.py install it produces a hcs_utils of version x.x.dev. Any ideas how I can get rid of it? @1) I'm going to write to the goobook mailing list @2) no idea, sry; otherwise I'll provide the hcs_utils package on my own

kind regards