Package Details: goobook-git 3.3.3.g79ae9a3-1

Git Clone URL: https://aur.archlinux.org/goobook-git.git (read-only, click to copy)
Package Base: goobook-git
Description: Search your google contacts from the command-line or mutt.
Upstream URL: https://gitlab.com/goobook/goobook
Licenses: GPL
Conflicts: goobook
Provides: goobook
Submitter: firecat53
Maintainer: firecat53
Last Packager: firecat53
Votes: 58
Popularity: 0.132624
First Submitted: 2010-03-29 18:20
Last Updated: 2020-07-02 19:48

Pinned Comments

firecat53 commented on 2020-09-03 00:06

FYI the latest goobook version requires the python xdg module. Until I can package it for the AUR and update the PKGBUILD, you will need to pip install --user xdg for goobook to continue working.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

petelewis commented on 2013-08-20 08:09

Arch has just replaced python2-distribute with python2-setuptools.

To get this to build and work, I found that I had to:

1) Change the depepend and makedepend from python2-distribute to python2-setuptools.

2) Replace line 58 of setup.py:
'distribute',
with
'setuptools',

I guess this should/will probably make it upstream at some point, but then I have no knowledge of python packaging. HTH.

firecat53 commented on 2013-08-14 05:04

Thanks! Guess I should test in a clean environment....
Fixed.

Scott

loxley commented on 2013-08-13 06:16

Missing a dependency for python2-six also.

goobook
Traceback (most recent call last):
File "/usr/bin/goobook", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2850, in <module>
working_set.require(__requires__)
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 696, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 594, in resolve
raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: six

Installing it will fix it.

firecat53 commented on 2013-08-11 03:03

Updated goobook-git (1.5) and python2-hcs_utils (1.4rc5) to most recent releases. You shouldn't get any errors now. Thanks for the heads up.

Scott

geekinthesticks commented on 2013-08-07 16:43

Latest version seems to require hcs-utils>=1.3. However, when I update to hcs_utils 1.4rc5 I get the following error:

pkg_resources.DistributionNotFound: argparse>=1.1

I have updated my Arch, so all the python packages should be the latest version.

firecat53 commented on 2013-06-12 16:55

Fixed, thanks!

Scott

Stebalien commented on 2013-06-12 02:08

You should add the '--tags' flag to 'git describe'. As it is, it generates 'v1.2.85.gbf7eb0f' instead of '1.4.1.gbf7eb0f'.

firecat53 commented on 2013-05-23 02:41

Fixed, thanks!

Scott

bidossessi commented on 2013-05-23 01:16

Package fails to install with yaourt.
Starting pkgver()...
==> Updated version: goobook-git 1.4-1-gbf7eb0f.bf7eb0f-1
==> ERROR: pkgver is not allowed to contain colons, hyphens or whitespace.
My solution: append "| sed 's|-|.|g'" to last pkgver() line.

firecat53 commented on 2013-04-16 04:22

PKGBUILD updated for pacman 4.1 standards.

Scott