Package Details: google-authenticator-libpam-git r120.c1b3879-1

Git Clone URL: https://aur.archlinux.org/google-authenticator-libpam-git.git (read-only, click to copy)
Package Base: google-authenticator-libpam-git
Description: PAM module for google authenticator app
Upstream URL: https://github.com/google/google-authenticator-libpam
Licenses: Apache
Conflicts: google-authenticator-libpam
Provides: google-authenticator-libpam
Submitter: calid
Maintainer: None
Last Packager: nylocx
Votes: 31
Popularity: 0.000000
First Submitted: 2012-03-31 22:39 (UTC)
Last Updated: 2016-11-10 17:03 (UTC)

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

Denton-L commented on 2018-09-01 21:23 (UTC)

We should change the conflicts and depends to 'libpam-google-authenticator' since that is the official package in [community].

Also, if possible, we should rename this package to 'libpam-google-authenticator-git' to match.

vonpupp commented on 2017-09-29 20:55 (UTC)

Hi, armv6 is not currently supported on the pkgbuild. It would be possible to add it please. I had to manually modify the pkgbuild and build it manually. It seems to work fine. Thx

francoism90 commented on 2016-05-14 08:11 (UTC)

Hi nylocx, Everytime I upgrade this package, the message 'you need to run # libtool --finish /usr/lib/security to finish the installation'. Maybe an .install file should be added, that automatically performs this task. :) Thanks.

commented on 2016-05-09 20:45 (UTC)

Just don't make the mistake of marking it as arch=('any') — it may work on just about any arch, but it's not architecture-independent.

Fr_nk commented on 2016-05-09 20:42 (UTC) (edited on 2016-05-09 20:43 (UTC) by Fr_nk)

Works on any arch, really ;-) (tested armv6h)

nylocx commented on 2016-02-26 07:26 (UTC)

Hi, I updated the package but only could test it on an RPi B. Hope this will work for most people.

frohman commented on 2016-02-26 01:56 (UTC)

Can you mark this package as working for the 'armv7h' arch? This will allow the package to be installed on the Raspberry PI 2, which it works fine on.

francoism commented on 2015-08-25 09:28 (UTC)

Thanks for providing this package. :) See Wiki (https://wiki.archlinux.org/index.php/Google_Authenticator) for configuration details, etc. Working OK here with ssh authentication. :)

nylocx commented on 2015-05-29 12:26 (UTC)

Done, I hope it's ok like this. If you need any more changes or comments let me know.

calid commented on 2015-05-29 11:33 (UTC)

nylocx would you mind submitting a pull request at https://github.com/calid/aur-google-auth-libpam-git?

nylocx commented on 2015-04-13 13:42 (UTC)

Hi, I updated this package to the "new" github repo and tried to clean it up a bit. I'm not sure if it is any better now but you can get my version at: http://dpaste.com/01MT5Q4

calid commented on 2013-10-04 05:26 (UTC)

fixed, thanks for the heads up.

swiftgeek commented on 2013-10-04 05:10 (UTC)

But dummy pkgver is needed now for just date pkgver() { date +%Y%m%d } https://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines#Fallback

calid commented on 2013-10-04 05:08 (UTC)

New version 20131003-1 * PKGBUILD updated with arch=any * github repo created at https://github.com/calid/aur-google-auth-libpam-git sorry for delayed replies to comments, my email filtering was messed up and I never check this page, but the problem has been resolved.

calid commented on 2013-10-04 04:08 (UTC)

any additional justification for renaming? This module was first, and in fact the name was modeled off the hg version which preceded it. I'm not opposed to a rename, but if anything libpam-google-authenticator should have modeled its name after the previous two existing packages...

jleclanche commented on 2013-06-03 10:54 (UTC)

This should be renamed to libpam-google-authenticator-git to be in line with https://aur.archlinux.org/packages/libpam-google-authenticator/.

alucryd commented on 2013-02-16 22:56 (UTC)

merging into git version

haawda commented on 2013-02-16 21:00 (UTC)

A TU can delete packages. Send a mail to aur-general.

zosodk69 commented on 2012-12-08 20:56 (UTC)

Works great on Arm (Raspberry Pi). You're probably good to set arch to any.

commented on 2012-06-06 23:33 (UTC)

They switched the version control system to Git so this PKGBUILD no longer works. Someone else already made a new one so you probably want to use that one: https://aur.archlinux.org/packages.php?ID=58094 (Is there a way to deprecate or delete AUR packages?)

commented on 2012-06-06 22:24 (UTC)

Getting "HTTP Error 404: Not Found" running makepkg: $ makepkg -s ==> WARNING: Cannot find the hg binary required to determine latest hg revision. ==> Making package: google-authenticator-libpam-hg 93-1 (Wed Jun 6 15:22:50 PDT 2012) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Installing missing dependencies... resolving dependencies... looking for inter-conflicts... Targets (2): mercurial-2.2.2-1 subversion-1.7.5-2 Total Installed Size: 43.79 MiB Proceed with installation? [Y/n] y (2/2) checking package integrity [##############################] 100% (2/2) loading package files [##############################] 100% (2/2) checking for file conflicts [##############################] 100% (2/2) checking available disk space [##############################] 100% (1/2) installing mercurial [##############################] 100% Optional dependencies for mercurial tk: for the hgk GUI (2/2) installing subversion [##############################] 100% Optional dependencies for subversion libgnome-keyring kdeutils-kwallet bash-completion: for svn bash completion python2: for some hook scripts ==> Retrieving Sources... ==> Extracting Sources... ==> Starting build()... ==> Connecting to Mercurial server.... warning: google-authenticator.googlecode.com certificate with fingerprint fd:02:92:b1:b3:32:27:f4:7b:40:3d:0a:ca:9e:dd:ee:22:17:52:02 not verified (check hostfingerprints or web.cacerts config setting) abort: HTTP Error 404: Not Found ==> ERROR: A failure occurred in build(). Aborting...

gdamjan commented on 2012-05-24 01:26 (UTC)

Since the "usrmove", PAM modules are now in /usr/lib/security not in /lib/security. The PKGBUILD needs to be updated

calid commented on 2012-05-05 22:11 (UTC)

didn't ln, just moved it since that's where everything else is now

xjpvictor commented on 2012-05-05 05:02 (UTC)

please ln pam_google_authenticator.so into /usr/lib/security/ for pam 1.1.5-3. thanks

commented on 2011-12-26 11:03 (UTC)

Updated the PKGBUILD. Have fun!

wanderxjtu commented on 2011-12-26 05:15 (UTC)

remove the makefile.patch and it works.

felixonmars commented on 2011-12-22 15:34 (UTC)

I'm getting this now: patching file libpam/Makefile Hunk #1 FAILED at 55 1 out of 1 hunks FAILED -- saving rejects to file libpam/Makefile.rej abort: patch failed to apply

Alibloke commented on 2011-12-08 09:13 (UTC)

There's a missing dependency for subversion in the PKGBUILD, if subversion isn't installed you get the error: abort: 'svn' executable not found for subrepo 'mobile/ios/externals/google-toolbox-for-mac'

commented on 2011-08-29 04:21 (UTC)

Oh come on Google... They have added two huge SVN repos as Mercurial subrepos. They are completely unrelated to the pam module but I don't know if theres a way to prevent Mercurial from checking them out. I'll try to find a work-around.

commented on 2011-08-28 03:20 (UTC)

It looks like subversion is necessary for the clone to succeed. Running hg -v --traceback clone https://code.google.com/p/google-authenticator Gave me a traceback where it was trying to call subversion. After installing subversion the clone would succeed.

commented on 2011-07-26 09:46 (UTC)

Updated the Makefile patch to work with the new upstream Makefile.

commented on 2011-07-25 12:24 (UTC)

I'm getting this with the latest version ==> Preparing build directory ==> Patching Makefile applying /tmp/google-authenticator-libpam-hg/src/makefile.patch patching file libpam/Makefile Hunk #1 FAILED at 45 1 out of 1 hunks FAILED -- saving rejects to file libpam/Makefile.rej abort: patch failed to apply ==> ERROR: A failure occurred in build(). Aborting...

commented on 2011-04-21 15:18 (UTC)

Uploaded a new version that fixes this problem. Have fun using it! ;)

pizzaman commented on 2011-04-21 12:57 (UTC)

I got this error when trying to install it. ==> Patching Makefile applying /var/abs/local/yaourtbuild/google-authenticator-libpam-hg/src/makefile.patch patching file libpam/Makefile Hunk #1 FAILED at 45 1 out of 1 hunks FAILED -- saving rejects to file libpam/Makefile.rej abort: patch failed to apply ==> ERROR: A failure occurred in build(). Aborting... ==> ERROR: Makepkg was unable to build google-authenticator-libpam-hg.

commented on 2011-03-07 22:23 (UTC)

Pro-tip, make sure you have your server syncing with ntp before using this. :)