Package Details: google-drive-ocamlfuse-git r430.aa926af-1

Git Clone URL: (read-only)
Package Base: google-drive-ocamlfuse-git
Description: FUSE filesystem backed by Google Drive, written in OCaml.
Upstream URL:
Licenses: MIT
Conflicts: google-drive-ocamlfuse
Provides: google-drive-ocamlfuse, google-drive-ocamlfuse-git
Submitter: EndlessEden
Maintainer: None
Last Packager: EndlessEden
Votes: 4
Popularity: 0.108937
First Submitted: 2017-01-02 15:38
Last Updated: 2017-01-02 15:38

Dependencies (5)

Required by (1)

  • bups (requires google-drive-ocamlfuse) (optional)

Sources (1)

Latest Comments

TZ86 commented on 2018-01-12 10:20


mobarre commented on 2018-01-02 12:52

Outdated build method. doesn't exist anymore. author switch to jbuilder. See here:

danny8376 commented on 2017-11-23 03:21

I think all dependencies there should be make dependencies.
ocaml is only used when building binary.

The only real dependency is sqlite.

RenatoXSR commented on 2017-11-19 17:35

Just built package with updated dependencies (had to manually update ocaml and ocamlnet to newer versions) and it worked. However, there was some permission issue which I fixed by manually copying the built google-drive-ocamlfuse file to /usr/bin.

EndlessEden commented on 2017-08-16 00:36

@10ne1: sorry it was just pulled out of aur3 mothballing for those who needed it.

Feel free to send me patches or requests. i will update it. but i dont have time to continuously maintain this alone.

olsonpm commented on 2017-04-23 15:45

regarding the symlink fix, for some reason camlidl was already a directory so my fix (using zsh-specific syntax, and `setopt extended_glob`)

ln -s /usr/lib/ocaml/^camlidl /usr/lib/ocaml/camlidl

10ne1 commented on 2017-01-04 13:31

Here's a fix for the gapi_ocaml problem, you can add my remote and pull it if you want.

10ne1 commented on 2017-01-03 21:57

This package has two problems

First, at build it errors with:
W: Field 'pkg_gapi_ocaml_version_ge_0_2_14' is not set: Cannot satisfy version constraint on pkg_gapi_ocaml: >= 0.2.14 (version: 0.2.10)

Can you please depend on gapi-ocaml-git instead of gapi-ocaml to fix it?

Second, it doesn't find its indirect dependencies files for camlidl, it expects them to be in /usr/lib/ocaml/camlidl/ but the AUR camlidl pkg installs them under /usr/lib/ocaml/. I've fixed it with 'ln -s /usr/lib/ocaml/ /usr/lib/ocaml/camlidl'. Can you please look into fixing this?

Thank you!