Package Details: google-webdesigner 1.7.0.1114-2

Git Clone URL: https://aur.archlinux.org/google-webdesigner.git (read-only)
Package Base: google-webdesigner
Description: Create engaging, interactive HTML5-based designs and motion graphics that can run on any device.
Upstream URL: https://www.google.com/webdesigner
Licenses: custom:webdesigner
Provides: google-webdesigner=1.7.0.1114
Submitter: jvybihal
Maintainer: jvybihal
Last Packager: jvybihal
Votes: 54
Popularity: 1.982394
First Submitted: 2014-04-22 19:09
Last Updated: 2016-11-18 13:20

Latest Comments

robrunner commented on 2016-11-18 13:27

Now it works. Thank you!

jvybihal commented on 2016-11-18 13:21

@robrunner try now please. PKGBUILD was updated.

robrunner commented on 2016-11-18 13:10

Using yaourt I get the following error:

==> Retrieving sources...
-> Downloading google-webdesigner_current_amd64.deb...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 29.9M 100 29.9M 0 0 6320k 0 0:00:04 0:00:04 --:--:-- 6476k
==> Validating source files with md5sums...
google-webdesigner_current_amd64.deb ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build google-webdesigner.

jvybihal commented on 2016-05-12 06:16

Thank you City-busz, you were absolutely correct.

City-busz commented on 2016-05-11 21:15

@jvybihal, you should update the .SRCINFO file when you update the package with the following command:
makepkg --printsrcinfo > .SRCINFO

j1simon commented on 2016-05-11 20:05

It's true. The problem is only with pacaur.

jvybihal commented on 2016-05-11 19:49

I am not familiar with pacaur, but I do not see any problem using yaourt.

http://pastebin.com/AVjW5Rg8


I will investigate anyway.

j1simon commented on 2016-05-11 19:37

It doesn't work:
$ pacaur -y google-webdesigner
:: resolving dependencies...
:: looking for inter-conflicts...

AUR Packages (1): google-webdesigner-1.5.1.1118-1

:: Proceed with installation? [Y/n]

:: Retrieving package(s)...
:: Checking google-webdesigner integrity...
:: Building google-webdesigner package(s)...
:: Installing google-webdesigner package(s)...
:: google-webdesigner package(s) failed to install. Check .SRCINFO for mismatching data with PKGBUILD.

jvybihal commented on 2016-05-05 06:48

Updated. Thanks @smrqdt.

i686 seems to be no longer supported, so I removed it from PKGBUILD.

moassma commented on 2016-03-17 19:12

404!

romgrk commented on 2016-02-12 23:49

Hi :)
I have a solution for the blank screen.
So when I got this (the blank screen), I ran a «strace -o ./sample.log -p» (I call it «sample» cause they have that on the pretty machines), and there was some errors about a ENOACCESS for a file in ~/.local/share/google-web-designer/data/CEF/Dictionaries/ folder.

Therefore, I booted a Debian machine on VirtualBox,
which was able to install GWD from the google .deb package,
which later generated all the user data.
Among which, a file called:
/home/romgrk/.local/share/google-web-designer/data/CEF/Dictionaries/en-US-6-1.bdic

I then copied back the whole ~/.local/share/google-web-designer directory (not just the file ― but I can't assert anything about the utility or inutility of the whole folder) from the virtual-Debian machine HD to the Arch HD, in my actual ~/.local/share folder.

Maybe someone with IT (the blank screen) could try copying the data/CEF/Dictionaries/en-US-6-1.bdic file (and/or, *afterwards*, the whole cache directory if it fails, and/or the whole google-web-designer directory) that I will provide below, and make a report to see about how it goes.

https://github.com/romgrk/our-parliament/blob/master/google-web-designer.zip
(please dont mind the repo)

Wesley_Chan commented on 2016-01-28 04:49

Is this doing any better?
http://pastebin.com/AhypLUu6

By the way, it may need google-chrome or opera to work. Mine only has firefox installed and it shows nothing but a blank window.

City-busz commented on 2016-01-25 19:53

It doesn't work for me. It just display a blank window.

snblg commented on 2015-11-19 08:15

Cannot install new version 1.5.0 with yaourt :
ERREUR : Un ou plusieurs fichiers sont invalides !
ERROR : One or more files are invalid !

I suppose I have to wait, because the 1.5.0 release is brand new ( yesterday )

I installed it succesfully 2 weeks agao, and GWB version was 1.4.2.0915, not 1.3.0 as mentionned.

jvybihal commented on 2015-11-03 14:39

thaz0th flagegd this package out-of-date, but I did not receive any explanation for this step, even when explicitly asking. So I unflagged it, I do not find it out-of-date and PKGBUILD works fine.

jvybihal commented on 2015-05-20 07:28

Yeah, works here fine too. It was probably some temporary glitch at my side.

FernandoBasso commented on 2015-05-19 21:46

1.3.0.0410 just worked fine here. Perhaps mv'ing the config files away would help?

jvybihal commented on 2015-04-15 07:46

Updated to 1.3, but when I run it, I only have black screen, similar to probles described in google-chrome-dev AUR page.

mzneverdies commented on 2015-04-14 20:58

md5sum fails, at least for 64bits .deb. Sum should be cc439889f3cc0cf47a85faf2e523832e

rabcor commented on 2015-03-31 22:26

My keyboard is not working properly in this program.

Thread: https://bbs.archlinux.org/viewtopic.php?pid=1515929

jvybihal commented on 2014-12-22 11:48

Updated. Thanks guys for reminding me and sorry for the delay.

Kuci commented on 2014-12-21 10:02

Version 1.2.0.1203 is out, doesn't require libgcrypt15 and still requires libudev.so.0.

Alomsimoy commented on 2014-12-09 20:28

Flagged as out of date, md5 checksums need to be updated.

mysnk commented on 2014-08-08 18:15

Package requires gconf.

madwifi commented on 2014-08-06 05:31

doesn't work with google-chrome package (AUR) as it's binary is created as google-chrome-stable

adding this line to the PKGBUILD package function should work

[ ! -f /usr/bin/google-chrome ] && [ -f /usr/bin/google-chrome-stable ] && ln -s /usr/bin/google-chrome-stable "${pkgdir}"/usr/bin/google-chrome || true

NOTE:
1. The same will apply for google-chrome-beta channel users
2. Maybe some more intelligent detection should be done here if there's variants of google chrome or firefox

PS: the google-webdesigner checks for google-chrome not for chrome so changes should be done to this too.

jvybihal commented on 2014-08-01 06:39

Thanks for notice, updated.

kylebaked commented on 2014-07-31 22:50

Flagged as out of date, md5 checksums need to be updated:

a13898e5285d663db8d334590d5c7e87 google-webdesigner_current_i386.deb
345a52e808e8df2cc4bf3b6759051637 google-webdesigner_current_amd64.deb

m1d1 commented on 2014-06-16 23:01

Using KDE I fixed my blank white window bug by installing gnome (pacman -S gnome). https://groups.google.com/forum/#!topic/gwdbeta/9OFdbYWYEss

jvybihal commented on 2014-05-02 06:22

That is so weird. I am sure I didn't change the checksums in the PKGBUILD, and they are still the same, BUT version in program iteslf changed. That is so weird, that the package changed but md5sums are the same. I was probably drunk or something, oherwise I can not explain this xD

alumni commented on 2014-05-01 22:31

I've just installed it. The package says 1.0.5, but when I open the application it's 1.0.6.

The problem I have is that the main window is a tool window, not a regular window. I cannot maximize it and I cannot make it smaller then the default size.

karaytanto commented on 2014-05-01 12:32

I unfortunately don't.

jvybihal commented on 2014-05-01 06:51

Do you have download link? The download button gives me still the old version with this hash f5e9d79fcd714c2ca45da52c80cc2494 (x64).

karaytanto commented on 2014-05-01 00:08

New version 1.0.6.0428 : https://support.google.com/webdesigner/answer/6000285

Stas_pythonist commented on 2014-04-24 16:55

Blank white window, even after LANGUAGE=en_US google-webdesigner... Wait until they fix this)

jvybihal commented on 2014-04-24 07:11

I have added Google Chrome Unstable && Firefox Nightly checks. If its installed, and /usr/bin/firefox or /usr/bin/chrome doesnt exist, it creates symlink.

# Google Chrome Dev
[ ! -f /usr/bin/chrome ] && [ -f /usr/bin/google-chrome-unstable ] && ln -s /usr/bin/google-chrome-unstable "${pkgdir}"/usr/bin/chrome || true

# Firefox Nightly
[ ! -f /usr/bin/firefox ] && [ -f /usr/bin/firefox-nightly ] && ln -s /usr/bin/firefox-nightly "${pkgdir}"/usr/bin/firefox || true

To the blank window: It's upstream issues, not sure right now if I can somehow fix it in PKGBUILD. I didn't experiance that problem myself, but LANGUAGE=en_US google-webdesigner seems to work for most of the people.

manasij7479 commented on 2014-04-24 02:58

It just shows a blank white window for me.
I have tried the locale fix, without effect.
Any idea what is going wrong?

chrisvella commented on 2014-04-24 00:41

google-webdesigner checks if firefox, google-chrome or opera are installed on the system. It fails to detect firefox-nightly and chromium.

For those using firefox nightly:
sudo ln -s /usr/bin/firefox-nightly /usr/bin/firefox


@JoZ3 thank you mate for the fix. I can confirm it works after running:
rm -r .local/share/google-web-designer
LANGUAGE=en_US google-webdesigner

latelx commented on 2014-04-24 00:19

@JoZ3 me,too, expcets it's grey blank window because of the different theme.

JoZ3 commented on 2014-04-23 22:46

Only shows a black window titled "Google web designer"

Temporal fix:

https://groups.google.com/forum/#!msg/gwdbeta/Le2uS92o8Is/NHlOB0hjVTIJ

jvybihal commented on 2014-04-23 16:01

remove that symlink, libgcrypt15 added as dependency

jvybihal commented on 2014-04-23 15:59

libgcrypt15 added as dependency

silvergeko commented on 2014-04-23 14:31

I have added the symbolic link libgcrypt.so --> libgcrypt.so.11 but now I have this error:

/usr/lib/libgcrypt.so.11: version `GCRYPT_1.2' not found (required by /opt/google/webdesigner/libcef.so)

jvybihal commented on 2014-04-23 12:26

Added the dependency, BUT keep in mind that symlinking like this is extremely UGLY and BAD thing. You should not do that.

Anyway, it works.


I will try to investigate further, if there is another way.

hcjl commented on 2014-04-23 12:10

@jvybihal
I have the same problem on 64bit. Installing the aur package you mentioned solved the problem. So please add it as a dependancy.
Thx & Rgds

jvybihal commented on 2014-04-23 06:05

using 32bit or 64bit?

In my environment:

└──> # >> file /usr/lib/libudev.so.0
/usr/lib/libudev.so.0: symbolic link to `/usr/lib/libudev.so'


Please try this https://aur.archlinux.org/packages/libudev.so.0/. If it will work for you, I will add it as dependency.

r3pek commented on 2014-04-23 02:29

Doesn't work:
$ google-webdesigner
google-webdesigner: error while loading shared libraries: libudev.so.0: cannot open shared object file: No such file or directory

jvybihal commented on 2014-04-22 19:10

I am learning how to make PKGBUILDs, this is far from perfect, but I am dedicated to make it better!