Package Details: gorm 1.2.28-1

Git Clone URL: https://aur.archlinux.org/gorm.git (read-only, click to copy)
Package Base: gorm
Description: GNUstep's easy-to-use interface designer
Upstream URL: http://www.gnustep.org/experience/Gorm.html
Licenses: GPL
Submitter: Beebo
Maintainer: Beebo
Last Packager: Beebo
Votes: 2
Popularity: 0.000000
First Submitted: 2021-05-10 13:16 (UTC)
Last Updated: 2021-06-10 20:12 (UTC)

Latest Comments

Beebo commented on 2021-06-10 19:55 (UTC) (edited on 2021-06-10 20:15 (UTC) by Beebo)

Sorry, this package flew under the radar after the merge happened. I've upgraded it now. I originally inherited it from a maintainer who left, but added the .app suffix to be consistent with Debian and their schema for denoting GNUstep apps. I don't remember if the original was gorm and I submitted a request to rename it or if there were 2 repos for the same thing.

Either way, somebody has renamed it to just gorm for now, which is terribly inconsistent.

micwoj92 commented on 2021-06-10 18:48 (UTC)

This is probably because this version is really out of date, latest version is 1.2.28. Download pkgbuild manually, change version to that and it should work.

Teripea commented on 2021-06-10 14:36 (UTC)

Building currently fails for me, throwing this error:

Making all for library GormCore...
 Compiling file GormClassManager.m ...
GormClassManager.m:33:10: fatal error: GNUstepBase/GSCategories.h: No such file or directory
   33 | #include <GNUstepBase/GSCategories.h>
      |          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.

Is that more likely a problem with upstream, the recipe, or my setup?