Package Details: gplaycli 3.24-1

Git Clone URL: https://aur.archlinux.org/gplaycli.git (read-only)
Package Base: gplaycli
Description: command line tool to search/install/update Android applications Google PlayStore able to run with cronjob, in order to automatically update an F-Droid server instance
Upstream URL: https://github.com/matlink/gplaycli
Licenses: AGPL
Submitter: fordprefect
Maintainer: fordprefect (lightdot)
Last Packager: fordprefect
Votes: 13
Popularity: 0.493683
First Submitted: 2016-04-22 21:01
Last Updated: 2018-09-10 15:25

Latest Comments

1 2 3 4 Next › Last »

kecef commented on 2018-07-21 13:36

You're right. Thanks for clarification.

doskoi commented on 2018-07-16 19:07

@kecef: It's python-gpapi that requires it, not gplaycli.

kecef commented on 2018-07-16 18:49

@doskoi: Why have you written that pycryptodome is not required? Without it gplaycli doesn't run at all.

Traceback (most recent call last): File "/usr/bin/gplaycli", line 6, in <module> from pkg_resources import load_entry_point File "/usr/lib/python3.6/site-packages/pkg_resources/init.py", line 3095, in <module> @_call_aside File "/usr/lib/python3.6/site-packages/pkg_resources/init.py", line 3079, in _call_aside f(args, *kwargs) File "/usr/lib/python3.6/site-packages/pkg_resources/init.py", line 3108, in _initialize_master_working_set working_set = WorkingSet._build_master() File "/usr/lib/python3.6/site-packages/pkg_resources/init.py", line 570, in _build_master ws.require(requires) File "/usr/lib/python3.6/site-packages/pkg_resources/init.py", line 888, in require needed = self.resolve(parse_requirements(requirements)) File "/usr/lib/python3.6/site-packages/pkg_resources/init.py", line 774, in resolve raise DistributionNotFound(req, requirers)</module></module>

pkg_resources.DistributionNotFound: The 'pycryptodome' distribution was not found and is required by gpapi

doskoi commented on 2018-04-08 00:35

python-pycryptodome, python-pyopenssl, python-requests, python-protobuf and python-clint are not required.

lightdot commented on 2018-02-16 04:32

gplaycli demands specific gpapi versions and besides that, the upstream has made a couple of typos in the past that caused wrong package versions to be reported or requested, effectively breaking gplaycli for prolonged periods of time. All in all, gplaycli in AUR often doesn't work without patching upstream sources for either gplaycli or python-gpapi.

@fordprefect, I'm using gplaycli regularly and I'm more than willing to co-maintain or take over both gplaycli and python-gpapi if you wish.

fordprefect commented on 2018-02-10 10:08

@kyak: I have the same issue, even when gpapi 0.4.1 is installed. I am quite low on time atm, but will try to take this upstream…

kyak commented on 2018-02-10 04:52

pkg_resources.DistributionNotFound: The 'gpapi==0.4.1' distribution was not found and is required by GPlayCli

gpapi 0.4.2 from AUR is installed here..

fordprefect commented on 2017-11-23 07:44

Issue is under investigation (upstream bug report opened).
Meanwhile I switched over to non-git versioned dependency for pyaxmlparser (minor change).

tengu commented on 2017-11-20 15:37

@fordprefect: Yes, I am on version local/gplaycli 3.10-1

fordprefect commented on 2017-11-20 12:50

@tengu: are you on the latest version?