Package Details: gpredict 1.3-3

Git Clone URL: https://aur.archlinux.org/gpredict.git (read-only)
Package Base: gpredict
Description: Real-time satellite tracking and orbit prediction application
Upstream URL: http://gpredict.oz9aec.net/
Licenses: GPL
Submitter: Allan
Maintainer: CarstenF
Last Packager: CarstenF
Votes: 26
Popularity: 0.080395
First Submitted: 2008-12-19 03:39
Last Updated: 2015-06-11 06:42

Latest Comments

CarstenF commented on 2014-07-14 15:35

Hello Everybody,

I have updated the PKGBUILD and changed the depency from goocanvas to goocanvas1.
I have also updated grig. Now both should work.
Have a lot of fun :-)

vy73 DL1CAF

skgsergio commented on 2014-03-29 11:09

Please remove grig as dep and change goocanvas to goocanvas1

skgsergio commented on 2014-03-29 11:09

Please remobe grig as dep and change goocanvas to goocanvas1

kstripp commented on 2014-02-01 18:16

Same problem with building grig as others, but GPredict does even depend on grig.

Simply removing grig from the dependency list solves the problem.

limaunion commented on 2013-11-22 01:15

I'm having the same problem as reported by einseenai, here's the output:

main.o: In function `main':
main.c:(.text.startup+0x80): undefined reference to `g_thread_supported'
collect2: error: ld returned 1 exit status
Makefile:367: recipe for target 'grig' failed
make[2]: *** [grig] Error 1
make[2]: Leaving directory '/tmp/yaourt-tmp-superuser/aur-grig/src/grig-0.8.0/src'
Makefile:381: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/tmp/yaourt-tmp-superuser/aur-grig/src/grig-0.8.0'
Makefile:288: recipe for target 'all' failed
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build .
==> Restart building grig ? [y/N]

Please I need some help on this, I need this package ASAP.
TIA

PS.: there's a new release (beta) of gpredict!

einseenai commented on 2013-06-05 16:15

Impossible to install due to a trouble with compiling grig.

CarstenF commented on 2013-05-04 18:42

Please change the dependency from goocanvas to goocanvas1

Thanks

z0id commented on 2012-09-28 22:23

Dependency on goocanvas has to be changed to goocanvas1.

einseenai commented on 2011-11-21 17:02

DL0, thanks so lot! Worked our like a charm :)

DL0 commented on 2011-11-20 22:48

I had the some problem as laganon and einseenai.

The solution is to install goocanvas1, available in community.

Until gpredict is updated to use goocanvas 2.0, change:

depends=('curl' 'grig' 'gtk2' 'goocanvas')
to
depends=('curl' 'grig' 'gtk2' 'goocanvas1')

in PKGBUILD

The program runs fine after compiling.

...Doug

lagagnon commented on 2011-11-13 17:20

Similar problem to einseenai, see pastebin below. Package will not build despite having goocanvas as required:
http://paste.pocoo.org/show/507269/

einseenai commented on 2011-11-12 11:48

Got the following while trying to install it - http://pastebin.com/DNAcKK3L - despite goocanvas package is installed on my system

einseenai commented on 2011-11-12 11:47

Got the following trying to build it - http://pastebin.com/DNAcKK3L - despite goonvas is installed on my system.

ur6lad commented on 2011-03-03 21:20

1.3

ur6lad commented on 2010-12-21 22:46

Gpredict in Linux Format January 2011 issue! http://twitpic.com/3i7099

ur6lad commented on 2010-10-12 20:14

1.2

> This release includes a new layout manager, satellite tooltips, improved
> interactivity, as well as fixes for many bugs discovered in the previous
> releases.