Package Details: gr-air-modes-git r376.514414f-1

Git Clone URL: https://aur.archlinux.org/gr-air-modes-git.git (read-only)
Package Base: gr-air-modes-git
Description: A software-defined radio receiver for Mode S transponder signals, including ADS-B reports from equipped aircraft.
Upstream URL: https://github.com/bistromath/gr-air-modes
Keywords: ADS-B GNURadio SDR
Licenses: BSD
Provides: gr-air-modes
Submitter: None
Maintainer: skgsergio
Last Packager: skgsergio
Votes: 3
Popularity: 0.023659
First Submitted: 2012-09-22 16:39
Last Updated: 2016-02-12 12:25

Dependencies (14)

Required by (1)

Sources (2)

Latest Comments

sangy commented on 2016-04-02 02:05

I seem to get the following errors from both upstream and this version:

Traceback (most recent call last):
File "/usr/local/bin/modes_rx", line 27, in <module>
import air_modes
File "/usr/local/lib/python2.7/site-packages/air_modes/__init__.py", line 50, in <module>
from air_modes_swig import *
ImportError: No module named air_modes_swig

skgsergio commented on 2015-04-23 13:32

Adopted and updated the package.
Needed to add a patch for detecting PyQt4, it will be removed when/if my pull request is accepted upstream: https://github.com/bistromath/gr-air-modes/pull/67

Also you can decide if you want it with GUI or without it by installing python2-pyqt4 and python2-pyqwt BEFORE installing this package or you will need to rebuild it.

I hope it's useful for someone :)

nickoe commented on 2013-11-24 12:11

Needs depend python2-pyzmq

martinpoljak commented on 2013-06-09 16:31

The 'python2-pyqt' dependency is presumably missing.

Anonymous comment on 2012-12-16 13:11

Fixed.
"make" replaced with "make -j1.
New build dep added.

Malvineous commented on 2012-12-15 10:04

Parallel builds are broken upstream <https://github.com/bistromath/gr-air-modes/issues/13> so this package fails with "No rule to make target `swig/air_modes_swig.py'" during compilation. Changing the "make" line to "make -j1" in the PKGBUILD fixes the problem.