Package Details: gradience-git 0.3.1.r2.ge5dd5c9-1

Git Clone URL: https://aur.archlinux.org/gradience-git.git (read-only, click to copy)
Package Base: gradience-git
Description: Change the look of Adwaita, with ease
Upstream URL: https://github.com/GradienceTeam/Gradience
Licenses: GPL3
Conflicts: adwcustomizer-git, gradience
Provides: gradience
Submitter: igor-dyatlov
Maintainer: igor-dyatlov (0xmrtt)
Last Packager: 0xmrtt
Votes: 6
Popularity: 0.027901
First Submitted: 2022-08-20 14:40 (UTC)
Last Updated: 2023-05-08 00:08 (UTC)

Latest Comments

1 2 Next › Last »

Tangdi commented on 2023-10-25 08:40 (UTC)

I fail to build this package with the following message

FAILED: data/ui
/usr/bin/blueprint-compiler batch-compile data/ui/. ../Gradience/data/ui ../Gradience/data/ui/error_list_row.blp ../Gradience/data/ui/palette_shades.blp ../Gradience/data/ui/option_row.blp ../Gradience/data/ui/window.blp ../Gradience/data/ui/monet_theming_group.blp ../Gradience/data/ui/app_type_dialog.blp ../Gradience/data/ui/custom_css_group.blp ../Gradience/data/ui/presets_manager_window.blp ../Gradience/data/ui/reset_preset_group.blp ../Gradience/data/ui/preferences_window.blp ../Gradience/data/ui/plugin_row.blp ../Gradience/data/ui/welcome_window.blp ../Gradience/data/ui/preset_row.blp ../Gradience/data/ui/builtin_preset_row.blp ../Gradience/data/ui/explore_preset_row.blp ../Gradience/data/ui/help_overlay.blp ../Gradience/data/ui/save_dialog.blp ../Gradience/data/ui/shell_prefs_window.blp ../Gradience/data/ui/shell_theming_group.blp ../Gradience/data/ui/repo_row.blp ../Gradience/data/ui/no_plugin_window.blp ../Gradience/data/ui/share_window.blp ../Gradience/data/ui/theming_empty_group.blp
error: Could not determine what kind of syntax is meant here
at ../Gradience/data/ui/error_list_row.blp line 4 column 10:
   4 |template $GradienceErrorListRow : ListBoxRow {
     |         ^

[27/28] Generating data/com.github.GradienceTeam.Gradience.appdata.xml with a custom command
ninja: build stopped: subcommand failed.
==> ERROR: A failure occurred in build().
    Aborting...
error: failed to build 'gradience-git-0.3.1.r2.ge5dd5c9-1':
error: packages failed to build: gradience-git-0.3.1.r2.ge5dd5c9-1

Any idea why this happens?

spacefall commented on 2023-08-08 18:44 (UTC)

The package doesn't build because the submodule's commit has been deleted(?) I "fixed" this by adding --remote to "git submodule update --init --recursive" in the PKGBUILD

HydroDiOxide commented on 2023-05-10 12:52 (UTC) (edited on 2023-05-10 13:11 (UTC) by HydroDiOxide)

UDPATE:

I was able to bypass the build error by running

git fetch
git submodule update --init --recursive

from the /.cache/yay/gradience-git directory

The issue below is SOLVED.

Build error. Please advise.

Build started at 2023-05-10T14:43:59.628215
Main binary: /usr/bin/python
Build Options: -Db_lto=true -Db_pie=true -Dprefix=/usr -Dlibexecdir=lib -Dsbindir=bin -Dauto_features=enabled -Dbuildtype=plain -Dwrap_mode=nodownload
Python system: Linux
The Meson build system
Version: 1.1.0
Source dir: /home/user/.cache/yay/gradience-git/src/Gradience
Build dir: /home/user/.cache/yay/gradience-git/src/build
Build type: native build
Project name: gradience
Project version: 0.4.1
Build machine cpu family: x86_64
Build machine cpu: x86_64
Host machine cpu family: x86_64
Host machine cpu: x86_64
Target machine cpu family: x86_64
Target machine cpu: x86_64
Program git found: YES (/usr/bin/git)
Pkg-config binary for 1 is not cached.
Pkg-config binary missing from cross or native file, or env var undefined.
Trying a default Pkg-config fallback at pkg-config
Found pkg-config: /usr/bin/pkg-config (1.8.1)
Determining dependency 'glib-2.0' with pkg-config executable '/usr/bin/pkg-config'
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --modversion glib-2.0` -> 0
stdout:
2.76.2
-----------
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --cflags glib-2.0` -> 0
stdout:
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/sysprof-4 -pthread
-----------
env[PKG_CONFIG_ALLOW_SYSTEM_LIBS]: 1
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --libs glib-2.0` -> 0
stdout:
-L/usr/lib -lglib-2.0
-----------
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --libs glib-2.0` -> 0
stdout:
-lglib-2.0
-----------
Run-time dependency glib-2.0 found: YES 2.76.2
Pkg-config binary for 1 is cached.
Determining dependency 'gtk4' with pkg-config executable '/usr/bin/pkg-config'
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --modversion gtk4` -> 0
stdout:
4.10.3
-----------
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --cflags gtk4` -> 0
stdout:
-I/usr/include/gtk-4.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/sysprof-4 -I/usr/include/harfbuzz -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/fribidi -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/graphene-1.0 -I/usr/lib/graphene-1.0/include -mfpmath=sse -msse -msse2 -pthread
-----------
env[PKG_CONFIG_ALLOW_SYSTEM_LIBS]: 1
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --libs gtk4` -> 0
stdout:
-L/usr/lib -lgtk-4 -lpangocairo-1.0 -lpango-1.0 -lharfbuzz -lgdk_pixbuf-2.0 -lcairo-gobject -lcairo -lgraphene-1.0 -lgio-2.0 -lgobject-2.0 -lglib-2.0
-----------
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --libs gtk4` -> 0
stdout:
-lgtk-4 -lpangocairo-1.0 -lpango-1.0 -lharfbuzz -lgdk_pixbuf-2.0 -lcairo-gobject -lcairo -lgraphene-1.0 -lgio-2.0 -lgobject-2.0 -lglib-2.0
-----------
Run-time dependency gtk4 found: YES 4.10.3
Pkg-config binary for 1 is cached.
Determining dependency 'libadwaita-1' with pkg-config executable '/usr/bin/pkg-config'
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --modversion libadwaita-1` -> 0
stdout:
1.3.2
-----------
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --cflags libadwaita-1` -> 0
stdout:
-I/usr/include/libadwaita-1 -I/usr/include/gtk-4.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/sysprof-4 -I/usr/include/harfbuzz -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/fribidi -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/graphene-1.0 -I/usr/lib/graphene-1.0/include -mfpmath=sse -msse -msse2 -pthread
-----------
env[PKG_CONFIG_ALLOW_SYSTEM_LIBS]: 1
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --libs libadwaita-1` -> 0
stdout:
-L/usr/lib -ladwaita-1 -lgtk-4 -lpangocairo-1.0 -lpango-1.0 -lharfbuzz -lgdk_pixbuf-2.0 -lcairo-gobject -lcairo -lgraphene-1.0 -lgio-2.0 -lgobject-2.0 -lglib-2.0
-----------
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --libs libadwaita-1` -> 0
stdout:
-ladwaita-1 -lgtk-4 -lpangocairo-1.0 -lpango-1.0 -lharfbuzz -lgdk_pixbuf-2.0 -lcairo-gobject -lcairo -lgraphene-1.0 -lgio-2.0 -lgobject-2.0 -lglib-2.0
-----------
Run-time dependency libadwaita-1 found: YES 1.3.2
Pkg-config binary for 1 is cached.
Determining dependency 'pygobject-3.0' with pkg-config executable '/usr/bin/pkg-config'
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --modversion pygobject-3.0` -> 0
stdout:
3.44.1
-----------
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --cflags pygobject-3.0` -> 0
stdout:
-I/usr/include/pygobject-3.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/sysprof-4 -pthread
-----------
env[PKG_CONFIG_ALLOW_SYSTEM_LIBS]: 1
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --libs pygobject-3.0` -> 0
stdout:
-L/usr/lib -lgobject-2.0 -lglib-2.0
-----------
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --libs pygobject-3.0` -> 0
stdout:
-lgobject-2.0 -lglib-2.0
-----------
Run-time dependency pygobject-3.0 found: YES 3.44.1
Pkg-config binary for 1 is cached.
Determining dependency 'libsoup-3.0' with pkg-config executable '/usr/bin/pkg-config'
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --modversion libsoup-3.0` -> 0
stdout:
3.4.2
-----------
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --cflags libsoup-3.0` -> 0
stdout:
-I/usr/include/libsoup-3.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/sysprof-4 -I/usr/include/libmount -I/usr/include/blkid -pthread
-----------
env[PKG_CONFIG_ALLOW_SYSTEM_LIBS]: 1
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --libs libsoup-3.0` -> 0
stdout:
-L/usr/lib -lsoup-3.0 -Wl,--export-dynamic -lgmodule-2.0 -pthread -lglib-2.0 -lgio-2.0 -lgobject-2.0 -lglib-2.0
-----------
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --libs libsoup-3.0` -> 0
stdout:
-lsoup-3.0 -Wl,--export-dynamic -lgmodule-2.0 -pthread -lglib-2.0 -lgio-2.0 -lgobject-2.0 -lglib-2.0
-----------
Run-time dependency libsoup-3.0 found: YES 3.4.2
Program python3 (lxml) found: YES (/usr/bin/python3) modules: lxml
Configuring constants.py using configuration
Configuring gradience using configuration
Configuring gradience-cli using configuration
Program blueprint-compiler found: YES (/usr/bin/blueprint-compiler)
Configuring com.github.GradienceTeam.Gradience.desktop.in using configuration
Program msgfmt found: YES (/usr/bin/msgfmt)
Program desktop-file-validate found: YES (/usr/bin/desktop-file-validate)
Adding test "Validate desktop file"
Pkg-config binary for 0 is not cached.
Pkg-config binary missing from cross or native file, or env var undefined.
Trying a default Pkg-config fallback at pkg-config
Found pkg-config: /usr/bin/pkg-config (1.8.1)
Determining dependency 'glib-2.0' with pkg-config executable '/usr/bin/pkg-config'
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --modversion glib-2.0` -> 0
stdout:
2.76.2
-----------
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --cflags glib-2.0` -> 0
stdout:
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/sysprof-4 -pthread
-----------
env[PKG_CONFIG_ALLOW_SYSTEM_LIBS]: 1
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --libs glib-2.0` -> 0
stdout:
-L/usr/lib -lglib-2.0
-----------
env[PKG_CONFIG_PATH]: 
Called `/usr/bin/pkg-config --libs glib-2.0` -> 0
stdout:
-lglib-2.0
-----------
Program glib-compile-resources found: YES (/usr/bin/glib-compile-resources)
Configuring com.github.GradienceTeam.Gradience.appdata.xml.in using configuration
Program appstream-util found: YES (/usr/bin/appstream-util)
Adding test "Validate appstream file"
Configuring com.github.GradienceTeam.Gradience.gschema.xml using configuration
Program glib-compile-schemas found: YES (/usr/bin/glib-compile-schemas)
Adding test "Validate schema file"

Gradience/data/meson.build:78:0: ERROR: Non-existent build file 'data/submodules/gnome-shell/meson.build'

niksingh710 commented on 2023-03-12 16:55 (UTC)

Okay so if someone facing errors in installation make sure to remove python-argparse and manually install python-cssutils and python-material-color-utilities

then clear paru or yay (or whatever aur helper u use) cache and proceed to install

ewout commented on 2022-12-21 13:52 (UTC)

Package creates stray files in $USER home directory.

0xmrtt commented on 2022-09-07 14:30 (UTC) (edited on 2022-09-07 14:31 (UTC) by 0xmrtt)

Hi,

I'm @0xMRTT, the maintainer of Gradience.

Can i become co-maintainer ?

I use Arch and i want to keep the PKGBUILD up to date

Thanks

rhysperry111 commented on 2022-09-02 00:50 (UTC) (edited on 2022-09-02 00:53 (UTC) by rhysperry111)

Not sure if I'm doing something wrong, but after installing this and trying to run gradience, I get this error:

Traceback (most recent call last):
  File "/usr/bin/gradience", line 64, in <module>
    from gradience import main
  File "/usr/lib/python3.10/site-packages/gradience/main.py", line 29, in <module>
    from .window import GradienceMainWindow
  File "/usr/lib/python3.10/site-packages/gradience/window.py", line 35, in <module>
    from .plugins_list import GradiencePluginsList
  File "/usr/lib/python3.10/site-packages/gradience/plugins_list.py", line 25, in <module>
    import pluggy
ModuleNotFoundError: No module named 'pluggy'

Installing python-pluggy changes the error to this:

Traceback (most recent call last):
  File "/usr/bin/gradience", line 64, in <module>
    from gradience import main
  File "/usr/lib/python3.10/site-packages/gradience/main.py", line 29, in <module>
    from .window import GradienceMainWindow
  File "/usr/lib/python3.10/site-packages/gradience/window.py", line 35, in <module>
    from .plugins_list import GradiencePluginsList
  File "/usr/lib/python3.10/site-packages/gradience/plugins_list.py", line 30, in <module>
    from plugins.hookspec import GradienceHooks
ModuleNotFoundError: No module named 'plugins'

Tracked it back to this commit which is fairly recent, so maybe things are temporarily broken?

Thanks for maintaining the package :)

0xmrtt commented on 2022-08-26 16:34 (UTC)

Hi,

Thanks for maintaing this AUR package. Do you want to be invited to GradienceTeam/Packages ?

Or do you want to contribute to the upstream? If something can be improved for Arch, tell me

0xmrtt commented on 2022-08-17 07:59 (UTC)

Hi, 👋

After a request from the GNOME team for changing the name, we moved the repo to HTTPS://GitHub.com/GradienceTeam/Gradience, the new name is Gradience and we are changing all names (the name change is not ready yet)