Package Details: grass6 6.4.6-1

Git Clone URL: https://aur.archlinux.org/grass6.git (read-only)
Package Base: grass6
Description: Geospatial data management and analysis, image processing, graphics/maps production, spatial modeling and visualization.
Upstream URL: https://grass.osgeo.org
Licenses: GPL
Submitter: czk
Maintainer: czk
Last Packager: czk
Votes: 3
Popularity: 0.013819
First Submitted: 2015-10-03 20:32
Last Updated: 2016-09-05 16:38

Latest Comments

ingleandrobarros commented on 2017-02-22 18:51

Bro, in GRASS6 when import a new project. i can't select EPGS code. Maybe, i have problem with GDAL? (but GRASS 7 allow select EPSG code). check that:

Unable to read EPGS codes: failed to open '/usr/local/share/proj/epsg'

ingleandrobarros commented on 2017-01-16 03:52

@czk

Thanks, now GRASS6 run perfectly!

czk commented on 2017-01-02 21:14

@ingleandrobarros

No such issue here. 3D view works fine in GRASS 6 for me.

Looks like you have somehow managed to remove your poppler installation. Which is strange, as normally you can't have GRASS installed without poppler, because the latter is a GDAL dependency, and GRASS requires GDAL.

The missing g.proj doesn't look normal either. It is one of core GRASS modules. You can't have a succesful GRASS build and installation without it.

I can only wonder what might have gone wrong with your setup. Update, reboot, build and install GRASS 6 anew and let me know how it went this time.

ingleandrobarros commented on 2017-01-01 01:54

GRASS 6.4.6 have ERROR:

~ > 3D view mode: libpoppler.so.66: cannot open shared object file: No such file or directory
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `gtk-primary-button-warps-slider' of type `gboolean' from rc file value "((GString*) 0x55ce57b2a7a0)" of type `gboolean'
GRASS module 'g.proj' not found. Unable to start map display window.

czk commented on 2016-04-18 16:42

@huorpalantir

Can't reproduce that. grass6 builds and installs fine for me on an up-to-date system. Make sure your system is updated and try building again. If the issue persists try looking for a hint in src/grass-6.4.5/config.log near the GDAL-related section.

huorpalantir commented on 2016-04-18 13:03

Build configure fails:
```
checking for regcomp... yes
checking whether to use Readline... yes
checking for location of Readline includes...
checking for readline/readline.h... yes
checking for readline/history.h... yes
checking for location of Readline library...
checking for readline in -lreadline... yes
checking for add_history in -lhistory... yes
checking whether to use GDAL... yes
checking for gdal-config... /usr/bin/gdal-config
configure: error: *** Unable to locate GDAL library.
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build grass6.
```