Package Details: gridtracker 1.24.0104-1

Git Clone URL: https://aur.archlinux.org/gridtracker.git (read-only, click to copy)
Package Base: gridtracker
Description: Companion program for WSJT-X for mapping contacts
Upstream URL: https://gridtracker.org/
Keywords: FT4 FT8 JT65 JT8 WSJT WSJT-X
Licenses: BSD
Replaces: gridtracker-bin
Submitter: classabbyamp
Maintainer: nr0q
Last Packager: nr0q
Votes: 12
Popularity: 0.46
First Submitted: 2020-10-13 23:22 (UTC)
Last Updated: 2024-01-06 15:45 (UTC)

Pinned Comments

Latest Comments

1 2 3 Next › Last »

nr0q commented on 2023-12-02 15:04 (UTC)

In re https://aur.archlinux.org/packages/gridtracker#comment-908330

This is a Chromium bug in the NWJS package, those look like debug messages that shouldn't cause GridTracker to not be able to run. The No net_fetcher for performing AIA chasing message has been around since as long as I've been involved in GT but doesn't stop anything from running. I've not seen the first two messages before.

john-WE1DER commented on 2023-11-23 18:09 (UTC)

Changing the following lines in PKGBUILD will allow update of GridTracker to 1.23.1112. pkgver=1.23.1112 sha256sums=('ae5c17a7c887fc0d5262234599de8113848a888fa545f712652296dc27ea14f8')

Modified pkgbuild and installed with makepkg and GridTracker is now running current version.

john-WE1DER commented on 2023-11-23 16:23 (UTC)

Flagged as out-of-date due to v1.23.1112 being available for download at the GridTracker website. https://gridtracker.org/index.php/documentation/change-log/v1-23-1112

simona commented on 2023-03-30 23:22 (UTC)

[19859:19859:0331/012214.756748:ERROR:gl_angle_util_vulkan.cc(189)] Failed to retrieve vkGetInstanceProcAddr [19859:19859:0331/012214.756786:ERROR:vulkan_instance.cc(91)] Failed to get vkGetInstanceProcAddr pointer from ANGLE.
[19825:19841:0331/012217.820198:ERROR:object_proxy.cc(622)] Failed to call method: org.freedesktop.DBus.StartServiceByName:object_path= /org/freedesktop/DBus: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
[19862:19866:0331/012221.912578:ERROR:cert_verify_proc_builtin.cc(600)] No net_fetcher for performing AIA chasing.

Misaka13514 commented on 2023-03-30 01:03 (UTC)

==> Validating source files with sha256sums... gridtracker-v1.23.0328.tar.gz ... FAILED ==> ERROR: One or more files did not pass the validity check!

should the hash be 8600877d415d0929bd65894cfeed33d44fe63e50b71355f1c8a7f893bbb4bc75?

simona commented on 2023-03-29 17:20 (UTC)

.cache/yay/gridtracker/PKGBUILD: riga 17: cd: /home/simona/.cache/yay/gridtracker/src/gridtracker-v1.23.0328/:File or directory not exist

swathe commented on 2021-05-08 10:35 (UTC) (edited on 2021-05-08 10:36 (UTC) by swathe)

EDIT: It appears Gitlab is in maintenance mode which could be preventing the download. Will verify once maintenance is over.

I am getting a 503 error when trying to curl the download URL for the tar file

==> Making package: gridtracker 1.21.0407-1 (Sat 08 May 2021 08:32:30 PM AEST) ==> Retrieving sources... -> Downloading gridtracker-v1.21.0407.tar.gz... % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 0 2330 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0 curl: (22) The requested URL returned error: 503 Warning: Problem : HTTP error. Will retry in 3 seconds. 3 retries left. 0 2330 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0 curl: (22) The requested URL returned error: 503 Warning: Problem : HTTP error. Will retry in 3 seconds. 2 retries left. 0 2330 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0 curl: (22) The requested URL returned error: 503 Warning: Problem : HTTP error. Will retry in 3 seconds. 1 retries left. 0 2330 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0 curl: (22) The requested URL returned error: 503 ==> ERROR: Failure while downloading https://gitlab.com/gridtracker.org/gridtracker/-/archive/v1.21.0407/gridtracker-v1.21.0407.tar.gz Aborting... :: Packages failed to build: gridtracker-1.21.0407-1

<deleted-account> commented on 2021-04-06 12:52 (UTC)

v1.21.0327 and now v1.21.0407 build fine now with no changes to the normal process.

<deleted-account> commented on 2021-03-25 01:26 (UTC)

Thanks for the advice.

For others that may be stuck:

cd
mkdir build && cd build
git clone https://aur.archlinux.org/gridtracker.git
cd gridtracker
makepkg -si

The last command will fail due to an error in the Makefile. Now remove the troublesome line from the Makefile and have it rebuild without extracting:

sed -i '/cp -r dist/d' src/gridtracker-v1.21.0322/Makefile 
makepkg -sie
cd
rm -fr build/

classabbyamp commented on 2021-03-24 22:42 (UTC)

@tobfromme should be fixed soon. for now, just remove that line from the makefile before building