Package Details: gridwars 9.3.2006-8

Git Clone URL: https://aur.archlinux.org/gridwars.git (read-only)
Package Base: gridwars
Description: Grid Wars 2: A clone of Geometry Wars
Upstream URL: http://gridwars.marune.de/
Licenses: GPL
Submitter: None
Maintainer: jorge_barroso
Last Packager: jorge_barroso
Votes: 79
Popularity: 0.000510
First Submitted: 2008-06-30 02:29
Last Updated: 2015-06-15 19:26

Dependencies (0)

Required by (0)

Sources (2)

Latest Comments

Getkey commented on 2015-09-30 10:45

Marco Incitti removed the zip with all the game file from his website.
Here is his explanation (from http://www.incitti.com/Blitz/index.html):
"Sorry folks... I've had to remove the link to the download.
Email from BizarreCreations:
"We're beginning to feel the effects of
the Geometry Wars clones on our sales via
Microsoft now and are beginning a process to
begin to more robustly protect our copyright
and intellectual property.
Therefore, I'd like to ask you in an amicable
fashion to stop infringing our IP and pull
the game 'Grid Wars' from the internet for download.
I hope you understand and are able to do this
without us having to take further steps.""

justin8 commented on 2014-06-17 12:14

Previous commenter is correct. This doesn't build without changes to the PKGBUILD

mezkov commented on 2014-01-19 18:20

Building this package don't work. It writes that it is not permitted to create directory "pkg" several times.

Solution is to put everything from build() function into package() function.

jorge_barroso commented on 2013-03-04 15:39

after looking for some information, I saw that which cares is to have something that owns libgl, so I've let libgl as sole dependency instead of mesa :)

jorge_barroso commented on 2013-03-03 12:23

I've made a check aswell (I have the open source ati drivers) and this is the command and output:

Pacman -Qo `ldd /usr/bin/gridwars | grep -o '/[^[:space:]]\+'` | grep mesa
/usr/lib32/libGL.so.1 is owned by lib32-mesa-libgl 9.1-2
/usr/lib32/libglapi.so.0 is owned by lib32-mesa 9.1-2

are you using nouveau or propietary drivers (as for your message I think there are the propietary ones)

jorge_barroso commented on 2013-03-03 11:44

thanks donbex, so I'm going to remove mesa as 'depend', I adopted gridwars at night and I'm not have time enough to check the package properly

donbex commented on 2013-03-03 11:07

The dependency on mesa doesn't seem to be required. On a system with the nvdia binary drivers ldd doesn't give any libraries owned by the mesa package:

$pacman -Qo `ldd /usr/bin/gridwars | grep -o '/[^[:space:]]\+'`
/usr/lib32/libX11.so.6 is owned by lib32-libx11 1.5.0-1
/usr/lib32/libGL.so.1 is owned by lib32-nvidia-utils 313.18-5
/usr/lib32/libGLU.so.1 is owned by lib32-glu 9.0.0-1
/usr/lib32/libXxf86vm.so.1 is owned by lib32-libxxf86vm 1.1.2-1
/usr/lib32/libstdc++.so.5 is owned by lib32-libstdc++5 3.3.6-6
/usr/lib32/libm.so.6 is owned by lib32-glibc 2.17-2
/usr/lib32/libpthread.so.0 is owned by lib32-glibc 2.17-2
/usr/lib32/libc.so.6 is owned by lib32-glibc 2.17-2
/usr/lib32/libxcb.so.1 is owned by lib32-libxcb 1.9-2
/usr/lib32/libdl.so.2 is owned by lib32-glibc 2.17-2
/usr/lib32/libnvidia-tls.so.313.18 is owned by lib32-nvidia-utils 313.18-5
/usr/lib32/libnvidia-glcore.so.313.18 is owned by lib32-nvidia-utils 313.18-5
/usr/lib32/libXext.so.6 is owned by lib32-libxext 1.3.1-1
/usr/lib32/libstdc++.so.6 is owned by lib32-gcc-libs 4.7.2-4
/usr/lib32/libgcc_s.so.1 is owned by lib32-gcc-libs 4.7.2-4
/lib/ld-linux.so.2 is owned by lib32-glibc 2.17-2
/usr/lib32/libXau.so.6 is owned by lib32-libxau 1.0.7-1
/usr/lib32/libXdmcp.so.6 is owned by lib32-libxdmcp 1.1.1-1

Anonymous comment on 2013-02-24 14:49

Package orphaned. Feel free to adopt.

pezcurrel commented on 2012-10-31 23:56

I get this error...

----
==> Starting build()...
/var/tmp/volatile/yaourt-tmp-gnucco/aur-gridwars/./PKGBUILD: line 17: cd: /var/tmp/volatile/yaourt-tmp-gnucco/aur-gridwars/src: No such file or directory
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build gridwars.
----

Line 17 is the 1st in the build block:
----
cd $startdir/src
----

I think it's related to the fact "$stardir" is deprecated.

I did a different package as release 7 of this same package, here is the source:
http://dl.dropbox.com/u/44746444/gridwars-9.3.2006-7.src.tar.gz

hcartiaux commented on 2011-07-11 13:34

I think the best idea is to not provide the game file. So I found a copy of the zip file for myself, and use a big part of worldofgoo PKGBUILD to improve gridwars PKGBUILD :
http://pastebin.archlinux.fr/433103

All comments