Package Details: grimshot 1.5.1-2

Git Clone URL: https://aur.archlinux.org/grimshot.git (read-only, click to copy)
Package Base: grimshot
Description: A helper for screenshots within sway.
Upstream URL: https://github.com/swaywm/sway
Licenses: MIT
Replaces: swaygrab
Submitter: WhyNotHugo
Maintainer: WhyNotHugo
Last Packager: WhyNotHugo
Votes: 6
Popularity: 1.28
First Submitted: 2020-05-01 08:22
Last Updated: 2021-01-01 12:27

Latest Comments

WhyNotHugo commented on 2021-01-01 12:27

Good hint, that's a lot simpler.

Updated.

cobaltspace commented on 2020-12-30 21:07

The sway package already has the grimshot file at usr/share/sway/scripts/grimshot, so because sway is a dependency, why not just make this use a symbolic link?

And then for the man page, just grab the file itself at https://raw.githubusercontent.com/swaywm/sway/1.5.1/contrib/grimshot.1 instead of the whole repo, or if you still want the man page generation in the PKGBUILD, https://raw.githubusercontent.com/swaywm/sway/1.5.1/contrib/grimshot.1.scd

Or, maybe grimshot-symlink should be a different package.

WhyNotHugo commented on 2020-05-04 12:49

Actually, mktemp is required for base, so no need to even list it at all. Thanks for pointing this out! Updated.

erazemk commented on 2020-05-04 12:11

WhyNotHugo: notify-send is provided by libnotify and mktemp is provided by codeutils, please update the dependency list (currently it shows like those two dependencies are not installed, even though they are).

I've created a patch: https://termbin.com/sun1 , which I can send over email if you want.