Package Details: grisbi 2.0.5-1

Git Clone URL: https://aur.archlinux.org/grisbi.git (read-only, click to copy)
Package Base: grisbi
Description: Shared files for the finance management program Grisbi.
Upstream URL: http://www.grisbi.org
Licenses: GPL
Conflicts: grisbi-git
Provides: grisbi
Replaces: grisbi
Submitter: None
Maintainer: FredBezies
Last Packager: FredBezies
Votes: 106
Popularity: 0.71
First Submitted: 2005-08-01 14:15 (UTC)
Last Updated: 2021-09-02 10:40 (UTC)

Latest Comments

FredBezies commented on 2021-02-24 09:45 (UTC)

@ennoia: it could be related indeed.

Ennoia commented on 2021-02-11 16:54 (UTC)

Hi, I've got a local repo. When doing a system upgrade, pacman asks me to reinstall grisbi again and again.( ver 2.0.1) Even when upgrading from 2.0.1 to 2.0.2, pacman had to suppress it before reinstalling. Something to do with the replace option of your PKGBUILD ?

sorbus commented on 2020-03-29 12:19 (UTC)

Hello,

Works fine after repo update

Thank you

sorbus commented on 2020-02-23 10:22 (UTC)

Hello,

Installation fails under manjaro mate 19.0...

Regards.

Details from pamac :

Préparation... Vérification des dépendances...

Désinstallation de blueman (2.1.1-2)... Exécution des crochets de post-transaction... Reloading system manager configuration... Arming ConditionNeedsUpdate... Reloading system bus configuration... Compiling GSettings XML schema files... Updating icon theme caches... Updating the desktop file MIME type cache... Transaction terminée avec succès.

Préparation... Vérification des dépendances... Avertissement : ecryptfs-utils peut nécessiter python2: for python module Avertissement : ffmpeg peut nécessiter ladspa: LADSPA filters Avertissement : firefox peut nécessiter networkmanager: Location detection via available WiFi networks Avertissement : grub peut nécessiter sdl: For grub-emu SDL support Avertissement : imagemagick peut nécessiter openexr: OpenEXR support Avertissement : jack peut nécessiter celt: NetJACK driver Avertissement : libmpeg2 peut nécessiter sdl: required for mpeg2dec Avertissement : libproxy peut nécessiter networkmanager: NetworkManager configuration module Avertissement : libproxy peut nécessiter python2: Python 2.x bindings Avertissement : lollypop peut nécessiter gst-plugins-bad: "Bad" plugin libraries Avertissement : mate-menus peut nécessiter python2: python2 bindings Avertissement : mpg123 peut nécessiter sdl: for sdl audio support Avertissement : net-snmp peut nécessiter python2: for the python modules Avertissement : networkmanager-openconnect peut nécessiter libnma: GUI support Avertissement : networkmanager-openvpn peut nécessiter libnma: GUI support Avertissement : networkmanager-pptp peut nécessiter libnma: GUI support Avertissement : networkmanager-vpnc peut nécessiter libnma: GUI support Avertissement : openconnect peut nécessiter python2: tncc-wrapper Avertissement : vlc peut nécessiter libdc1394: IEEE 1394 access plugin Avertissement : vlc peut nécessiter libgme: Game Music Emu plugin Avertissement : vlc peut nécessiter protobuf: chromecast streaming Avertissement : vlc peut nécessiter libdvdnav: DVD with navigation input module Avertissement : vlc peut nécessiter zvbi: VBI/Teletext/webcam/v4l2 capture/decoding Avertissement : vlc peut nécessiter libkate: Kate codec Avertissement : vlc peut nécessiter libtiger: Tiger rendering for Kate streams Avertissement : vlc peut nécessiter srt: SRT input/output plugin Avertissement : vlc peut nécessiter chromaprint: Chromaprint audio fingerprinter Avertissement : webkit2gtk peut nécessiter geoclue: Geolocation support Avertissement : webkit2gtk peut nécessiter gst-plugins-bad: media decoding Transaction annulée.

Préparation... Clonage des fichiers de construction de grisbi... Vérification des dépendances de grisbi... Résolution des dépendances... Recherche des conflits entre paquets...

Construction de grisbi... ==> Création du paquet grisbi 1.2.2-1 (dim. 23 févr. 2020 11:10:54 CET) ==> Vérification des dépendances pour l’exécution… ==> Vérification des dépendances pour la compilation… ==> Récupération des sources… -> grisbi-1.2.2.tar.bz2 trouvé -> bugfix-1898.patch trouvé ==> Validation des fichiers source avec sha256sums… grisbi-1.2.2.tar.bz2 ... Réussite bugfix-1898.patch ... Réussite ==> Suppression du répertoire $srcdir/ existant… ==> Extraction des sources… -> Extraction de grisbi-1.2.2.tar.bz2 avec bsdtar ==> Lancement de prepare()… patching file src/grisbi_win.c Reversed (or previously applied) patch detected! Assume -R? [n] Apply anyway? [n] Skipping patch. 1 out of 1 hunk ignored -- saving rejects to file src/grisbi_win.c.rej patching file src/gsb_assistant_file.c Reversed (or previously applied) patch detected! Assume -R? [n] Apply anyway? [n] Skipping patch. 3 out of 3 hunks ignored -- saving rejects to file src/gsb_assistant_file.c.rej patching file src/parametres.c Reversed (or previously applied) patch detected! Assume -R? [n] Apply anyway? [n] Skipping patch. 1 out of 1 hunk ignored -- saving rejects to file src/parametres.c.rej patching file src/structures.h Reversed (or previously applied) patch detected! Assume -R? [n] Apply anyway? [n] Skipping patch. 1 out of 1 hunk ignored -- saving rejects to file src/structures.h.rej ==> ERREUR : Une erreur s’est produite dans prepare(). Abandon…

FredBezies commented on 2019-12-16 21:14 (UTC)

bugfix-1898.patch seems to be not needed anymore.

patching file src/grisbi_win.c Reversed (or previously applied) patch detected! Assume -R? [n] Apply anyway? [n] Skipping patch. 1 out of 1 hunk ignored -- saving rejects to file src/grisbi_win.c.rej patching file src/gsb_assistant_file.c Reversed (or previously applied) patch detected! Assume -R? [n] Apply anyway? [n] Skipping patch. 3 out of 3 hunks ignored -- saving rejects to file src/gsb_assistant_file.c.rej patching file src/parametres.c Reversed (or previously applied) patch detected! Assume -R? [n] Apply anyway? [n] Skipping patch. 1 out of 1 hunk ignored -- saving rejects to file src/parametres.c.rej patching file src/structures.h Reversed (or previously applied) patch detected! Assume -R? [n] Apply anyway? [n] Skipping patch. 1 out of 1 hunk ignored -- saving rejects to file src/structures.h.rej

Fraaalesi commented on 2019-11-22 22:22 (UTC)

Update 2 hours later after a mail from Matthieu Froment (thanks !): it's only a Preferences setting in the "Completion" sub-menu. So no problem with Arch. Thanks Matthieu

Fraaalesi commented on 2019-11-22 20:16 (UTC) (edited on 2019-11-22 22:22 (UTC) by Fraaalesi)

I used to use Grisbi as provided in Ubuntu 18.04 and have now switched to Manjaro/ArchLinux so I use this version of Grisbi. I have a minor problem that was not present in Ubuntu, in case anyone has a solution: when entering a new transaction, when I select the payee, the categorie is not auto-filled anymore. It used to be autofilled with the category of the latest entry with this same payee

thanks !

ChrDr commented on 2019-01-27 21:17 (UTC)

Updated to version 1.2.0

ChrDr commented on 2017-06-13 21:41 (UTC)

Updated to version 1.0.2.

Nyutag commented on 2014-04-02 19:29 (UTC)

If anyone have trouble with the graph in the 1.0 like me, just install goffice0.8 and install grisbi again. I think you should add goffice0.8 in the optdepends for the graphic.

ChrDr commented on 2014-03-26 21:02 (UTC)

Updated to version 1.0.0.

molux commented on 2014-03-21 19:01 (UTC)

New stable version pkgver=1.0.0 md5sums=("d3d0b03b49f2c86b110910ec903630f2")

ChrDr commented on 2012-01-11 21:03 (UTC)

Updated to version 0.8.9. Seems that LDFLAGS="-lm" is not needed any longer.

ChrDr commented on 2011-12-24 09:43 (UTC)

@damien64: I do not get this error message, thus I can't really help you. Are all your packages up-to-date?

commented on 2011-12-22 18:00 (UTC)

For the compilation, it's OK but i've a bug at the start of program and the messages are: grisbi(traitement_sigsegv+0x169) [0x4437d9] /lib/libpthread.so.0(+0xf850) [0x7fcc78a06850] grisbi(gsb_file_util_get_contents+0xd1) [0x468581] grisbi(gsb_file_load_open_file+0xa6) [0x45e0f6] grisbi(gsb_file_open_file+0x7d) [0x45363d] grisbi(main+0x4c7) [0x43cf17] /lib/libc.so.6(__libc_start_main+0xed) [0x7fcc7869114d] grisbi() [0x43cfbd] But with xubuntu, the version 8.8 work normaly; then what is??? Best regard,

commented on 2011-12-22 16:33 (UTC)

I have find: if i open with a .gsb file, it's OK. sorry and thank you best regards

commented on 2011-12-22 16:28 (UTC)

For the compilation, it's OK but i've a bug at the start of program and the messages are: grisbi(traitement_sigsegv+0x169) [0x4437d9] /lib/libpthread.so.0(+0xf850) [0x7fcc78a06850] grisbi(gsb_file_util_get_contents+0xd1) [0x468581] grisbi(gsb_file_load_open_file+0xa6) [0x45e0f6] grisbi(gsb_file_open_file+0x7d) [0x45363d] grisbi(main+0x4c7) [0x43cf17] /lib/libc.so.6(__libc_start_main+0xed) [0x7fcc7869114d] grisbi() [0x43cfbd] But with xubuntu, the version 8.8 work normaly; then what is??? Best regard,

ChrDr commented on 2011-12-22 11:15 (UTC)

Seems that some arch update has introduced this compilation error. petit_lo shows the way to go. I have added "-lm" to the LDFLAGS now, too.

commented on 2011-12-22 09:43 (UTC)

I have a problem of compilation with this message: "/usr/bin/ld: ./.libs/libgrisbi.a(print_report.o): undefined reference to symbol 'ceil@@GLIBC_2.2.5' /usr/bin/ld: note: 'ceil@@GLIBC_2.2.5' is defined in DSO /lib/libm.so.6 so try adding it to the linker command line /lib/libm.so.6: could not read symbols: Invalid operation" It is a recent problem but for all versions (8.5-8.6-8.7-8.8 and also 9.3): upon update arch?? best regards,

commented on 2011-12-10 14:17 (UTC)

In build() function, I had to add the line export LDFLAGS="$LDFLAGS -lm" before ./configure command Best,

ChrDr commented on 2011-10-07 21:22 (UTC)

Updated to version 0.8.8.

LeCrayonVert commented on 2011-10-07 16:54 (UTC)

Please update to 0.8.8

LeCrayonVert commented on 2011-04-14 11:36 (UTC)

0.8.5 is out ;)

LeCrayonVert commented on 2011-03-15 11:03 (UTC)

ChrDr > 0.8.4 is available....

commented on 2011-03-09 19:35 (UTC)

Grisbi 0.8.3 available

ChrDr commented on 2011-02-25 12:29 (UTC)

Updated to version 0.8.2.

LeCrayonVert commented on 2011-02-22 21:49 (UTC)

Actually, it is 0.8.2...

LeCrayonVert commented on 2011-02-21 21:49 (UTC)

Grisbi 0.8.1 available.

commented on 2010-06-09 12:11 (UTC)

# Maintainer: Dab <dab@brospower.com> pkgname=grisbi pkgver=0.6.0 pkgrel=1 pkgdesc="Personal financial management program" url="http://www.grisbi.org" license="GPL" depends=('gtk2' 'libxml2' 'libofx') source=(http://prdownloads.sourceforge.net/grisbi/grisbi-$pkgver.tar.bz2) arch=('i686' 'x86_64') build() { cd $startdir/src/$pkgname-$pkgver ./configure --prefix=/usr make || return 1 make DESTDIR=$startdir/pkg install } md5sums=('19062be7f4f6ec29adda4ec09f0d626f')