Package Details: grub-customizer 5.0.6-1

Git Clone URL: https://aur.archlinux.org/grub-customizer.git (read-only)
Package Base: grub-customizer
Description: A graphical grub2 settings manager
Upstream URL: https://launchpad.net/grub-customizer
Keywords: config customize grub grub2
Licenses: GPL3
Provides: grub-customizer
Submitter: None
Maintainer: dvzrv
Last Packager: dvzrv
Votes: 212
Popularity: 8.671319
First Submitted: 2010-11-30 00:10
Last Updated: 2016-05-11 22:55

Latest Comments

dvzrv commented on 2016-09-29 14:47

@fusion809: Well, I guess that's something to report upstream, not here. Also, the current stable gtkmm3 version is 3.20.1 in the repos.

Thanks for the heads up nonetheless!

fusion809 commented on 2016-09-29 14:02

This package's build fails with gtkmm-3.22.0 (in gnome-unstable), giving this output:

==> Making package: grub-customizer 5.0.6-1 (Thu Sep 29 23:56:01 AEST 2016)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Found grub-customizer_5.0.6.tar.gz
-> Found grub.cfg
==> Validating source files with md5sums...
grub-customizer_5.0.6.tar.gz ... Passed
grub.cfg ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
-> Extracting grub-customizer_5.0.6.tar.gz with bsdtar
==> Entering fakeroot environment...
==> Starting package()...
==> Starting make...
-- The C compiler identification is GNU 6.2.1
-- The CXX compiler identification is GNU 6.2.1
-- Check for working C compiler: /usr/lib/hardening-wrapper/bin/cc
-- Check for working C compiler: /usr/lib/hardening-wrapper/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/lib/hardening-wrapper/bin/c++
-- Check for working CXX compiler: /usr/lib/hardening-wrapper/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.29.1")
-- Checking for module 'gtkmm-3.0'
-- Package 'gdk-3.0' requires 'gio-unix-2.0 >= 2.49.4' but version of gio-unix-2.0 is 2.48.2
-- Checking for module 'gthread-2.0'
-- Found gthread-2.0, version 2.48.2
-- Checking for module 'openssl'
-- Found openssl, version 1.0.2j
-- Checking for module 'libarchive'
-- Found libarchive, version 3.2.1
-- Configuring done
-- Generating done
-- Build files have been written to: /home/fusion809/AUR/grub-customizer/src/grub-customizer-5.0.6
Scanning dependencies of target grub-customizer
[ 12%] Building CXX object CMakeFiles/grub-customizer.dir/src/main/client.cpp.o
In file included from /home/fusion809/AUR/grub-customizer/src/grub-customizer-5.0.6/src/main/../Bootstrap/../Model/ListCfg.hpp:50:0,
from /home/fusion809/AUR/grub-customizer/src/grub-customizer-5.0.6/src/main/../Bootstrap/Factory.hpp:24,
from /home/fusion809/AUR/grub-customizer/src/grub-customizer-5.0.6/src/main/client.cpp:23:
/home/fusion809/AUR/grub-customizer/src/grub-customizer-5.0.6/src/main/../Bootstrap/../Model/SettingsManagerData.hpp: In static member function ‘static std::map<std::__cxx11::basic_string<char>, std::__cxx11::basic_string<char> > Model_SettingsManagerData::parsePf2(const string&)’:
/home/fusion809/AUR/grub-customizer/src/grub-customizer-5.0.6/src/main/../Bootstrap/../Model/SettingsManagerData.hpp:58:28: warning: ignoring return value of ‘char* fgets(char*, int, FILE*)’, declared with attribute warn_unused_result [-Wunused-result]
fgets(sizeBuf, 5, file);
^
/home/fusion809/AUR/grub-customizer/src/grub-customizer-5.0.6/src/main/../Bootstrap/../Model/SettingsManagerData.hpp:63:38: warning: ignoring return value of ‘char* fgets(char*, int, FILE*)’, declared with attribute warn_unused_result [-Wunused-result]
fgets(contentBuf, size + 1, file);
^
[ 25%] Building CXX object CMakeFiles/grub-customizer.dir/src/Bootstrap/GtkView.cpp.o
In file included from /home/fusion809/AUR/grub-customizer/src/grub-customizer-5.0.6/src/Bootstrap/GtkView.cpp:18:0:
/home/fusion809/AUR/grub-customizer/src/grub-customizer-5.0.6/src/Bootstrap/../View/Gtk/About.hpp:23:19: fatal error: gtkmm.h: No such file or directory
#include <gtkmm.h>
^
compilation terminated.
make[2]: *** [CMakeFiles/grub-customizer.dir/build.make:87: CMakeFiles/grub-customizer.dir/src/Bootstrap/GtkView.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:68: CMakeFiles/grub-customizer.dir/all] Error 2
make: *** [Makefile:128: all] Error 2
==> ERROR: A failure occurred in package().
Aborting...


dvzrv commented on 2016-05-11 23:03

Just updated to 5.0.6
It seems to work fine so far.

@Auphora: I'm not sure what your error relates to and you might want to report this upstream, not here. Also:
- it seems some picture is not where it's supposed to be
- something in the way you built this package seems very off. There should be no relation to some makepkg dir in tmp when running the application... how exactly did you build this package? I suggest this way: https://wiki.archlinux.org/index.php/Arch_User_Repository#Installing_packages

Auphora commented on 2016-03-28 12:15

@dvzrv Works good. Not sure what I've done wrong, but when I change my grub theme, click on one of the previews of that theme and change it afterwards I get this error message:
"exeptiopn '9Exception'
with message 'themefile boot_menu_e.png not found!'
in /tmp/makepkg/grub-customizer/src/grub-customizer-5.0.4/src/main/../Bootstrap/../Model/Theme.hpp:152"

I just installed it via makepkg. When changing the build path of makepkg the error message also changes to that path

dvzrv commented on 2016-03-28 11:22

Just updated to the 5.0 branch.
Please bake this and see if it works for you as intended.
So far I didn't have any problems.

dvzrv commented on 2016-03-22 16:04

@mister_karim: Not sure in what way you've installed your package, but you shouldn't be running anything from /tmp/yaourt after installing a package.

If your report is related to installing grub-customizer, use makepkg (https://wiki.archlinux.org/index.php/Arch_User_Repository#Installing_packages) instead of (possibly) broken AUR helper applications, which you might not understand entirely.

If your report is related to running the application, please report it upstream.

In any case, please refer to the wiki before posting here and make sure you actually did things the way they were intended.
I just built, installed and ran grub-customizer successfully.

mister_karim commented on 2016-03-22 00:40

Hi,
after running grub-customizer a got this error
---------------------------------------------------------
...
exception '28InvalidStringFormatException'
with message 'unable to parse index from /etc/grub.d/6_grub-customizer_menu_color_helper'
in /tmp/yaourt-tmp-karim/aur-grub-customizer/src/grub-customizer-4.0.6/src/Model/Script.cpp:276
exception '28InvalidStringFormatException'
with message 'unable to parse index from '
in /tmp/yaourt-tmp-karim/aur-grub-customizer/src/grub-customizer-4.0.6/src/Model/Script.cpp:276
exception '28InvalidStringFormatException'
with message 'unable to parse index from '
in /tmp/yaourt-tmp-karim/aur-grub-customizer/src/grub-customizer-4.0.6/src/Model/Script.cpp:276
....
---------------------------------------------------------
i tryed to reinstall it but i got the same error !

xx55tt commented on 2016-02-18 17:48

@Crandel: Rebuilding the package fixed it for me.

Crandel commented on 2016-01-23 06:25

(grub-customizer:6152): Gtk-CRITICAL **: gtk_image_menu_item_set_image: assertion 'GTK_IS_IMAGE_MENU_ITEM (image_menu_item)' failed

(grub-customizer:6152): Gtk-CRITICAL **: gtk_container_add: assertion 'GTK_IS_CONTAINER (container)' failed

(grub-customizer:6152): Gtk-CRITICAL **: gtk_accel_label_set_accel_widget: assertion 'GTK_IS_WIDGET (accel_widget)' failed

(grub-customizer:6152): Gtk-CRITICAL **: gtk_image_menu_item_set_image: assertion 'GTK_IS_IMAGE_MENU_ITEM (image_menu_item)' failed

(grub-customizer:6152): Gtk-CRITICAL **: gtk_container_add: assertion 'GTK_IS_CONTAINER (container)' failed

(grub-customizer:6152): Gtk-CRITICAL **: gtk_accel_label_set_accel_widget: assertion 'GTK_IS_WIDGET (accel_widget)' failed

(grub-customizer:6152): Gtk-CRITICAL **: gtk_image_menu_item_set_image: assertion 'GTK_IS_IMAGE_MENU_ITEM (image_menu_item)' failed

(grub-customizer:6152): Gtk-CRITICAL **: gtk_container_add: assertion 'GTK_IS_CONTAINER (container)' failed

(grub-customizer:6152): Gtk-CRITICAL **: gtk_accel_label_set_accel_widget: assertion 'GTK_IS_WIDGET (accel_widget)' failed
“sudo grub-customizer” terminated by signal SIGSEGV (Address boundary error)
Suddenly I`ve got this error and it not opened

Soukyuu commented on 2015-12-20 13:16

Hmm, I just freshly checked out the package and compiled it. Upon start, I'm being greeted with

exception '15AssertException'
with message 'Assertion `script != __null' failed. Function: _rAppendRule'
in /tmp/makepkg/grub-customizer/src/grub-customizer-4.0.6/src/Controller/MainControllerImpl.cpp:391

Anyone else getting this?

dvzrv commented on 2015-11-06 23:11

@mikafouenski: thx for the fix. I added it to the PKGBUILD.
@all: If you added "-std=c++11" to your /etc/makepkg.conf, you should remove it now!

Binero commented on 2015-11-06 19:48

@gusgmb glib.h seems to be a part of core/glib2, maybe try installing that?

gusgmb commented on 2015-11-06 17:26

I got an error compiling

[ 20%] Building CXX object CMakeFiles/grub-customizer.dir/src/Model/DeviceMap.cpp.o
In file included from /.../Downloads/grub-customizer/src/grub-customizer-4.0.6/src/Model/DeviceMap.h:23:0,
from /.../Downloads/grub-customizer/src/grub-customizer-4.0.6/src/Model/DeviceMap.cpp:19:
.../Downloads/grub-customizer/src/grub-customizer-4.0.6/src/Model/../lib/regex.h:24:18: fatal error: glib.h: File or directory not found

I followed koesherbacon instructions,and also tried via 'yaourt -S grub-customizer' but no deal.

Any ideas?
Thanks!

koesherbacon commented on 2015-10-31 20:48

I'd like to confirm that mikafouenski's solution worked for me as well. In case you're also a little new to linux like I am, here's some instructions to put into Terminal in order to get it working:

1) sudo cp /etc/makepkg.conf /etc/makepkg.conf.bak
↳ Makes a backup of makepkg.conf just in case. Call it whatever you want...
2) sudo leafpad /etc/makepkg.conf
↳ ...Or whatever editor you prefer. gedit, nano, vi, etc.
3) In the .conf file, add ' -std=c++11' to the end of CXXFLAGS="..." inside the quotation mark.
4) Save and exit the editor
5) yaourt -G grub-customizer
6) cd grub-customizer && makepkg -i
7) cd ..
8) rm -rf grub-customizer
9) cd
10) sudo grub-customizer

This probably would also work with 'yaourt -S grub-customizer' as well, but I already did 'yaourt -G grub-customizer' so I didn't bother installing it the other way.

mikhail21393 commented on 2015-10-30 20:29

@mikafouenski Man you are a life saver! It works! I don't know how to thank you! If anyone has the same error on this build! Then try this! :-)

mikafouenski commented on 2015-10-12 21:07

Ok, I had search a lot. I got the issue of the building error, I tried different version but still not working.
-> The problem was c++ 11
I solve the problem by adding the -std=c++11 flag to my /etc/makepkg.conf in the CXXFLAGS.
Since build OK for all version of the package.

dvzrv commented on 2015-03-24 22:53

Currentyl I don't have any system, that uses GRUB. That's most likely not going to change in the future.
If someone would like to adopt this package, please let me know! I'm about to drop it (as I can not properly test its functionality any longer and I'm not up for setting up a VM just for that ;) ).

ferrvittorio commented on 2014-11-11 15:01

Hi,
trying to install with yaourt and having problem with this not met dependency:
cannot download 'grub-1:2.02.beta2-4-x86_64.pkg.tar.xz' from archlinux.openlabto.org : The requested URL returned error: 404 Not Found

Any hints?

ryanmjacobs commented on 2014-06-02 02:52

@david.runge Sorry, for the very, very late response. Yes, it compiles just fine now. Thank you.

poincare commented on 2014-06-01 19:39

FYI: builds for me no problem. It also pulled in cmake and nothing else. Seems to run fine; just tested it.

caseyjp1 commented on 2014-05-24 06:41

Just built it a few minutes ago on a clean base / base-devel system. It only had to pull in cmake, and the build process worked just fine. fyi.

dvzrv commented on 2014-04-21 18:20

Updated to 4.0.6

@imaweasal @ryanjacobs: Is this still an issue for you guys?
Sorry, I can't be of more help. I was able to build it just fine using makepkg (even on 3 different systems/setups). Maybe you can provide more information about the kind of system you're using or even file a bug report upstream.

ryanmjacobs commented on 2014-03-16 17:31

@david.runge: I'm having the exact same problems as @imaweasel, verbatim. I went through every step you told him, and got the same results. If you ever found a solution please reply.

dvzrv commented on 2014-01-26 10:04

@imaweasel: write to me on freenode. I'm not so very sure I can really help you with your problem though.

imaweasal commented on 2014-01-26 07:49

@david.runge:

╭─epers@wintermute ~
╰─➤ pkg-config --modversion gtkmm-3.0
3.10.0

dvzrv commented on 2014-01-24 09:07

@imaweasel: hm, that is very odd. Your makepkg is still complaining about gtkmm3 missing and is not doing subsequent tests. Are you sure things like pkg-config are installed? What does 'pkg-config --modversion gtkmm-3.0' say?

imaweasal commented on 2014-01-24 02:35

@david.runge:
Reinstalled glib2. base-devel, and gtkmm3 (again); makepkg fails as well:
http://pastebin.com/vUjNCAN2

imaweasal commented on 2014-01-24 02:35

Reinstalled glib2. base-devel, and gtkmm3 (again); makepkg fails as well:
http://pastebin.com/vUjNCAN2

dvzrv commented on 2014-01-22 07:46

@imaweasel: please download the tarball, extract, go into the directory and execute makepkg. Post that output. Don't use packer-color.
Your previous output also suggests that there might be a problem with your glib2 package. glib.h won't be found in the includes and on top none of the subsequent tests after gtkmm3 are being executed.
You might wanna reinstall that and base-devel.

imaweasal commented on 2014-01-22 05:19

@david.runge gtkmm3 is installed, I verified that just now and attempted the build again, and it fails with the same errors.

dvzrv commented on 2014-01-19 15:32

@imaweasel: line 25 "-- package 'gtkmm-3.0' not found" (aka, you don't have gtkmm3 installed).
Use some wrapper/extension like aura. It will be much easier for you to use!

imaweasal commented on 2014-01-18 23:53

Build fails, I'm using packer-color if that makes a difference.
Here's a log:
http://pastebin.com/iNwjy9xh

dvzrv commented on 2013-12-20 12:36

@smokex: that is correct! Didn't notice, as I have it installed. Uploaded a new version.

In that regard: Anyone interested in the gtkmm2 version of grub-customizer? Otherwise I'll only provide the gtkmm3 one.

smokex commented on 2013-12-20 07:02

gtkmm needs to be changed to gtkmm3.

adoldrol commented on 2013-12-17 15:39

I had this error today while updating grub-customizer.Sorry my bad English.

make[2]: *** [CMakeFiles/grub-customizer.dir/src/Model/DeviceMap.cpp.o] Error 1
CMakeFiles/Makefile2:63: recipe for target 'CMakeFiles/grub-customizer.dir/all' failed
make[1]: *** [CMakeFiles/grub-customizer.dir/all] Error 2
Makefile:116: recipe for target 'all' failed
make: *** [all] Error 2

dvzrv commented on 2013-12-17 13:06

Version bump! Check if this works for you!
There are some major changes in functionality. I'm not yet sure about what to do with this planned addition to /etc/grub-customizer/grub.cfg yet (as there are no such grub related executables):
DEVICEMAP_FILE="/boot/grub2/device.map"
MKDEVICEMAP_CMD="grub2-mkdevicemap --device-map=/dev/stdout"

Any ideas are welcome

dvzrv commented on 2013-10-12 19:56

@ivdok: This package is not out of date. So please do not flag it.
I'm not sure yet, why the package is not building for you, but as it is for me (with latest updates), this is most likely a problem in your configuration. Make sure you have a) all dependencies installed and b) have read this: https://wiki.archlinux.org/index.php/AUR#Getting_started
On top: Are you building this for i686 with recent updates? Do you have base-devel installed?

ivdok commented on 2013-10-12 16:37

[ 68%] Building CXX object CMakeFiles/grub-customizer.dir/src/lib/Exception.cpp.o
[ 70%] Building CXX object CMakeFiles/grub-customizer.dir/src/lib/assert.cpp.o
[ 71%] Building CXX object CMakeFiles/grub-customizer.dir/src/lib/ArrayStructure.cpp.o
[ 72%] Building CXX object CMakeFiles/grub-customizer.dir/src/lib/trim.cpp.o
Linking CXX executable grub-customizer
/usr/lib/gcc/i686-pc-linux-gnu/4.8.1/../../../libgiomm-2.4.so: undefined reference to `g_file_measure_disk_usage_async'
/usr/lib/gcc/i686-pc-linux-gnu/4.8.1/../../../libgiomm-2.4.so: undefined reference to `g_file_measure_disk_usage_finish'
/usr/lib/gcc/i686-pc-linux-gnu/4.8.1/../../../libgiomm-2.4.so: undefined reference to `g_file_measure_disk_usage'
collect2: error: ld returned 1 exit status
make[2]: *** [grub-customizer] Error 1
make[1]: *** [CMakeFiles/grub-customizer.dir/all] Error 2
make: *** [all] Error 2
==> ERROR: A failure occurred in package().
Aborting...
==> ERROR: Makepkg was unable to build grub-customizer.

dvzrv commented on 2013-08-09 13:14

This is building with gtkmm 2.24.4
PKGBUILD updated, so please make sure you have that version installed now!
REPEAT: 2.24.3 will fail to build!

lobisquit commented on 2013-06-13 13:09

gtkmm version 2.24.2 can be found here:
http://arm.konnichi.com/2012/12/21/extra/os/

lobisquit commented on 2013-06-13 13:08

the package can be found in http://arm.konnichi.com/2012/12/21/extra/os/x86_64/

mikronimo commented on 2013-05-24 14:34

Ok solved; i searched (I always search in the wiki before ask) "downgrading package" but i did not reached the link you provided; thanks for your patience.

dvzrv commented on 2013-05-23 16:21

@mikronimo: It seems that I can not stress this enough: Please rtfm!
https://wiki.archlinux.org/index.php/Pacman#Skip_package_from_being_upgraded
gtkmm is not required to be of version 2.24.3 for ANY package => downgrade & ignore.

@all: Please vote for the bug on the bugtracker mentioned below to have this fixed upstream.

mikronimo commented on 2013-05-23 10:05

Yes, downgrading to gtkmm 2.24.2 solved the problem, but the system upgrade became impossible due a missing dependency (gtkmm 2.24.3 of course), so the only way is to delete grub-customizer, and when is necessary to use it, I have to install gtkmm 2.24.2, grub-customizer; made any kind of work with it, disinstall again, to avoid problem upgrading the system; it is true that not every single day I have to use the program, but it is quite complicated... for the rest it is a very good program.

Anonymous comment on 2013-05-21 13:40

I'm sorry, i didn't found that in the wiki; btw, now grub-customizer works well.

dvzrv commented on 2013-05-21 04:18

PKGBUILD updated. Dropped gksu and updated gtkmm to <=2.24.2 for the time being.

dvzrv commented on 2013-05-21 02:00

@ncristian: please refer to the excellent wiki on how to do that. It seems most people always forget about it or are too lazy to search there...
There's a whole article about downgrading (https://wiki.archlinux.org/index.php/Downgrading_Packages#Finding_your_older_version)
You might even still have that version in your pacman cache btw.

Anonymous comment on 2013-05-20 20:13

Do you know where i can find that version of gtkmm? Sorry to bother you

dvzrv commented on 2013-05-20 17:10

So far none but downgrading gtkmm to 2.24.2-2. It seems this won't break any packages relying on it.

Anonymous comment on 2013-05-20 15:17

Any news? I get this error too.

dvzrv commented on 2013-05-19 06:42

Upstream bug report: https://bugs.launchpad.net/grub-customizer/+bug/1181656

dvzrv commented on 2013-05-19 06:42

I can confirm that it fails. Have opened an upstream bug report. Will update the PKGBUILD soon.

alfplayer commented on 2013-05-18 16:40

Someone solved it downgrading to 2.24.2-2 (https://bbs.archlinux.org/viewtopic.php?id=163365).

dvzrv commented on 2013-05-16 10:46

@Voidi: Sure you have base-devel installed? Seems to be a problem with your gtkmm... which sound strange. Have you tried reinstalling it?

Anonymous comment on 2013-05-15 19:08

Got errors during the Build:
http://pastebin.com/duCafnP6
advices?

dvzrv commented on 2013-05-11 01:00

@manu79 & @jeffcasavant: I recommend reading the Arch Wiki before installing anything from the AUR.... Especially this will solve all your problems: https://wiki.archlinux.org/index.php/AUR#Getting_started

dvzrv commented on 2013-05-11 00:59

@manu79 & @jeffcasavant: I recommend reading the Arch Wiki before installing anything from the AUR.... Especially this will solve all your problems: https://wiki.archlinux.org/index.php/AUR#Getting_started

jeffcasavant commented on 2013-05-10 18:56

I second that pkg-config should be added as a dependency.

Anonymous comment on 2013-04-22 12:28

I, i have a problem with installing grub-customizer via yaourt. Below:
Building and installing package
==> ERROR: Cannot find the fakeroot binary required for building as non-root user.
==> ERROR: Cannot find the strip binary required for object file stripping.
==> ERROR: Makepkg was unable to build grub-customizer.
==> Restart building grub-customizer ? [y/N]
==> ----------------------------------------

Anyadvice? what i have to do ? I am a newebe of Arch

dvzrv commented on 2013-03-02 17:54

Sorry it took some time to update. Had to reinstall :>
Enjoy!

dvzrv commented on 2012-11-18 10:59

No. Because you should read this first, before trying to install anything from AUR: https://wiki.archlinux.org/index.php/ArchLinux_User-community_Repository_%28AUR%29#Prerequisites

Anonymous comment on 2012-11-18 09:47

Hi. You sould add pkg-config like dependency to build. If not, crash. Thanks

dvzrv commented on 2012-10-02 02:37

@luolimao: thanks for the sed tip! Highly appreciated.
I don't know how long you have been using this package, but some versions ago there was no $pkgname-$pkgver. That's why it is "bad packaging". I have been waiting for things to settle upstream and would have eventually been switching to cd to that directory. Thanks for making things clear for everyone (hopefully) and thanks for the PKGBUILD update.

luolimao commented on 2012-09-27 19:49

Your PKGBUILD doesn't need to move all the files from the $pkgname-$pkgver folder. It's not bad packaging, because it avoids any conflicting packages' files accidentally overwriting the source that you're building. Also, the sed script doesn't need to be that repetitive, because it can execute multiple regexes with the '-e' switch. Posted a simpler PKGBUILD here: https://gist.github.com/3796069

dvzrv commented on 2012-09-08 15:53

Thanks in return and updated.
Be aware that this version is different in functionality than the one before!

xzy3186 commented on 2012-09-08 14:14

3.0 has been released, thanks :-)

Anonymous comment on 2012-06-29 17:11

Yeah I was sort of thinking that the problem might be at my end, especially since no on else has had problem. I'm going to have a look over the weekend. I more just wanted to check I'd not had a brain fart and missed anything silly!! Thanks. Oh I'm just using cower and makepkg.

dvzrv commented on 2012-06-29 08:53

@sausageandeggs: sorry for the late reply. have been on the road.
The lines are there, because two or three versions ago upstream changed the way of packing their source (now: subdir with pkgname-pkgver dir in it; before: everything in parent dir). I wasn't too sure if they'd change it back or anything. Therefore I tried fixing it with this.
Anyhow, it's strange that it breaks, because it builds fine here (tried several times). Are you using yaourt or unpacking, running makepkg? Are your directory permissions correct (make in /tmp), the mv error sounds like a permission problem.
btw: please look inside the package that you created and make sure everything is put to the right place now

Anonymous comment on 2012-06-25 23:39

I don't get why these lines are needed:

if [[ -d "${pkgname}-${pkgver}" ]]; then
msg "Fixing bad packaging..."
mv ${pkgname}-${pkgver}/* .
fi

It stops the build for me with:

==> Starting build()...
==> Fixing bad packaging...
mv: cannot move ‘grub-customizer-2.5.7/misc’ to ‘./misc’: Directory not empty
mv: cannot move ‘grub-customizer-2.5.7/src’ to ‘./src’: Directory not empty
mv: cannot move ‘grub-customizer-2.5.7/translation’ to ‘./translation’: Directory not empty
==> ERROR: A failure occurred in build().
Aborting...

But it builds and runs fine for me without them. Am I missing something?

dvzrv commented on 2012-05-12 17:15

Updated to 2.5.6 with a fix for the bad upstream packaging (subfolder in source).

@sausageandeggs: thanks for the tip! Highly appreciated :)

dvzrv commented on 2012-05-12 17:08

Updated to 2.5.6 with a fix for the bad upstream packaging (subfolder in source).

@sausageandeggs: thanks for the tip! Highly appreciated :)

Anonymous comment on 2012-05-12 14:39

If you change line 25 of the PKGBUILD to

cmake -DCMAKE_INSTALL_PREFIX=/usr .&& make

it installs to /usr and you can get rid of the 'converting pkg' section.

dvzrv commented on 2012-05-05 17:11

@Gen2ly: hm, I don't think it's a packaging problem though. I had similar issues when using proxified scripts (aka. menu entries renamed by grub-customizer). That stuff gets stored in /etc/grub.d/proxifiedScripts alongside your custom confs and grub-customizer puts new entries to /etc/grub.d/ based on them.
Do you have a /etc/grub.d/bin folder? That's where grub-customizer allegedly puts the proxy config.

What I have done: Renamed my grub menu entries to my liking in my custom config files in /etc/grub.d/.
I deleted the folders created by grub-customizer in /etc/grub.d.
I deleted all files not belonging to grub2 from /boot/grub/
I reinstalled grub2 to the MBR/partition (because the newer versions of grub2 require some subfolders in /boot/grub to be present that will only get there by reinstalling) -> look that up in the forums/wiki

Anyhow, after doing this the troubles went away. Not using proxified scripts at the moment though. For further questions on how to use the program please ask upstream: https://answers.launchpad.net/grub-customizer

Gently commented on 2012-05-04 14:36

Hmm, still problems. When I go to save, I get this:

"Proxy binary not found!

You will see all entries (uncustomized) when you
run grub. This accurs (in most cases), when
you didn't install grub gustomizer correctly."

dvzrv commented on 2012-04-11 22:36

updated.

@vladi: check if you have all makedepends and depends installed. If it doesn't work, try using yaourt for interfacing AUR instead of packer.
I've had no troubles building this with makepkg. If you have further troubles with the new version, pastebin your whole build output.

Anonymous comment on 2012-04-05 20:42

I got this
/tmp/packerbuild-1000/grub-customizer/grub-customizer/src/src/model/proxy.cpp: In member function ‘bool Proxy::deleteFile()’:
/tmp/packerbuild-1000/grub-customizer/grub-customizer/src/src/model/proxy.cpp:300:45: error: ‘unlink’ was not declared in this scope
make[2]: *** [CMakeFiles/grub-customizer.dir/src/model/proxy.cpp.o] Error 1
make[1]: *** [CMakeFiles/grub-customizer.dir/all] Error 2
make: *** [all] Error 2

Any ideea why?

dvzrv commented on 2012-02-07 23:36

adopted package, updated to 2.5.3

Anonymous comment on 2011-12-01 08:41

I'm no longer runing Arch atm, so I will Disown my packages. Editing 70 to 129 in the PKGBUILD should force the installer to pull the latest version from launchpad though. Good luck with it!

Anonymous comment on 2011-11-30 22:31

I've reinstalled for some reason, and now the package version is grub-customizer 129-1 (2.4.1). An update will be great. Thanks.

Yaro commented on 2011-04-04 06:54

fbsplash or alternate runlevel users BE CAREFUL. This thing will gut your kernel command line and replace it with what *it* thinks is the correct one without even giving you the option to not have it do that.

I'm hit with both, and will have to fix my computer tomorrow: fbsplash cannot work without a set console or the kernel command line telling it what theme to use (This tool won't keep those.) And I have my default runlevel at 6 and my BURG entries defining different runlevels themselves (So that when I'm done in single mode, my system will reboot and apply its changes in full instead of potentially hazardously plodding forward into whatever the defult run is.) Again, it doesn't save this.

Not to say this is a bad tool. It made changing some of the more difficult options in burg.cfg that aren't even documented. But I strongly recommend once you're done with this tool, by the Gods, VERIFY THE SANITY OF YOUR BOOT CONFIGURATION.

Anonymous comment on 2011-03-12 06:07

I had the same thing as fabioamd87 happen. The link in the Gnome main menu tries to run:

'su-to-root -X -c grub-customizer'

I just changed it in alacarte to:

'gksu grub-customizer'

now it works fine.

Anonymous comment on 2011-01-31 18:41

Hmm, what do you mean with that?
The application runs fine for me, can you run it by just launching from terminal?

Fabioamd87 commented on 2011-01-31 18:16

in gnome menu, the command: su-to-root -X -c

doesn't work.

Anonymous comment on 2011-01-15 14:07

updated.

Anonymous comment on 2011-01-14 19:53

'gtkmm' should be added to depends list

Anonymous comment on 2011-01-14 19:52

'gtkmm' should be added to depends list

Anonymous comment on 2011-01-09 07:09

/tmp/yaourt-tmp-nick/aur-grub-customizer/src/grub-customizer/src/grubconf_ui_gtk.h:3:19: фатальная ошибка: gtkmm.h: Нет такого файла или каталога
Компиляция прервана.

Anonymous comment on 2010-11-30 10:17

This second PKGBUILD should be better. Any suggestions, please.

arriagga commented on 2010-11-30 02:35

the binary should be on "/usr/bin" not "/usr/local/bin".

try to read the Packaging Standards on: https://wiki.archlinux.org/index.php/Arch_Packaging_Standards.
that can help you a lot.

arriagga commented on 2010-11-30 02:34

the binary should be on "/usr/bin" not "/usr/local".

try to read the Packaging Standards on: https://wiki.archlinux.org/index.php/Arch_Packaging_Standards.
that can help you a lot.

arriagga commented on 2010-11-30 02:34

the binary should be on "/usr/bin" not "/usr/local".

try to read the Packaging Standards on: https://wiki.archlinux.org/index.php/Arch_Packaging_Standards.
that can help you a lot.

Anonymous comment on 2010-11-30 00:11

This is my first PKGBUILD. Used the burg-bzr PKGBUILD together with https://answers.launchpad.net/grub-customizer/+faq/1397 to create it. Works fine on my system, please leave some feedback.