Package Details: grub-legacy 0.97-25

Git Clone URL: https://aur.archlinux.org/grub-legacy.git (read-only)
Package Base: grub-legacy
Description: A GNU multiboot boot loader
Upstream URL: http://www.gnu.org/software/grub/
Licenses: GPL
Conflicts: grub
Submitter: pressh
Maintainer: ljmf00
Last Packager: ljmf00
Votes: 84
Popularity: 0.000001
First Submitted: 2012-07-20 09:42
Last Updated: 2018-10-29 22:12

Latest Comments

« First ‹ Previous 1 2 3 4 5 6

ava1ar commented on 2012-07-21 02:35

Are you building? i686 or x86_64?

fosskers commented on 2012-07-21 02:35

Now why would this be happening...:

checking for gcc... gcc
checking for gcc... (cached) gcc
checking whether the C compiler works... no
configure: error: in `/boot/grub-legacy-1862/grub-legacy/src/grub-0.97':
configure: error: C compiler cannot create executables

File permissions maybe? Typically package building occurs as non-root user, but this is attempting to build right into /boot and thus it fails?

fosskers commented on 2012-07-21 02:33

Now why would this be happening...:

checking for gcc... gcc
checking for gcc... (cached) gcc
checking whether the C compiler works... no
configure: error: in `/boot/grub-legacy-1862/grub-legacy/src/grub-0.97':
configure: error: C compiler cannot create executables

ava1ar commented on 2012-07-21 01:01

Adopted:
- PKGBUILD cleanup;
- added patch for automake issue;
- got rid of DESTARCH envvar (using CARCH)

Tested on both i686 and x86_64 architectures and seems to work fine. Please report issues here, if any.

pressh commented on 2012-07-20 10:08

Dropped from [core] and rename to grub-legacy.

Needs to be cleaned up if you adopt it (e.g. remove it being part of the base group, maybe more).

pressh commented on 2012-07-20 09:42

Dropped from [core] and rename to grub-legacy.