Package Details: grub-libzfs 2:2.06-2

Git Clone URL: https://aur.archlinux.org/grub-libzfs.git (read-only, click to copy)
Package Base: grub-libzfs
Description: GNU GRand Unified Bootloader (2) - libzfs support
Upstream URL: https://www.gnu.org/software/grub/
Licenses: GPL3
Conflicts: grub, grub-bios, grub-common, grub-efi-x86_64, grub-emu, grub-legacy
Provides: grub, grub-bios, grub-common, grub-efi-x86_64, grub-emu
Replaces: grub, grub-bios, grub-common, grub-efi-x86_64, grub-emu
Submitter: chungy
Maintainer: chungy
Last Packager: chungy
Votes: 2
Popularity: 0.000000
First Submitted: 2017-08-31 19:29 (UTC)
Last Updated: 2021-12-04 21:55 (UTC)

Required by (147)

Sources (7)

Latest Comments

codyps commented on 2021-02-15 02:18 (UTC)

It appears that this is broken due to https://git.savannah.gnu.org/gitweb/?p=grub.git;a=commit;h=6643507ce30f775008e093580f0c9499dfb2c485 with current gcc.

codyps commented on 2019-01-28 16:36 (UTC)

Build failure due to lack of freetype-config:

checking for freetype-config... no
configure: error: grub-mkfont was explicitly requested but can't be compiled (need freetype2 library)
==> ERROR: A failure occurred in build().
    Aborting...
Error making: grub-libzfs

As far as I can tell, freetype-config no longer exists. may need to pass some options to grub to configure it.

Alternately, upstream grub commit 7e23437df3ad7572756102f3ab1063f284b57983 ("build: Use pkg-config to find FreeType") may be backported.

chungy commented on 2017-11-17 00:17 (UTC)

Both those packages are part of base-devel, it is not required for a PKGBUILD to explicitly depend on those. Please install that group :)

codyps commented on 2017-11-15 04:35 (UTC)

Missing build deps: bison, flex ``` checking for cmp... cmp checking for bison... no configure: error: bison is not found ==> ERROR: A failure occurred in build(). Aborting... ``` ``` checking for bison... (cached) bison checking whether make sets $(MAKE)... (cached) yes checking whether ln -s works... yes configure: error: flex is not found ==> ERROR: A failure occurred in build(). Aborting... :: failed to build grub-libzfs package(s) ```

chungy commented on 2017-08-31 19:33 (UTC)

Note that this package primarily benefits grub-install support. It does not add new features to GRUB at the boot time -- unsupported zpool features in the standard 'grub' package will remain unsupported here!