Package Details: grub-theme-lenovo 3.3-1

Git Clone URL: https://aur.archlinux.org/distro-grub-themes.git (read-only, click to copy)
Package Base: distro-grub-themes
Description: Theme for Grub2
Upstream URL: https://github.com/ahmedmoselhi/distro-grub-themes
Keywords: arch grub themes
Licenses: GPL, CCPL:by-sa
Submitter: ahmedmoselhi
Maintainer: ahmedmoselhi
Last Packager: ahmedmoselhi
Votes: 5
Popularity: 0.89
First Submitted: 2023-02-02 19:42 (UTC)
Last Updated: 2023-11-20 11:52 (UTC)

Sources (58)

Latest Comments

flygoat commented on 2024-01-10 13:08 (UTC)

Hi, There are some new upstream variants such as Asus ROG and Asus TUF. Do you mind packing them as well? Thanks.

ahmedmoselhi commented on 2023-11-22 11:53 (UTC)

@risto3 could be network issue , for me it builds and installed fine

risto3 commented on 2023-11-20 13:49 (UTC)

When updating aur/grub-theme-endeavouros 3.2-1 -> 3.3-1, I get the following:

...
==> Making package: distro-grub-themes 3.3-1 (Mon Nov 20 14:42:30 2023)
==> Retrieving sources...
...
==> WARNING: Skipping verification of source file PGP signatures.
==> Validating source files with sha256sums...
    grub-theme-acer.tar ... FAILED
...
    grub-theme-endeavouros.tar ... FAILED
...
==> ERROR: One or more files did not pass the validity check!
...
:: (1/1) Parsing SRCINFO: distro-grub-themes
==> Making package: distro-grub-themes 3.3-1 (Mon Nov 20 14:42:54 2023)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
...
==> Validating source files with sha256sums...
    grub-theme-acer.tar ... FAILED
...
    grub-theme-endeavouros.tar ... FAILED
...
==> ERROR: One or more files did not pass the validity check!
 -> error making: distro-grub-themes-exit status 1
 -> Failed to install the following packages. Manual intervention is required:
grub-theme-endeavouros - exit status 1

Appears that updpkgsums should be run on the package after bumping the revision prior to committing.

berkersal commented on 2023-03-26 11:59 (UTC)

Yeah, it is a bit annoying to install all of the packages, what is the purpose of having multiple packages then?

beast64 commented on 2023-02-15 06:56 (UTC) (edited on 2023-02-15 06:57 (UTC) by beast64)

There has been a typo on the source function

"grub-theme-mint.tar::https://github.com/AdisonCavani/distro-grub-themes/releases/download/v${pkgver}/acer.tar"
"grub-theme-msi.tar::https://github.com/AdisonCavani/distro-grub-themes/releases/download/v${pkgver}/mint.tar"
"grub-theme-mx.tar::https://github.com/AdisonCavani/distro-grub-themes/releases/download/v${pkgver}/msi.tar"

Further note, I would like you to change the way these packages are running, instead of downloading all of it tar packages, why don't you just download the one that matches the name of this AUR package, then the installation time will improve significantly. This small typo I think it also applies to other grub-theme-<prefix> AUR packages