Package Details: gst-plugins-bad-git 1.19.2.r93557.g2200a3dbcd-1

Git Clone URL: https://aur.archlinux.org/gst-plugins-bad-git.git (read-only, click to copy)
Package Base: gst-plugins-bad-git
Description: GStreamer Multimedia Framework Bad Plugins
Upstream URL: http://gstreamer.freedesktop.org/
Keywords: glib opengl streaming video
Licenses: LGPL
Conflicts: gst-plugins-bad, gst-plugins-bad-libs, gst-plugins-gl
Provides: gst-plugins-bad
Submitter: lubosz
Maintainer: SolarAquarion
Last Packager: SolarAquarion
Votes: 4
Popularity: 0.000019
First Submitted: 2013-04-09 19:29 (UTC)
Last Updated: 2021-10-11 15:34 (UTC)

Required by (190)

Sources (1)

Latest Comments

Samega7Cattac commented on 2021-09-24 22:04 (UTC)

Run-time dependency storage_client found: NO (tried pkgconfig and cmake)

gst-plugins-bad/ext/gs/meson.build:8:0: ERROR: Dependency "storage_client" not found, tried pkgconfig and cmake

Samega7Cattac commented on 2021-09-24 22:03 (UTC)

both packages have a -git

Samega7Cattac commented on 2021-09-15 11:26 (UTC)

libopenaptx and dssim packages are missing.

piussj2 commented on 2021-08-23 23:12 (UTC)

I got:

Checking for function "gme_enable_accuracy" with dependency -lgme: YES Run-time dependency storage_client found: NO (tried pkgconfig and cmake)

gst-plugins-bad/ext/gs/meson.build:8:0: ERROR: Dependency "storage_client" not found, tried pkgconfig and cmake

A full log can be found at /home/piu/gst-plugins-bad/repos/extra-x86_64/src/build/meson-logs/meson-log.txt

Atraii commented on 2021-02-10 17:32 (UTC)

Should this conflict with gst-plugins-bad-libs? Pacman is showing that files already exist in the filesystem owned by gst-plugins-bad-libs.

kode54 commented on 2021-01-30 07:39 (UTC)

This package needs several changes with more recent versions of the source repository:

Add libldac and libopenaptx to the dependencies.

Disable several plugins that require unmet dependencies, or somehow track down and package the libraries for them all:

-Dmagicleap=disabled -Dwasapi2=disabled - Why doesn't this automatically disable itself on Linux?? -Disac=disabled

Samega7Cattac commented on 2020-08-11 18:25 (UTC)

gst-plugins-bad/sys/magicleap/meson.build:7:0: ERROR: C library 'ml_audio' not found

orestisf commented on 2017-06-18 18:54 (UTC)

Fixed

Tom_B commented on 2017-03-20 18:12 (UTC)

This causes an error "Source should be an array" PKGBUILD needs changing: -source='git+git://anongit.freedesktop.org/gstreamer/gst-plugins-bad' +source=('git+git://anongit.freedesktop.org/gstreamer/gst-plugins-bad')

J5lx commented on 2015-07-12 14:48 (UTC)

This needs gtk-doc to build.

evanpurkhiser commented on 2015-06-21 09:21 (UTC)

This is also missing rtmpdump as a dependency.

evanpurkhiser commented on 2015-06-21 07:29 (UTC)

It appears this needs glu now to build. Also seems to be missing gtk-doc as a makedeps.

stevenvdb commented on 2014-07-01 21:11 (UTC)

is it just me or does this need glu to build now?

ewtoombs commented on 2014-04-16 06:25 (UTC)

@quequotion: That's changed now. It compiles fine with the provided flags, but gtkdoc fails. Add --disable-gtk-doc to skip this step, and it will get packaged.

quequotion commented on 2014-04-04 11:06 (UTC)

gstreamer-egl depends on mesa's libEGL, which cannot be installed alongside nvidia's. If you're using nvidia's proprietary driver, you'll have to add --with-egl-window-system=none to autogen.sh's command line.