Package Details: gst-plugins-pulseeffects-legacy-git 4.8.5.r1.g4ec1f83b-2

Git Clone URL: https://aur.archlinux.org/pulseeffects-legacy-git.git (read-only, click to copy)
Package Base: pulseeffects-legacy-git
Description: Audio Effects for Pulseaudio applications - gstreamer plugins
Upstream URL: https://github.com/wwmm/easyeffects
Licenses: GPL3
Conflicts: gst-plugins-pulseeffects, gst-plugins-pulseeffects-legacy
Provides: gst-plugins-pulseeffects, gst-plugins-pulseeffects-legacy, libgstpeadapter.so, libgstpeautogain.so, libgstpeconvolver.so, libgstpecrystalizer.so, libgstpernnoise.so
Submitter: yochananmarqos
Maintainer: None
Last Packager: yochananmarqos
Votes: 7
Popularity: 0.000884
First Submitted: 2021-01-23 17:16 (UTC)
Last Updated: 2021-09-14 15:16 (UTC)

Pinned Comments

yochananmarqos commented on 2021-02-03 22:36 (UTC) (edited on 2021-02-04 01:11 (UTC) by yochananmarqos)

This is the last release supporting Pulseaudio. The following PulseEffects releases will be based on the new Pipewire multimedia server and only fixes to critical bugs will be backported to the legacy pulseaudio branch.

Known issues:

  • Currently none

Latest Comments

1 2 3 Next › Last »

bertieb commented on 2022-06-10 11:34 (UTC)

4.8.7 solves the below glib GIO error :)

(pulseeffects:887854): GLib-GIO-ERROR **: 12:08:46.939: The schema default value for key 'mode' in schema 'com.github.wwmm.pulseeffects.compressor' was rejected by the binding mapping function.
Trace/breakpoint trap (core dumped)

hrehfeld commented on 2022-04-17 12:05 (UTC)

To build, I had to get rid of 'gst-plugins-pulseeffects-legacy' in https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=pulseeffects-legacy-git#n46

abner commented on 2022-01-03 05:45 (UTC)

I'm getting an error, even though meson is installed. Anyone had this as well?

Traceback (most recent call last):
  File "/usr/bin/meson", line 33, in <module>
    sys.exit(load_entry_point('meson==0.60.3', 'console_scripts', 'meson')())
  File "/usr/bin/meson", line 22, in importlib_load_entry_point
    for entry_point in distribution(dist_name).entry_points
  File "/usr/lib/python3.9/importlib/metadata.py", line 524, in distribution
    return Distribution.from_name(distribution_name)
  File "/usr/lib/python3.9/importlib/metadata.py", line 187, in from_name
    raise PackageNotFoundError(name)
importlib.metadata.PackageNotFoundError: meson

yochananmarqos commented on 2021-07-05 15:09 (UTC)

@pjag: Try adding this line in the check() function and let me know if works:

export ENV LANG en_US.utf8

pjag commented on 2021-07-05 11:51 (UTC) (edited on 2021-07-05 11:53 (UTC) by pjag)

@yochananmarqos Probably should have mentioned my locale:

`$ locale

LANG=pl_PL.UTF-8

LC_CTYPE="pl_PL.UTF-8"

LC_NUMERIC="pl_PL.UTF-8"

LC_TIME="pl_PL.UTF-8"

LC_COLLATE="pl_PL.UTF-8"

LC_MONETARY="pl_PL.UTF-8"

LC_MESSAGES="pl_PL.UTF-8"

LC_PAPER="pl_PL.UTF-8"

LC_NAME="pl_PL.UTF-8"

LC_ADDRESS="pl_PL.UTF-8"

LC_TELEPHONE="pl_PL.UTF-8"

LC_MEASUREMENT="pl_PL.UTF-8"

LC_IDENTIFICATION="pl_PL.UTF-8"

LC_ALL= `

I think that must be clearly it since that's why "compressor" is translated and hence too short, but other than that I don't know. As a workaround I just removed the check from PKGBUILD.

yochananmarqos commented on 2021-07-04 14:30 (UTC)

@pjag: I can't reproduce that in a clean chroot.

pjag commented on 2021-07-04 12:34 (UTC) (edited on 2021-07-04 12:35 (UTC) by pjag)

Building the package fails for me now on the "check" step:

"data/com.github.wwmm.pulseeffects.appdata.xml: FAILED: • style-invalid : <caption> is too short [Kompresor];shortest allowed is 10 chars "

which is probably related to locale or something... an overzealous check anyway.

yochananmarqos commented on 2021-02-04 17:51 (UTC)

@maxpayne3: rnnoise-git already provides and conflicts with rnnoise.

maxpayne3 commented on 2021-02-04 17:36 (UTC) (edited on 2021-02-04 17:37 (UTC) by maxpayne3)

Okay, I resolved my issue. It was something related to dconf. Anyway I think it's better to stay on upstream rnnoise like other plugins. Who want rnnoise-git can still install it listing rnnoise in conflict/provide variable of rnnoise-git PKGBUILD (just like zam-plugins-git, calf-git, etc).

yochananmarqos commented on 2021-02-04 16:29 (UTC)

@maxpayne3: Yes, I tested it.