Package Details: gstm 1.3.3-3

Git Clone URL: https://aur.archlinux.org/gstm.git (read-only)
Package Base: gstm
Description: Gnome SSH Tunnel Manager - Gtk3 Edition
Upstream URL: https://github.com/dallenwilson/gstm
Licenses: GPL
Submitter: jhenson
Maintainer: jvybihal
Last Packager: jvybihal
Votes: 5
Popularity: 0.000418
First Submitted: 2015-08-18 22:28
Last Updated: 2019-04-30 13:14

Latest Comments

roti commented on 2019-04-30 06:44

Thank you for the update. One note: you can also remove the libgnomeui dependency.

jvybihal commented on 2019-04-26 06:59

I have updated to the new GTK3 version suggested by @roti (thanks!). The GUI is little messy, but app as a whole works. I will later add gstm-gtk2 package for those wanting to keep old version.

roti commented on 2019-04-25 20:31

Please update gstm to the gtk3 fork from here: https://github.com/dallenwilson/gstm/releases/tag/1.3.3 It works great, without any gtk2 dependency.

jchatard commented on 2017-11-30 11:25

I'm seeing the same behaviour:

(gdb) run
Starting program: /usr/bin/gstm
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff63229d6 in g_type_check_instance_cast () from /usr/lib/libgobject-2.0.so.0
(gdb)

Anyone aware of an alternative?

Thanks,
Jérémy

trajan commented on 2017-09-08 17:04

Thanks for responding. It happens on start. I never see any GUI, just the crash information in the log.

I see the same ouput as you for libgobject query.

BTW, It does work fine for me on a Ubuntu 16.04 install. Just not on Arch. I am assuming there is another dependency that I am missing.

Regards

jvybihal commented on 2017-09-06 06:28

I use it daily. I do not have this problem. Does it happen on start, or some specific situation?

# pacman -Qo /usr/lib/libgobject-2.0.so.0.5200.3
/usr/lib/libgobject-2.0.so.0.5200.3 is owned by glib2 2.52.3-1

trajan commented on 2017-09-05 14:57

Hello, I am seeing this crash on two recent installs of Arch.

[ 594.398768] gstm[1468]: segfault at 19953120 ip 00007fce137015a6 sp 00007ffee4a538a0 error 4 in libgobject-2.0.so.0.5200.3[7fce136cc000+51000]

Anybody have it working?

Thanks

jvybihal commented on 2017-03-12 08:27

Good point. Does not hurt to have it as dependency.

davepb commented on 2017-03-11 06:17

Should openssh should be added as a dependency?

I forgot to install it on a fresh install of Arch and kept getting an "Unknown error: 65280" every time I tried to connect with gSTM.

Thanks for maintaining.



jvybihal commented on 2017-02-23 15:22

I use it, so I guess I will adopt this package and see how it goes. Does not seems like it needs alot maintaining.