Package Details: gstreamer0.10-good 0.10.31-29

Git Clone URL: https://aur.archlinux.org/gstreamer0.10-good.git (read-only)
Package Base: gstreamer0.10-good
Description: GStreamer Multimedia Framework Good plugin libraries
Upstream URL: https://github.com/triceratops1/gstreamer0
Licenses: LGPL
Submitter: yurikoles
Maintainer: kirillnow
Last Packager: kirillnow
Votes: 34
Popularity: 1.300883
First Submitted: 2017-01-26 13:56
Last Updated: 2017-11-18 09:39

Latest Comments

gdea73 commented on 2018-02-08 06:35

I recently struggled with getting this to build, along with gstreamer0.10-ffmpeg and gstreamer0.10-bad. They compiled without issue on one system (ThinkPad T440p), but I was getting the GST_VERSION_MAJOR error as described by thebonaestest below on two other (more recently installed) Arch systems.

It turns out the bizarre discrepancy was that I had gstreamer0.10-0.10.36-4-x86_64 installed (from 2014!) on the ThinkPad when I built these packages. The older version of gstreamer (and gstreamer-base) were formerly in the official repositories, and can be found at (https://archive.archlinux.org/packages/g/).

On the two more recent systems, I deliberately installed the old GStreamer from 2014 and was able to install the good, bad, and ffmpeg additions. Then I installed the newest available gstreamer0.10 and gstreamer0.10-base from the AUR only after the former had completed.

(I went through the trouble mainly because I need to use the Processing video library, and it still only supports gstreamer0.10 (officially), though I noticed after it was too late that there was a commit merged into its master branch a couple of months ago adding gst1 support. If anyone encounters this issue, it may be worth pulling down the source for Processing and its video library in order to just use gst1.)

bidulock commented on 2017-12-21 17:32

Need to add python to makedepends to build in chroot.

kirillnow commented on 2017-11-18 09:45

Fixed

thebonaestest commented on 2017-11-08 04:20

This fails to build for me (Antergos, kernel version 4.13.11-1).
It gives a long string of errors starting with:

make[3]: Entering directory '/tmp/yaourt-tmp/aur-gstreamer0.10-good/src/gst-plugins-good/gst/videofilter'
CC libgstvideofilter_la-plugin.lo
In file included from /usr/include/gstreamer-0.10/gst/gst.h:32:0,
from plugin.c:24:
/usr/include/gstreamer-0.10/gst/gstversion.h:63:27: error: expected declaration specifiers or ‘...’ before ‘(’ token
#define GST_VERSION_MAJOR (0)

The issue appears to be errors in the source for each plugin - the GST_PLUGIN_DEFINE macro is not called correctly in any of them. I was able to get it to build by fixing the call in each individual plugin.

Has anyone else experienced this problem? If so, I can push my changes upstream.

Alad commented on 2017-10-27 18:17

spease, simple - you adopt and fix it.

spease commented on 2017-08-22 03:34

This is still broken and it's apparently been a few months. How can the situation be rectified?

Bachsau commented on 2017-05-27 18:39

Is there an easy way to change this in an active database of installed packages or will I need to uninstall the whole thing and all its dependencies just to change the PKGBUILD and reinstall?

dreieck commented on 2017-05-16 11:59

new upstream version of package 'extra/libsoup' does not provide anymore 'libsoup-gnome'. Consider changing the dependency 'libsoup-gnome' to 'libsoup'.

Bachsau commented on 2017-05-13 21:11

Still no fire-and-forget command for this libsoup thing? Currently, I don't have time to figure out whats going on.

krnl0138 commented on 2017-05-12 13:23

@hamelg just did pacman -Rdd the whole gstreamer & libsoup and it works fine after reinstall, idk what it was w/ compilator, thanks for help

All comments