Package Details: gsview 4.9-12

Git Clone URL: https://aur.archlinux.org/gsview.git (read-only)
Package Base: gsview
Description: A nice looking GUI for ghostscript with some extraction features
Upstream URL: http://pages.cs.wisc.edu/~ghost/gsview/get49.htm
Licenses: custom:Aladdin Free Public License
Submitter: ConnorBehan
Maintainer: ConnorBehan
Last Packager: ConnorBehan
Votes: 56
Popularity: 0.858479
First Submitted: 2007-09-09 01:29
Last Updated: 2016-04-28 17:35

Dependencies (2)

Required by (0)

Sources (2)

Latest Comments

haawda commented on 2015-10-07 18:57

Builds fine here, but only after rebuilding and installing glib and gtk. Without so, I get the same error.

jpaechnatz commented on 2015-10-07 05:41

Does not build, I get multiple of these errors:

./obj/gvcdisp.o: In function `g_bit_nth_lsf':
/usr/include/glib-1.2/glib.h:1581: multiple definition of `g_bit_nth_lsf'
./obj/gvcmisc.o:/usr/include/glib-1.2/glib.h:1581: first defined here
./obj/gvcdisp.o: In function `g_bit_nth_msf':
/usr/include/glib-1.2/glib.h:1599: multiple definition of `g_bit_nth_msf'
./obj/gvcmisc.o:/usr/include/glib-1.2/glib.h:1599: first defined here
./obj/gvcdisp.o: In function `g_bit_storage':
/usr/include/glib-1.2/glib.h:1618: multiple definition of `g_bit_storage'
./obj/gvcmisc.o:/usr/include/glib-1.2/glib.h:1618: first defined here
./obj/gvccmd.o: In function `g_bit_nth_lsf':
/usr/include/glib-1.2/glib.h:1581: multiple definition of `g_bit_nth_lsf'
./obj/gvcmisc.o:/usr/include/glib-1.2/glib.h:1581: first defined here

GreenRaccoon23 commented on 2015-09-25 13:57

It looks like the source url on fossies changed. I had to use this one: http://fossies.org/unix/misc/old/ghost/ghostgum/${pkgname}-${pkgver}.tar.gz

aksr commented on 2012-08-30 07:17

@jpaechnatz:
Yes, you're right:
source=(http://fossies.org/unix/misc/ghost/ghostgum/${pkgname}-${pkgver}.tar.gz ${pkgname}.desktop)
@ConnorBehan:
I would put both urls. One commented, of course.

jpaechnatz commented on 2012-08-30 05:54

Working URL:
http://fossies.org/unix/misc/ghost/ghostgum/

aksr commented on 2012-08-28 03:52

@ConnorBehan:
Please change line 24:
from:
install -Dm644 "$srcdir"/$pkgname-$pkgver/srcunx/gsview.1 "$pkgdir"/usr/man/man1/gsview.1
to:
install -Dm644 "$srcdir"/$pkgname-$pkgver/srcunx/gsview.1 "$pkgdir"/usr/share/man/man1/gsview.1
Thank you.

aksr commented on 2012-08-28 03:51

@ConnorBehan:
Please change line 24 to:
from:
install -Dm644 "$srcdir"/$pkgname-$pkgver/srcunx/gsview.1 "$pkgdir"/usr/man/man1/gsview.1
to:
install -Dm644 "$srcdir"/$pkgname-$pkgver/srcunx/gsview.1 "$pkgdir"/usr/share/man/man1/gsview.1
Thank you.

ConnorBehan commented on 2012-05-18 01:23

They work for me. Please explain the specific error you're getting.

Anonymous comment on 2012-05-17 12:28

Flagged out of date since upstream sources do not work.

ConnorBehan commented on 2012-03-16 02:29

Gsview 5.0 is not for Linux yet.

All comments