Package Details: gtk-engine-murrine-git 0.98.2.r408.f96e446-1

Git Clone URL: https://aur.archlinux.org/gtk-engine-murrine-git.git (read-only, click to copy)
Package Base: gtk-engine-murrine-git
Description: The marvelous gtk2 cairo engine (development version)
Upstream URL: http://cimitan.com/murrine/
Licenses: LGPL3
Conflicts: gtk-engine-murrine
Provides: gtk-engine-murrine
Submitter: None
Maintainer: carstene1ns
Last Packager: carstene1ns
Votes: 264
Popularity: 0.000025
First Submitted: 2009-04-17 18:46 (UTC)
Last Updated: 2018-11-22 19:11 (UTC)

Required by (247)

Sources (2)

Latest Comments

carstene1ns commented on 2018-11-22 19:11 (UTC)

RemoteAdmin: URL updated, thank you!

RemoteAdmin commented on 2018-10-13 05:51 (UTC)

Source is not available anymore. Alternative would be https://github.com/GNOME/murrine

paulsinnett commented on 2018-04-09 08:07 (UTC)

Now requires automake 1.7.x to build

artemh commented on 2016-02-03 20:51 (UTC)

Updated for automake-1.15: newer-automakes.patch: http://pastebin.com/psX9Q0jd PKGBUILD: http://pastebin.com/CYx0c4Ku

carstene1ns commented on 2014-10-10 19:51 (UTC)

Package adopted and fixed.

Dasonk commented on 2014-10-05 23:59 (UTC)

You should add git as a make dependency

juancate commented on 2013-12-15 05:34 (UTC)

fro_ozen, the files I put work. You just have to copy them and if the checksum fails you just must replace it for its correct value.

fro_ozen commented on 2013-12-14 17:50 (UTC)

I am having troubles installing this. Please look at my post in the forums for further information: https://bbs.archlinux.org/viewtopic.php?pid=1360185#p1360185

Tjuh commented on 2013-11-23 16:00 (UTC)

Worked like a charm! Thank you.

juancate commented on 2013-11-23 00:57 (UTC)

I solved the error that stackptr described by adding a patch for automake-1.14 just like the other two patches and adding it to the PKGBUILD. Here is a copy of these files: automake-1.14.patch : http://pastebin.com/D5anhe8v PKGBUILD : http://pastebin.com/ngMW8v53

kevincox commented on 2013-08-21 18:43 (UTC)

I get the same error as stackptr. Apparently AM_DISABLE_STATIC is a depreciated alias for AC_DISABLE_STATIC however I don't know why that would cause a failure.

stackptr commented on 2013-07-30 17:41 (UTC)

Same error as sotokoya. Installing automake-1.7 from AUR allows me to get past that error, only to get a build error: checking for a BSD-compatible install... /usr/bin/install -c checking whether make sets $(MAKE)... yes ./configure: line 2702: AM_DISABLE_STATIC: command not found ./configure: line 2703: AC_LIBTOOL_WIN32_DLL: command not found ./configure: line 2704: AM_PROG_LIBTOOL: command not found ./configure: line 2706: syntax error near unexpected token `0.37.1' ./configure: line 2706: `AC_PROG_INTLTOOL(0.37.1)' ==> ERROR: A failure occurred in build(). Aborting... The build failed.

commented on 2013-06-30 00:04 (UTC)

-> Starting build... You must have automake 1.7.x installed to compile . Install the appropriate package for your distribution, or get the source tarball at http://ftp.gnu.org/gnu/automake/

aphanic commented on 2013-06-02 11:46 (UTC)

Hi Jristz, I've updated the package to reflect pacman 4.1 source arrays and version schemes and added a patch for automake 1.13. It should build without errors now.

commented on 2013-06-01 18:33 (UTC)

-> Patching... patching file autogen.sh -> Starting build... You must have automake 1.7.x installed to compile . Install the appropriate package for your distribution, or get the source tarball at http://ftp.gnu.org/gnu/automake/ ==> ERROR

KaiSforza commented on 2013-04-10 21:45 (UTC)

This should be updated to reflect the new pacman 4.1 source array and version scheme.

commented on 2013-02-12 02:20 (UTC)

@Shiz0 Can you clarify how to apply the patch? Using it as a *.sh scripts gives syntax errors.

commented on 2012-05-04 23:08 (UTC)

Shiz0, it's not the AUR package fault, it's murrine's fault. I just reported this: https://bugzilla.gnome.org/show_bug.cgi?id=675484 Use the patch I posted and it will work :)

commented on 2012-04-28 14:24 (UTC)

Cloning into '/tmp/yaourt-tmp-shiz0/aur-gtk-engine-murrine-git/src/gtk-engine-murrine-build'... done. You must have automake 1.7.x installed to compile . Install the appropriate package for your distribution, or get the source tarball at http://ftp.gnu.org/gnu/automake/ ==> ERROR: Makepkg was unable to build gtk-engine-murrine-git. ==> Restart building gtk-engine-murrine-git ? [y/N] I have the latest automake version installed. Please, fix it.

whynothugo commented on 2012-04-05 00:49 (UTC)

Could you add "provides=('gtk-engine-murrine=0.98.1.1')", so packages that require "gtk-engine-murrine" work with this as well?

Grus commented on 2012-01-12 08:24 (UTC)

Fails with: ./configure: line 12972: syntax error near unexpected token `GTK,' ./configure: line 12972: `PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.18.0,,' ==> ERROR: A failure occurred in build().

gadget3000 commented on 2011-07-01 23:35 (UTC)

I also get the automake error but I've just installed it from [core] and it's worked fine, so the version number doesn't need to be 1.7 as specified in the error.

commented on 2011-04-01 10:48 (UTC)

Unable to reproduce.

Xaero252 commented on 2011-03-30 19:35 (UTC)

Unable to compile currently. Wants specifically automake1.7 which is unavailable in the AUR and regular repositories. You must have automake 1.7.x installed to compile . Install the appropriate package for your distribution, or get the source tarball at http://ftp.gnu.org/gnu/automake/

commented on 2011-02-26 14:09 (UTC)

are you sure you've installed gtk2?

commented on 2011-02-25 16:55 (UTC)

I try to compile this and have this error while building : In file included from ./src/animation.c:21:0: ./src/animation.h:24:21: fatal error: gtk/gtk.h: No such file or directory compilation terminated. make[1]: *** [animation.lo] Erreur 1 make[1]: quittant le répertoire « ~/builds/gtk-engine-murrine-git/gtk-engine-murrine-git/src/gtk-engine-murrine-build » make: *** [all-recursive] Erreur 1

LeCrayonVert commented on 2010-08-05 08:48 (UTC)

Each time I run yaourt --sucre, it wants to recompile gtk-engine-murrine-git...what is wrong ? (it may be related to the date in PKGBUILD)...

commented on 2010-07-26 15:23 (UTC)

thanks :) but still have a problem with metacity, not fully look like ubuntu.

ganlu commented on 2010-06-18 23:41 (UTC)

There is likely a bug of makepkg, when you use non en_US environment, you can't get 'pkgver' automatically updated to the current date saying 20100618 but stayed as of the PKGBUILD.

commented on 2010-06-18 18:45 (UTC)

Why is it flagged out of date?

commented on 2010-06-14 16:27 (UTC)

uh! ehm...ok thanks! shame on me!xD

commented on 2010-06-14 16:23 (UTC)

http://wiki.archlinux.org/index.php/AUR_User_Guidelines#Prerequisites

commented on 2010-06-14 16:12 (UTC)

I suggest to include 'autoconf' to the dependencies! Some seconds ago I'd to include it manually! :D

commented on 2010-03-26 00:40 (UTC)

It's been fixed 9 hours ago, please try it again.

commented on 2010-03-25 15:08 (UTC)

I'm trying to install this, but it fails durring compile time. This is the output I am getting as it fails. ./src/murrine_rc_style.c: In function ‘murrine_rc_style_parse’: ./src/murrine_rc_style.c:638: warning: passing argument 3 of ‘theme_parse_boolean’ from incompatible pointer type ./src/murrine_rc_style.c:242: note: expected ‘gboolean *’ but argument is of type ‘struct GtkRcStyle *’ ./src/murrine_rc_style.c:638: error: too many arguments to function ‘theme_parse_boolean’ make[1]: *** [murrine_rc_style.lo] Error 1 make[1]: Leaving directory `/tmp/yaourt-tmp-umer/aur-gtk-engine-murrine-git/gtk-engine-murrine-git/src/gtk-engine-murrine-build' make: *** [all-recursive] Error 1 ==> ERROR: Build Failed. Aborting... Error: Makepkg was unable to build gtk-engine-murrine-git package.